Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 104554 - EBuild for 389 Directory Ldap Server (fka Fedora Directory Ldap Server)
Summary: EBuild for 389 Directory Ldap Server (fka Fedora Directory Ldap Server)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Fabio Erculiani (RETIRED)
URL: http://directory.fedora.redhat.com/wi...
Whiteboard:
Keywords: EBUILD
: 128019 (view as bug list)
Depends on: 209589 309539 309541 309547 309549 309551 309553 309557 309559 309561 309567 309569 309575 309581
Blocks: 297665 309951 327649
  Show dependency tree
 
Reported: 2005-09-01 23:35 UTC by Mark
Modified: 2010-07-11 10:26 UTC (History)
23 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fedora ds 1.0 ebuild and patches (fedora-ds-1.0-20051205.tar.bz2,7.85 KB, application/octet-stream)
2005-12-10 06:25 UTC, Stefan Knoblich (RETIRED)
Details
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild (fedora-ds-adminutil-1.0.4.ebuild,1.24 KB, text/plain)
2007-02-19 15:07 UTC, mikael lammentausta
Details
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild (fedora-ds-adminutil-1.0.4.ebuild,1.68 KB, text/plain)
2007-02-19 15:50 UTC, mikael lammentausta
Details
net-nds/fedora-ds-mozilla/fedora-ds-mozilla-1.0.3.ebuild (fedora-ds-mozilla-1.0.3.ebuild,2.50 KB, text/plain)
2007-02-19 17:33 UTC, mikael lammentausta
Details
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild (fedora-ds-adminutil-1.0.4.ebuild,1.22 KB, text/plain)
2007-02-20 08:54 UTC, mikael lammentausta
Details
net-nds/fedora-ds-mozilla/fedora-ds-mozilla-1.0.3.ebuild (fedora-ds-mozilla-1.0.3.ebuild,2.89 KB, text/plain)
2007-02-22 07:12 UTC, mikael lammentausta
Details
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild (fedora-ds-adminutil-1.0.4.ebuild,1.17 KB, text/plain)
2007-02-22 07:12 UTC, mikael lammentausta
Details
net-nds/fedora-ds-setuputil/fedora-ds-setuputil-1.0.3.ebuild (fedora-ds-setuputil-1.0.3.ebuild,1.50 KB, text/plain)
2007-02-22 07:13 UTC, mikael lammentausta
Details
dev-libs/svrcore/svrcore-4.0.4.ebuild (svrcore-4.0.4.ebuild,633 bytes, text/plain)
2007-08-08 10:17 UTC, Dmitry S. Kulyabov
Details
dev-libs/mozldap/mozldap-6.0.4.ebuild (mozldap-6.0.4.ebuild,2.18 KB, text/plain)
2007-08-08 10:17 UTC, Dmitry S. Kulyabov
Details
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.1.2_pre20070808.ebuild (fedora-ds-adminutil-1.1.2_pre20070808.ebuild,1.03 KB, text/plain)
2007-08-08 10:54 UTC, Dmitry S. Kulyabov
Details
net-nds/fedora-ds/fedora-ds-1.1.0_pre20070808.ebuild (fedora-ds-1.1.0_pre20070808.ebuild,1.86 KB, text/plain)
2007-08-08 11:02 UTC, Dmitry S. Kulyabov
Details
net-nds/fedora-ds/files/fedora-ds.initd (fedora-ds.initd,2.33 KB, text/plain)
2007-08-08 11:02 UTC, Dmitry S. Kulyabov
Details
net-nds/fedora-ds/files/fedora-ds.confd (fedora-ds.confd,72 bytes, text/plain)
2007-08-08 11:03 UTC, Dmitry S. Kulyabov
Details
net-nds/fedora-ds-setuputil/fedora-ds-setuputil-1.1.0_pre20070808.ebuild (fedora-ds-setuputil-1.1.0_pre20070808.ebuild,1.03 KB, text/plain)
2007-08-08 11:15 UTC, Dmitry S. Kulyabov
Details
fixed fedora-ds-base ebuild from svn (fedora-ds-base-1.1.1.ebuild,1.99 KB, text/plain)
2008-08-18 16:12 UTC, Vladimir Rusinov
Details
added missing dependencies (fedora-ds-admin-1.1.5.ebuild,2.18 KB, text/plain)
2008-08-18 17:49 UTC, Vladimir Rusinov
Details
version bump (389-ds-base-1.2.3.ebuild,2.42 KB, text/plain)
2009-11-02 12:24 UTC, Andreis Vinogradovs ( slepnoga )
Details
389 Directory Server - Admin serwer (389-admin-1.1.9.ebuild,1.71 KB, text/plain)
2009-11-02 12:25 UTC, Andreis Vinogradovs ( slepnoga )
Details
wersion bump, fix install binary and headers files (mozldap-6.0.6.ebuild,3.31 KB, text/plain)
2009-11-02 12:28 UTC, Andreis Vinogradovs ( slepnoga )
Details
apr-util ebuild as mozldap USE/Support - reqired for user web interface 389 serwer (apr-util-1.3.9-r101.ebuild,2.53 KB, text/plain)
2009-11-02 12:30 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-adminutil ebuild (389-adminutil-1.1.8-r1.ebuild,791 bytes, text/plain)
2009-11-02 12:31 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-admin-console Java based remote GUI for 389-admin server (389-admin-console-1.1.4.ebuild,1.84 KB, text/plain)
2009-11-02 12:33 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-ds-console ebuild (389-ds-console-1.2.0.ebuild,1.86 KB, text/plain)
2009-11-02 12:34 UTC, Andreis Vinogradovs ( slepnoga )
Details
idm-console for 389 ladp server (389-idm-console-1.1.3.ebuild,1.61 KB, text/plain)
2009-11-02 12:35 UTC, Andreis Vinogradovs ( slepnoga )
Details
389 Directory Server Gateway web apps (389-dsgw-1.1.4.ebuild,896 bytes, text/plain)
2009-11-02 12:36 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-ds-base-1.2.5_rc2.ebuild (389-ds-base-1.2.5_rc2.ebuild,2.73 KB, text/plain)
2009-12-10 12:39 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-admin-1.1.10_alpha2.ebuild (389-admin-1.1.10_alpha2.ebuild,2.17 KB, text/plain)
2009-12-20 20:10 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-ds-base-1.2.5_rc3.ebuild (389-ds-base-1.2.5_rc3.ebuild,2.73 KB, text/plain)
2009-12-20 20:11 UTC, Andreis Vinogradovs ( slepnoga )
Details
1.2.5.ebuild - snmp agent script added (389-ds-base-1.2.5.ebuild,2.85 KB, text/plain)
2010-01-26 03:07 UTC, Andreis Vinogradovs ( slepnoga )
Details
389-admin-1.1.10.ebuild (389-admin-1.1.10.ebuild,3.66 KB, text/plain)
2010-01-26 03:12 UTC, Andreis Vinogradovs ( slepnoga )
Details
net-nds/389-ds-base-1.2.6_alpha2.ebuild (389-ds-base-1.2.6_alpha2.ebuild,4.22 KB, text/plain)
2010-03-20 14:02 UTC, Mario Fetka (geos_one)
Details
389-ds-base/files/0001-Bug-480787-Autoconf-parameter-with-and-without.patch (0001-Bug-480787-Autoconf-parameter-with-and-without.patch,26.81 KB, patch)
2010-03-20 14:03 UTC, Mario Fetka (geos_one)
Details | Diff
net-nds/389-ds-base/files/389-ds-base-1.2.6.a2-gentoo_selinux-1.patch (389-ds-base-1.2.6.a2-gentoo_selinux-1.patch,1.25 KB, text/plain)
2010-03-20 14:05 UTC, Mario Fetka (geos_one)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2005-09-01 23:35:16 UTC
It would be great if there was an ebuild for feodra directory server. I am
currently using open-ldap which is difficult to configure, especially acls and
seems flaky. My database gets corrupt every now and then and then needs to be
restored.


thanks

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




See

http://directory.fedora.redhat.com/wiki/Main_Page
Comment 1 Mike Baikov 2005-12-02 01:22:02 UTC
1.0 version bump.
Comment 2 Joshua Harris 2005-12-02 14:39:05 UTC
Here's another request for Fedora DS ebuilds. 
Comment 3 Mike Crawford (ali3nx) 2005-12-04 12:32:59 UTC
Make mine #3 pleez! I'm going to pick through the  rpm this coming week and see
what i can do about helping with an ebuild. Hopefully some others drum up some
interest
Comment 4 Tomoyuki Sakurai (RETIRED) gentoo-dev 2005-12-04 14:46:29 UTC
(In reply to comment #3)
> I'm going to pick through the  rpm this coming week and see

what you need is 
http://directory.fedora.redhat.com/wiki/Building#Example

confirmed it compiled successfully and it was not so difficult.

possible problems are:

* it doesn't use installed libraries or software(uses its own db-4.*, net-snmp)
* many components to handle
* dependencies are unclear(you need zip to build)
Comment 5 Mike Slinn 2005-12-04 21:40:08 UTC
I'd like to see to an ebuild too!  :)
Comment 6 Johannes Schanda 2005-12-06 04:48:05 UTC
I'd like to see an ebuild too! 
Comment 7 Stefan Knoblich (RETIRED) gentoo-dev 2005-12-10 06:25:30 UTC
Created attachment 74427 [details]
fedora ds 1.0 ebuild and patches

incomplete (!) ebuild

ccache breaks it, distcc is unsupported
Comment 8 Mark 2006-02-18 09:34:20 UTC
man -- i really need this ebuild. Wish I could do it myself. Just got screwed by openldap 2.3.19 upgrade. Will someone please deliver us from this openldap hell?

thanks

Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-03-29 11:06:54 UTC
*** Bug 128019 has been marked as a duplicate of this bug. ***
Comment 10 Massimiliano Adamo 2006-03-30 02:10:45 UTC
HI all,

I installed binaries of Fedora DS, on Gentoo AMD64 and i686, by using the by using rpm.
It simply works.

This is my init script (which is not good if you use certificates):

#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

#Modify this parameter depending on your setup
# This is usually the hostname.
MYSLAPD=gentoo

DSPATH=/opt/fedora-ds
export MYSLAPD DSPATH

depend() {
        need net
        use dns
}

start() {
        ebegin "Starting Fedora DS"
        start-stop-daemon --start --quiet \
        --make-pidfile --pidfile /var/run/fedora-ds.pid \
        --exec ${DSPATH}/slapd-${MYSLAPD}/start-slapd 
        eend $?

        ebegin "Starting Fedora Admin Server"
        start-stop-daemon --start --quiet \
        --make-pidfile --pidfile /var/run/fedora-admsrv.pid \
        --exec ${DSPATH}/start-admin
        eend $?
}

stop() {
        ebegin "Stopping Fedora Admin Server"
        start-stop-daemon --start --quiet \
        --pidfile /var/run/fedora-admsrv.pid \
        --exec ${DSPATH}/stop-admin 
        eend $?

        ebegin "Stopping Fedora DS"
        start-stop-daemon --start --quiet \
        --pidfile /var/run/fedora-ds.pid \
        --exec ${DSPATH}/slapd-${MYSLAPD}/stop-slapd 
        eend $?

}

restart() {
        svc_stop
        svc_start
}
Comment 11 Mike Slinn 2006-04-16 10:24:40 UTC
bump
Comment 12 mikael lammentausta 2006-11-10 03:56:27 UTC
The krb5 inside this won't build.. any change to get the package to use external mit-krb5 package?

The latest version of fedora-ds is 1.0.4.
Comment 13 André-Sebastian Liebe 2006-12-25 14:03:00 UTC
any news regarding a net-nds/fedora-ds-1.0.4 ebuild?
Comment 14 Petteri Räty (RETIRED) gentoo-dev 2007-01-07 15:38:17 UTC
Seems to have java stuff so should be checked with use before adding to the tree.
Comment 15 Philipp Riegger 2007-01-09 17:02:32 UTC
What's the status on this one? Anybody working on the ebuild? Sunrise maybe?
Comment 16 Erric 2007-02-15 21:42:56 UTC
I was just able to build this using the dsbuild tarball provided by the fedora folks. I did have to change a few make files and create one symlink but other then this it built fine. I haven't tried to run it yet though. I removed -ltermcap from four or five make files and the symlink I made was for /usr/sbin/apxs2 to /usr/sbin/apxs. That was done to satisfy mod_nss.
Comment 17 Erric 2007-02-15 23:41:53 UTC
Ok, so I rebuilt this and took some notes to help out. First, i did try emerging the termcap from portage, but this didn't seem to make any difference. So, here are the list of files I edited -ltermcap out of:

$PATH/dsbuild-fds104/ds/setuputil/work/fedora-setuputil-1.0.3/installer/unix/Makefile

$PATH/dsbuild-fds104/ds/adminserver/work/fedora-adminserver-1.0.3/admservi/newinst/src/Makefile

$PATH/dsbuild-fds104/ds/ldapserver/work/fedora-ds-1.0.4/ldap/cm/newinst/Makefile

$PATH of crouse is up to you, mine happened to be /usr/local/src/ldap.

The APXS business was easy too. I just changed into the mod_nss dir and did a configure like this: ./confiure --with-apxs=/usr/sbin/apxs2 and then I did a make and changed back to the $PATH/dsbuild-fds104/meta/ds dir to continue the build process.

The server seems to fire up but I also built it with the NOJAVA=1 option since it's just going to be a server. It starts up all fine and I will be testing with it shortly. I don't know how to make an ebuild file. I may investigate this but I have more pressing issues right now.
Comment 18 mikael lammentausta 2007-02-19 15:07:49 UTC
Created attachment 110645 [details]
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild

I continued to work on from the giant ebuild. This is the first one I got working, it uses external libs. I managed to get this one compiled, I've no idea if it really works. I'll try to modularize the rest as well.

Please test to see if it works and look for updates in the following days.
Comment 19 mikael lammentausta 2007-02-19 15:50:24 UTC
Created attachment 110657 [details]
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild

Updated. Use this.
Comment 20 mikael lammentausta 2007-02-19 17:33:53 UTC
Created attachment 110675 [details]
net-nds/fedora-ds-mozilla/fedora-ds-mozilla-1.0.3.ebuild

I figured this one is the first to install. It builds several files to which the later packages link. I'm not sure if I got everything right the first time, probably not. :D 

Emerge tells me this after a successful install, I don't know if the problem is in the ebuild or in the code itself (it seems it's from gcc 2> stream):

 * QA Notice: Package has poor programming practices which may compile
 *            fine but exhibit random runtime failures.
 * ../../../../pr/src/io/prfdcach.c:165: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../pr/src/io/prfdcach.c:224: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../pr/src/misc/prthinfo.c:109: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../pr/src/misc/prthinfo.c:235: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../pr/src/pthreads/ptio.c:899: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:100: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:100: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:119: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:119: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:136: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:136: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:151: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:167: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../dbm/src/ndbm.c:167: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkistore.c:318: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkistore.c:452: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkistore.c:500: warning: dereferencing type-punned pointer will break strict-aliasing rules
pk11load.c:306: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1085: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1086: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1087: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1088: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1089: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1090: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1091: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1364: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1365: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1366: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1367: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1368: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1369: warning: dereferencing type-punned pointer will break strict-aliasing rules
sslsnce.c:1370: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmsattr.c:95: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmsattr.c:132: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmsenvdata.c:139: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmsrecinfo.c:231: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:766: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:810: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:826: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:864: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:1037: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:1039: warning: dereferencing type-punned pointer will break strict-aliasing rules
blapitest.c:3383: warning: dereferencing type-punned pointer will break strict-aliasing rules
install.c:443: warning: dereferencing type-punned pointer will break strict-aliasing rules
ldappr-io.c:138: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:253: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:254: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:255: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:256: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:257: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:277: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:278: warning: dereferencing type-punned pointer will break strict-aliasing rules
clientinit.c:279: warning: dereferencing type-punned pointer will break strict-aliasing rules
ldapsinit.c:233: warning: dereferencing type-punned pointer will break strict-aliasing rules
Comment 21 mikael lammentausta 2007-02-20 08:54:54 UTC
Created attachment 110714 [details]
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild

Work in progress.
Comment 22 mikael lammentausta 2007-02-22 07:12:35 UTC
Created attachment 110956 [details]
net-nds/fedora-ds-mozilla/fedora-ds-mozilla-1.0.3.ebuild
Comment 23 mikael lammentausta 2007-02-22 07:12:57 UTC
Created attachment 110957 [details]
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.0.4.ebuild
Comment 24 mikael lammentausta 2007-02-22 07:13:21 UTC
Created attachment 110959 [details]
net-nds/fedora-ds-setuputil/fedora-ds-setuputil-1.0.3.ebuild
Comment 25 mikael lammentausta 2007-02-22 07:17:42 UTC
These packages build fine. I don't have time to develop these right now, I hope someone else would continue from here. I'm not very good at writing such complicated ebuilds.

The next step would be to install the Apache modules. However, these link to adminutil, and as I separated the libs and headers, the configure script won't accept this, it wants them both to be on the same path. Symlinks perhaps?

I'm going to login to a root account on a Fedora box and try to install the rpms for now. :/
Comment 26 Mario Fetka (geos_one) 2007-08-07 07:45:44 UTC
(In reply to comment #25)
> These packages build fine. I don't have time to develop these right now, I hope
> someone else would continue from here. I'm not very good at writing such
> complicated ebuilds.

Hallo 
I am working at the moment on some new ebuilds:

I only have the required libs in the tree to get the ds compile (ebuild for ds will be added this week)

dev-libs/svrcore
dev-libs/mozldap
dev-perl/perl-mozldap

the overlay is located at

svn co http://mars.arge.at/svn/linamh/trunk/linamh/

so my plan is to finisch the ebuild for the ds this week and start working on the rest next week.

wfg
Mario
Comment 27 Petteri Räty (RETIRED) gentoo-dev 2007-08-07 09:13:38 UTC
(In reply to comment #26)
> 
> dev-libs/svrcore
> dev-libs/mozldap
> dev-perl/perl-mozldap
> 

Adding perl to CC so that they can comment.
Comment 28 Mario Fetka (geos_one) 2007-08-07 22:27:57 UTC
> so my plan is to finisch the ebuild for the ds this week and start working on
> the rest next week.

The ebuild for fedora-ds-base is in the tree.

net-nds/fedora-ds-base (is the suggested name from the fedora project)
net-nds/fedora-ds-adminutil (the suggested name is adminutils ? )

the server also includes a nice initscript with instance support
only setup the server with setup-ds.pl and add the instance name to
/etc/conf.d/fedora-ds

the fedora-ds-setuputil is deprecated

so lets start adding the complicated ebuilds (java + apache + cgi + perl + ....)

all packages are using the todays snapshot for all packages with autotools support (waiting for the fedora-ds 1.1 release)

wfg
Mario 
Comment 29 Dmitry S. Kulyabov 2007-08-08 10:17:17 UTC
Created attachment 127259 [details]
dev-libs/svrcore/svrcore-4.0.4.ebuild

My ebuilds, based on Fedora spec.
Comment 30 Dmitry S. Kulyabov 2007-08-08 10:17:44 UTC
Created attachment 127260 [details]
dev-libs/mozldap/mozldap-6.0.4.ebuild
Comment 31 Dmitry S. Kulyabov 2007-08-08 10:54:54 UTC
Created attachment 127262 [details]
net-nds/fedora-ds-adminutil/fedora-ds-adminutil-1.1.2_pre20070808.ebuild
Comment 32 Dmitry S. Kulyabov 2007-08-08 11:02:19 UTC
Created attachment 127263 [details]
net-nds/fedora-ds/fedora-ds-1.1.0_pre20070808.ebuild
Comment 33 Dmitry S. Kulyabov 2007-08-08 11:02:43 UTC
Created attachment 127265 [details]
net-nds/fedora-ds/files/fedora-ds.initd
Comment 34 Dmitry S. Kulyabov 2007-08-08 11:03:08 UTC
Created attachment 127266 [details]
net-nds/fedora-ds/files/fedora-ds.confd
Comment 35 Dmitry S. Kulyabov 2007-08-08 11:15:34 UTC
Created attachment 127269 [details]
net-nds/fedora-ds-setuputil/fedora-ds-setuputil-1.1.0_pre20070808.ebuild
Comment 36 Mario Fetka (geos_one) 2007-08-08 13:16:32 UTC
(In reply to comment #35)
> Created an attachment (id=127269) [edit]
> net-nds/fedora-ds-setuputil/fedora-ds-setuputil-1.1.0_pre20070808.ebuild
> 

the setup utils are offical deprecated by the fedora-ds 1.1 

so the setuputils are not required.
Comment 37 Mario Fetka (geos_one) 2007-08-08 19:46:11 UTC
(In reply to comment #28)
> net-nds/fedora-ds-adminutil (the suggested name is adminutils ? )

had to move the fedora-ds-adminutil to

dev-libs/adminutil (yes fedora was right with ther suggestion )

> so lets start adding the complicated ebuilds (java + apache + cgi + perl +
> ....)
> 

the new additions to the tree are

www-apache/mod_nss
www-apache/mod_admserv

can someone plz test this mod_*'s mainly the default configfiles if there are some false asumptions.

wfg
Mario
Comment 38 Erric 2007-08-08 20:23:38 UTC
akira fedora # emerge -pv www-apache/mod_admserv www-apache/mod_nss

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] net-www/apache-2.0.58-r2  USE="apache2 mpm-worker ssl -debug -doc -ldap -mpm-itk -mpm-leader -mpm-peruser -mpm-prefork -mpm-threadpool (-selinux) -static-modules -threads" 0 kB 
[ebuild  N    ] dev-libs/adminutil-1.1.4.20070807  USE="ipv6 sasl -debug" 302 kB [1] 
[ebuild  N    ] www-apache/mod_admserv-1.0.20070807  USE="ssl" 230 kB [1] 
[ebuild  N    ] www-apache/mod_nss-1.0.20070807  USE="ssl" 293 kB [1] 

Total: 4 packages (4 new), Size of downloads: 824 kB

The first two build just fine but i'm having trouble downloading the packages for the last two. Both distfiles.gentoo.org and distro.ibiblio.org give me a 404 and I am not allowing FTP here at work.
Comment 39 Mario Fetka (geos_one) 2007-08-09 14:28:47 UTC
(In reply to comment #38)
> The first two build just fine but i'm having trouble downloading the packages
> for the last two. Both distfiles.gentoo.org and distro.ibiblio.org give me a
> 404 and I am not allowing FTP here at work.
> 

i have added an http mirror to the list.

at the moment i am on working out what would be the best way for handling fds-admin

the requirement for admin is that the apache that is running the admin soft should use the mozldap ..stop..

the fedora way:
they are using the system apache with LD_PRELOAD=/usr/lib/mozldap/libldap60.so
to overrride all openldap functions.
so they have an initscript that is mainly an apache start script with the override.

the gentoo way: (the way it should be; i think)
as gentoo has this nice USE flags add a new one "mozldap"
this use flag should be used by apr-utils & apache 
this way these packages would be compiled aginst mozldap and no need for this odd override
then have a init script (fedora-ds-admin only start admin server) with befor apache2 & after fedora-ds

apr-utils must be patched to detect mozldap60 or mozldap must be downgradet to 50 

so what way we are going?

wfg
Mario
Comment 40 Erric 2007-08-09 18:08:29 UTC
My vote would be the gentoo way. That is indeed why we do have USE flags.
Comment 41 Erric 2007-08-09 20:25:24 UTC
I downloaded the files you had sent me but they don't pass the checks for building. It looks like the file size has changed and not been updated, or I got the wrong one.

akira fedora # emerge -v net-nds/fedora-ds-base

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] net-nds/fedora-ds-base-1.1.0.20070807  USE="ipv6 sasl -debug -snmp" 0 kB [1] 

Total: 1 package (1 new), Size of downloads: 0 kB
Portage overlays:

>>> Emerging (1 of 1) net-nds/fedora-ds-base-1.1.0.20070807 to /
 * fedora-ds-1.1.0-20070807.tar.bz2 MD5 ;-) ...                                                                  [ ok ]
 * fedora-ds-1.1.0-20070807.tar.bz2 RMD160 ;-) ...                                                               [ ok ]
 * fedora-ds-1.1.0-20070807.tar.bz2 SHA1 ;-) ...                                                                 [ ok ]
 * fedora-ds-1.1.0-20070807.tar.bz2 SHA256 ;-) ...                                                               [ ok ]
 * fedora-ds-1.1.0-20070807.tar.bz2 size ;-) ...                                                                 [ ok ]
 * checking ebuild checksums ;-) ...                                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                                            [ !! ]

!!! Digest verification failed:
!!! /usr/local/portage/fedora/net-nds/fedora-ds-base/files/fedora-ds-cvs.sh
!!! Reason: Filesize does not match recorded size
!!! Got: 346
!!! Expected: 334
Comment 42 Massimiliano Adamo 2007-08-10 09:38:07 UTC
why not creating a binary package: net-nds/fedora-ds-bin and closing this ticket after 2 years ??
There is already binary package either for x86 and amd64.
This ticket is 2 years old and I don't understand where you want to get on.

cheeers
Comment 43 Mario Fetka (geos_one) 2007-08-10 10:13:38 UTC
(In reply to comment #42)
> why not creating a binary package: net-nds/fedora-ds-bin and closing this
> ticket after 2 years ??
> There is already binary package either for x86 and amd64.
> This ticket is 2 years old and I don't understand where you want to get on.
> 
> cheeers
> 
the fedora-ds already works ok.
i am working on the management system that will become a new framework for managing the next versions of RHEL.
Comment 44 Massimiliano Adamo 2007-08-10 10:27:08 UTC
(In reply to comment #43)
> (In reply to comment #42)
> > why not creating a binary package: net-nds/fedora-ds-bin and closing this
> > ticket after 2 years ??
> > There is already binary package either for x86 and amd64.
> > This ticket is 2 years old and I don't understand where you want to get on.
> > 
> > cheeers
> > 
> the fedora-ds already works ok.
> i am working on the management system that will become a new framework for
> managing the next versions of RHEL.
> 

Cool!... but I hope, once you finish, you'll not have to work again to create an ebuild for opends :)
http://www.opends.org/
http://blogs.sun.com/DirectoryManager/entry/opends_0_9_0_is
This software derives from the Netscape DS (like Fedora-ds), it's licensed with CDDL license and it will replace SunDS.
cheers
Comment 45 Mario Fetka (geos_one) 2007-08-10 16:24:45 UTC
(In reply to comment #44)
> Cool!... but I hope, once you finish, you'll not have to work again to create
> an ebuild for opends :)
> http://www.opends.org/
> http://blogs.sun.com/DirectoryManager/entry/opends_0_9_0_is
> This software derives from the Netscape DS (like Fedora-ds), it's licensed with
> CDDL license and it will replace SunDS.
> cheers
> 
i dont think this server derives from Netscape ! the whole server is written in java i have not found any c Code like in fedora-ds  
Comment 46 Erric 2007-08-10 16:35:33 UTC
The OpenDS isn't related to the fedora-ds as far as I can tell. If there are people who want the OpenDS to run LDAP, they are most welcome to use it, create ebuilds etc. There are others interested in the fedora-ds because of it's maturity level and because there is already an investment in understanding it.
Comment 47 Mario Fetka (geos_one) 2007-10-05 22:20:32 UTC
(In reply to comment #40)
> My vote would be the gentoo way. That is indeed why we do have USE flags.
> 

the apr-util & apache are now mozldap aware and the modified ebuilds are already in my tree
the apr-util patch is already send upstream (not included yet)

only add mozldap to your useflags
the next step is to create the ebuild for the admin server and module

so not that far away from the final ebuilds 
my plan is to have testing ebuilds for the final fds release 
Comment 48 Mario Fetka (geos_one) 2007-10-06 17:24:45 UTC
i have added a basic fedora-ds-admin ebuild to my tree 
have removed the start/stop/restart -ds-admin scripts 
as the apache server is build against mozldap

the apache confs are in /etc/dirsrv/admin-serv/
could someone with apache config knowhow create some basic working gentoo style configs that i can use as a save default install

my idee is to have

47_mod_nss -> www-apache/mod_nss
48_mod_restartd -> www-apache/mod_restartd
49_mod_admserv -> net-nds/fedora-ds-admin

console.conf ?
Comment 49 Mario Fetka (geos_one) 2007-10-07 20:01:33 UTC
the fedora management framework is now in my tree 

dev-java/idm-console-framework -> the management framwork

only merge 
app-admin/fedora-admin-console -> the adminserver plugin for idm app-admin/fedora-ds-console -> the directory server plugin for idm
app-admin/fedora-idm-console -> the artwork amd startscript for idm

the name of of the brad changed from fedora-ds to dirsrv
migrate-ds.pl
Comment 50 Vladimir Rusinov 2008-05-20 10:26:52 UTC
Any progress here?

Mario Fetka, is your overlay accessible?
Comment 51 Mario Fetka (geos_one) 2008-05-21 06:58:32 UTC
(In reply to comment #50)
> Any progress here?
> 
> Mario Fetka, is your overlay accessible?
> 
yes my overlay is accesssibel.
but i am stuck at the admin server with the apache eclass patch it would be great if someone with more knowlege at eclass design can have a look at the eclass and arp-util patch yes its working apache build against mozldap.

the overlay only holds the management console and the server but not the admin server 

my overlay file for layman:

http://ftp.mars.arge.at/pub/overlay/linamh-overlay.xml

be warnde this overlay also holds some other ebuilds
Comment 52 Dmitry S. Kulyabov 2008-05-21 07:10:11 UTC
mark layman # layman -a linamh
* Running command "/usr/bin/svn co "http://mars.arge.at/svn/linamh/trunk/linamh/" "/usr/portage/local/layman/linamh""...
svn: PROPFIND request failed on '/svn/linamh/trunk/linamh'
svn: PROPFIND of '/svn/linamh/trunk/linamh': 405 Method Not Allowed (http://mars.arge.at)
* Failed to add overlay "linamh".
* Error was: Adding the overlay failed!
Comment 53 Mario Fetka (geos_one) 2008-05-21 07:15:20 UTC
(In reply to comment #52)
> mark layman # layman -a linamh
> * Running command "/usr/bin/svn co
> "http://mars.arge.at/svn/linamh/trunk/linamh/"
> "/usr/portage/local/layman/linamh""...
> svn: PROPFIND request failed on '/svn/linamh/trunk/linamh'
> svn: PROPFIND of '/svn/linamh/trunk/linamh': 405 Method Not Allowed
> (http://mars.arge.at)
> * Failed to add overlay "linamh".
> * Error was: Adding the overlay failed!
> 
i am having some server problems i will correct in a view minutes
Comment 54 Mario Fetka (geos_one) 2008-08-01 09:36:37 UTC
dirsrv-admin slowly starts working:

the admin server (apache2 build against mozldap) starts working.

i was able to connect with the idm-console to the admin-server but then complains about not finding some jars

so there is some progress
the progress can be folled in the overlay.  
Comment 55 Vladimir Rusinov 2008-08-18 15:08:22 UTC
fedora-ds-base-1.1.1 does not build without sasl:


# USE="-sasl" emerge <....>
<...>
checking for --with-sasl... no
checking for --with-sasl-inc... no
checking for --with-sasl-lib... no
checking for sasl.h... no
configure: error: sasl not found, specify with --with-sasl.

amd64
Comment 56 Mario Fetka (geos_one) 2008-08-18 16:11:22 UTC
(In reply to comment #55)
> fedora-ds-base-1.1.1 does not build without sasl:
> 
> 
> # USE="-sasl" emerge <....>
> <...>
> checking for --with-sasl... no
> checking for --with-sasl-inc... no
> checking for --with-sasl-lib... no
> checking for sasl.h... no
> configure: error: sasl not found, specify with --with-sasl.
> 
> amd64
> 

thx updated ebuild to depend on sals
Comment 57 Vladimir Rusinov 2008-08-18 16:12:17 UTC
Created attachment 163221 [details]
fixed fedora-ds-base ebuild from svn

Tried to fix compilation without sasl (not tested, ebuild could be broken).
Added missing dependency: dev-perl/perl-mozldap
Comment 58 Vladimir Rusinov 2008-08-18 17:49:18 UTC
Created attachment 163230 [details]
added missing dependencies
Comment 59 Vladimir Rusinov 2008-08-18 18:52:45 UTC
Hi Mario.

I'm getting following error after using setup-ds-admin.pl:

[08/08/19:06:27:10] - [Setup] Info Are you ready to set up your servers?
[08/08/19:06:27:13] - [Setup] Info yes
[08/08/19:06:27:13] - [Setup] Info Creating directory server . . .
[08/08/19:06:27:16] - [Setup] Info Your new DS instance 'edir01' was successfully created.
[08/08/19:06:27:16] - [Setup] Info Creating the configuration directory server . . .
[08/08/19:06:27:16] - [Setup] Info Beginning Admin Server creation . . .
[08/08/19:06:27:16] - [Setup] Info Creating Admin Server files and directories . . .
[08/08/19:06:27:16] - [Setup] Info Updating adm.conf . . .
[08/08/19:06:27:16] - [Setup] Info Updating admpw . . .
[08/08/19:06:27:16] - [Setup] Info Registering admin server with the configuration directory server . . .
[08/08/19:06:27:17] - [Setup] Info Updating adm.conf with information from configuration directory server . . .
[08/08/19:06:27:17] - [Setup] Info Updating the configuration for the httpd engine . . .
[08/08/19:06:27:17] - [Setup] Info Starting admin server . . .
[08/08/19:06:27:17] - [Setup] Info output: sh: /usr/sbin/start-ds-admin: No such file or directory
[08/08/19:06:27:17] - [Setup] Fatal Failed to create and configure the admin server
[08/08/19:06:27:17] - [Setup] Fatal Exiting . . .

As I can see, all configuration files on /etc/dirserv/admin-serv/ were updated seccesfully, but I can't find start-ds-admin anywhere.

dirserv seems to work well, at least I can `telnet localhost ldap`
Comment 60 Mario Fetka (geos_one) 2008-08-18 21:38:45 UTC
> As I can see, all configuration files on /etc/dirserv/admin-serv/ were updated
> seccesfully, but I can't find start-ds-admin anywhere.
> 
> dirserv seems to work well, at least I can `telnet localhost ldap`
> 
plz update svn:
the fedora-ds-admin now works
the missing script were removed on the old ebuilds (hard coded paths; this changed with 1.1.1 1.1.5)

the use flags are removed now as the m4 macros aren't working on gentoo 
there is no switch like --without-sasl if its on the system its used even with USE=-sasl

Mario
Comment 61 Erric 2008-08-20 16:27:21 UTC
Hello,

There seems to be a checksum issue with the ds-console tarball:

>>> Downloading 'http://directory.fedoraproject.org/sources/fedora-ds-console-1.1.1.tar.bz2'
--14:29:56--  http://directory.fedoraproject.org/sources/fedora-ds-console-1.1.1.tar.bz2
           => `/usr/portage/distfiles/fedora-ds-console-1.1.1.tar.bz2'
Resolving directory.fedoraproject.org... 209.132.176.189
Connecting to directory.fedoraproject.org|209.132.176.189|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 803,125 (784K) [application/x-bzip2]

100%[===========================================================================================>] 803,125      221.28K/s    ETA 00:00

14:30:00 (203.10 KB/s) - `/usr/portage/distfiles/fedora-ds-console-1.1.1.tar.bz2' saved [803125/803125]

 * checking ebuild checksums ;-) ...                                                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                                                           [ ok ]
 * checking fedora-ds-console-1.1.1.tar.bz2 ;-) ...                                                                              [ !! ]

!!! Digest verification failed:
!!! /usr/portage/distfiles/fedora-ds-console-1.1.1.tar.bz2
!!! Reason: Filesize does not match recorded size
!!! Got: 803125
!!! Expected: 802587
Comment 62 Mario Fetka (geos_one) 2008-08-20 21:47:22 UTC
(In reply to comment #61)
> Hello,
> 
> There seems to be a checksum issue with the ds-console tarball:
> 
is corrected thx for report. 
Comment 63 Erric 2008-08-22 16:45:34 UTC
Hi Mario,

I'm still getting the same error:

>>> Downloading 'http://directory.fedoraproject.org/sources/fedora-ds-console-1.1.1.tar.bz2'
--09:37:01--  http://directory.fedoraproject.org/sources/fedora-ds-console-1.1.1.tar.bz2
           => `/usr/portage/distfiles/fedora-ds-console-1.1.1.tar.bz2'
Resolving directory.fedoraproject.org... 209.132.176.189
Connecting to directory.fedoraproject.org|209.132.176.189|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 803,125 (784K) [application/x-bzip2]

100%[===========================================================================================>] 803,125      350.77K/s             

09:37:04 (349.91 KB/s) - `/usr/portage/distfiles/fedora-ds-console-1.1.1.tar.bz2' saved [803125/803125]

 * checking ebuild checksums ;-) ...                                                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                                                           [ ok ]
 * checking fedora-ds-console-1.1.1.tar.bz2 ;-) ...                                                                              [ !! ]

!!! Digest verification failed:
!!! /usr/portage/distfiles/fedora-ds-console-1.1.1.tar.bz2
!!! Reason: Filesize does not match recorded size
!!! Got: 803125
!!! Expected: 802587
 * GNU info directory index is up-to-date.

Thank you,

Erric
Comment 64 Erric 2008-08-22 16:52:28 UTC
Never mind, It was me. I didn't do a layman -S :D

However:

checking for --with-httpd... using /usr/sbin/apache2
grep: /usr//etc/apache2/httpd.conf: No such file or directory
configure: error: mime.types file not found

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-nds/fedora-ds-admin-1.1.5-r1/work/fedora-ds-admin-1.1.5/config.log
 * 
 * ERROR: net-nds/fedora-ds-admin-1.1.5-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2502:  Called econf 'src_compile' 'src_compile' '--disable-debug'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *  The die message:
 *   econf failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-nds/fedora-ds-admin-1.1.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/fedora-ds-admin-1.1.5-r1/temp/environment'.
 * This ebuild is from an overlay: '/usr/portage/local/layman/linamh/'

Looks like a simple path issue. --Erric
Comment 65 Mario Fetka (geos_one) 2008-08-22 19:07:09 UTC
(In reply to comment #64)
> checking for --with-httpd... using /usr/sbin/apache2
> grep: /usr//etc/apache2/httpd.conf: No such file or directory
> configure: error: mime.types file not found

added missing depend on app-misc/mime-types

thx for report
Comment 66 Erric 2008-08-22 19:51:30 UTC
Mario,

Thank you for updating this. It all builds correctly now on my system. Now to see if it runs ok :D

Erric

hostname # equery list fedora
[ Searching for package 'fedora' in all categories among: ]
 * installed packages
[I--] [ ~] app-admin/fedora-admin-console-1.1.1 (1.1)
[I--] [ ~] app-admin/fedora-ds-console-1.1.1 (1.1)
[I--] [ ~] app-admin/fedora-idm-console-1.1.1 (1.1)
[I--] [ ~] net-nds/fedora-ds-admin-1.1.5-r1 (0)
[I--] [ ~] net-nds/fedora-ds-base-1.1.1-r1 (0)

Comment 67 Mario Fetka (geos_one) 2008-08-22 20:06:37 UTC
(In reply to comment #66)
> Mario,
> 
> Thank you for updating this. It all builds correctly now on my system. Now to
> see if it runs ok :D
> 
> Erric
> 
> hostname # equery list fedora
> [ Searching for package 'fedora' in all categories among: ]
>  * installed packages
> [I--] [ ~] app-admin/fedora-admin-console-1.1.1 (1.1)
> [I--] [ ~] app-admin/fedora-ds-console-1.1.1 (1.1)
> [I--] [ ~] app-admin/fedora-idm-console-1.1.1 (1.1)
> [I--] [ ~] net-nds/fedora-ds-admin-1.1.5-r1 (0)
> [I--] [ ~] net-nds/fedora-ds-base-1.1.1-r1 (0)
> 

at the moment i am stuck at the webinterface it only errors out
hey maby you can find the reason for the error
mod_admserv access permissons ?

Mario
Comment 68 Erric 2008-08-22 20:16:24 UTC
I'm not completely sure if its the same problem I have when building on my own from source, but it sounds like it. Basically I would get everything installed and running, then try and use the fancy java client to log in but would always get denied there even when using a simple password. Strange thing is that I was able to log into the Web based manager as DC=Administrator, but it's not very robust.

I will certainly report back what I find later on today.

Comment 69 Graham Seaman 2008-08-25 09:34:23 UTC
(In reply to comment #57)
> Created an attachment (id=163221) [edit]
> fixed fedora-ds-base ebuild from svn
> 
> Tried to fix compilation without sasl (not tested, ebuild could be broken).

I'm having problems with this. I do have cyrus-sasl installed. But I can't compile with or without it:

>USE="-sasl" emerge --deep fedora-ds-base
....
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-debug --without-sasl --with-fhs --build=i686-pc-linux-gnu
....
configure: checking for sasl...
checking for --with-sasl... yes
configure: error: sasl not found in no

(that's the exact message). 

Graham(In reply to comment #57)

Comment 70 Mario Fetka (geos_one) 2008-08-25 10:26:36 UTC
(In reply to comment #69)
> I'm having problems with this. I do have cyrus-sasl installed. But I can't
> compile with or without it:

plz update svn
Comment 71 Mario Fetka (geos_one) 2009-01-21 13:11:19 UTC
I have moved the all fds related ebuilds to its own overlay.

the new layman file is located at
http://ftp.mars.arge.at/pub/overlay/geos_one-overlay.xml

the overlay is called "fds"

so everyone using this ebuilds should move to this overlay
Comment 72 Mario Fetka (geos_one) 2009-04-07 05:32:28 UTC
updated ebuilds in my overlay 
fds 1.2
Comment 73 Dmitry S. Kulyabov 2009-05-21 08:10:03 UTC
mark ~ # layman -s fds
* Running command "/usr/bin/svn up "/usr/portage/local/layman/fds""...
svn: OPTIONS of 'http://mars.arge.at/svn/linamh/trunk/fds': could not connect to server (http://mars.arge.at)
*
* Errors:
* ------
*
* Failed to sync overlay "fds".
* Error was: Syncing overlay "fds" returned status 256!
*
Comment 74 Mario Fetka (geos_one) 2009-05-21 08:28:20 UTC
(In reply to comment #73)
> mark ~ # layman -s fds
> * Running command "/usr/bin/svn up "/usr/portage/local/layman/fds""...
> svn: OPTIONS of 'http://mars.arge.at/svn/linamh/trunk/fds': could not connect
> to server (http://mars.arge.at)
> *
> * Errors:
> * ------
> *
> * Failed to sync overlay "fds".
> * Error was: Syncing overlay "fds" returned status 256!
> *
> 

the server is up
but there are some important corporate updates taking the compleat internet quota
so lets hope they are finished  tomorrow
Comment 75 Mario Fetka (geos_one) 2009-05-21 08:34:05 UTC
the update to 389 is on the way

can someone plz correct the Summery to: EBuild for 389 Directory Ldap Server
Comment 76 Mario Fetka (geos_one) 2009-05-21 12:46:48 UTC
most of the tree has been renamed including the tree 
there are still packages that dont have new renamed versions

the overlay is now called 389-ds
happy testing
Comment 77 Mario Fetka (geos_one) 2009-08-24 00:34:14 UTC
update for the 1.2.1 release now in tree
also added my mirror of the used packages packages
upstream is doing package update without version bump

still working on  the admin server bug

all packages are now renamed to 389-*

also renamed the fedora-idm-console package (its the fedora theme package)
a gentoo theme pack would be greate ;-)

one thing that is low priority is a patch for setup-ds.pl
the problem:
when you run setup-ds.pl a ldif file for the inital start is created in the privat tempdir for the root user
when the server makes its initial start as unprivileged dirsrv user it has no access to the prior as root generated ldif file
for now when you want to setup the server unset TMP and unset TMPDIR
this way the generated file will be placed into /tmp and everything is going as it should

the second thing with high priority that needs work are patches for the m4 macros for 389-ds-base 389-admin to specify --without-sasl and alike 
at the moment when the sasl is found it is build even if the system is build with USE=-sasl

patches appriciated
Comment 78 Antek Grzymała (antoszka) 2009-10-21 15:45:23 UTC
What is the status of the overlay? Where can I currently check out from?

I cannot find it on any of the above-mentioned URL (be it layman xml, or a SVN address) nor in the official Gentoo overlays list.
Comment 79 Mario Fetka (geos_one) 2009-10-21 17:49:56 UTC
(In reply to comment #78)
> What is the status of the overlay? Where can I currently check out from?
> 
> I cannot find it on any of the above-mentioned URL (be it layman xml, or a SVN
> address) nor in the official Gentoo overlays list.
> 

here the updated infos
the layman file http://ftp.mars.arge.at/pub/overlay/geos_one-overlay.xml
the overlay is named 389-ds

if you had the fedora directory server installed the plz unmerge all fedora packages first

so happy testing
Comment 80 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:24:31 UTC
Created attachment 209028 [details]
version bump

more fix, it is compatible witch FreeIPA ( FreeIPA ebuils in process)
Comment 81 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:25:42 UTC
Created attachment 209030 [details]
 389 Directory Server - Admin serwer
Comment 82 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:28:53 UTC
Created attachment 209032 [details]
wersion bump, fix install binary and headers files

Based om Mario Fetka ebuild
Comment 83 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:30:20 UTC
Created attachment 209033 [details]
apr-util ebuild as mozldap USE/Support - reqired for user web interface 389 serwer
Comment 84 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:31:14 UTC
Created attachment 209035 [details]
389-adminutil ebuild
Comment 85 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:33:29 UTC
Created attachment 209037 [details]
389-admin-console Java based remote GUI for 389-admin server
Comment 86 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:34:21 UTC
Created attachment 209039 [details]
389-ds-console ebuild 

A Java based remote management console used for Managing 389 Administration and Directory Server
Comment 87 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:35:37 UTC
Created attachment 209041 [details]
idm-console for 389 ladp server
Comment 88 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:36:59 UTC
Created attachment 209043 [details]
389 Directory Server Gateway web apps
Comment 89 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:44:47 UTC
All ebuild/programm stack  developed by me in rion overlay.
I also write for ebuilds for RedHat pki server, based on 389 serwer - 	is a separate bug
Comment 90 Andreis Vinogradovs ( slepnoga ) 2009-11-02 12:50:24 UTC
Optional kerberos support in 389 server depend on #177522
Comment 91 Andreis Vinogradovs ( slepnoga ) 2009-12-10 12:39:42 UTC
Created attachment 212617 [details]
389-ds-base-1.2.5_rc2.ebuild
Comment 92 Andreis Vinogradovs ( slepnoga ) 2009-12-20 20:10:49 UTC
Created attachment 213604 [details]
389-admin-1.1.10_alpha2.ebuild
Comment 93 Andreis Vinogradovs ( slepnoga ) 2009-12-20 20:11:37 UTC
Created attachment 213605 [details]
389-ds-base-1.2.5_rc3.ebuild
Comment 94 Mario Fetka (geos_one) 2009-12-20 20:48:56 UTC
added 389-dsgw to my overlay (ebuilds is based on Andreis_Vinogradovs )
also corrected some old errors typos
all ebuilds are now eapi2
Comment 95 Mario Fetka (geos_one) 2009-12-21 07:25:29 UTC
initial freeipa ebuilds are now also in the tree (i did do not move them into its own overlay because they depend on 389 dirsrv)
this ebuilds are not for production
freeipa heavily depends on redhat style system
so if someone is that adventurous take a look at the blocking bug #297665
Comment 96 Andreis Vinogradovs ( slepnoga ) 2010-01-26 03:07:06 UTC
Created attachment 217432 [details]
1.2.5.ebuild - snmp agent script added

Upstream relized 1.2.5 version
Comment 97 Andreis Vinogradovs ( slepnoga ) 2010-01-26 03:12:59 UTC
Created attachment 217433 [details]
389-admin-1.1.10.ebuild

upstream relised 1.1.10 version on this package.
This ebuild install mod_restartd and mod_admserv due build system for this module deleted
Comment 98 Andreis Vinogradovs ( slepnoga ) 2010-03-15 12:46:07 UTC
Comment on attachment 209032 [details]
wersion bump, fix install binary and headers files

See #309539
Comment 99 Andreis Vinogradovs ( slepnoga ) 2010-03-15 13:47:30 UTC
Comment on attachment 217433 [details]
389-admin-1.1.10.ebuild

See #309575 bug
Comment 100 Mario Fetka (geos_one) 2010-03-20 14:02:09 UTC
Created attachment 224381 [details]
net-nds/389-ds-base-1.2.6_alpha2.ebuild

this ebuild adds selinux (thx to Andries) and adds the openldap (for the adventourous ones) and adds the with without patch (no use workarounds) 

again thx to the great work on squashing the last bugs to Andries
Comment 101 Mario Fetka (geos_one) 2010-03-20 14:03:13 UTC
Created attachment 224383 [details, diff]
389-ds-base/files/0001-Bug-480787-Autoconf-parameter-with-and-without.patch

the upstream patch for with and without
Comment 102 Mario Fetka (geos_one) 2010-03-20 14:05:26 UTC
Created attachment 224389 [details]
net-nds/389-ds-base/files/389-ds-base-1.2.6.a2-gentoo_selinux-1.patch

the combined selinux patch from Andreis

as usual this updated ebuilds are in my overlay

http://ftp.disconnected-by-peer.at/pub/overlay/geos_one-overlay.xml

happy testing
Comment 103 Fabio Erculiani (RETIRED) gentoo-dev 2010-06-21 14:34:14 UTC
I wonder if you guys are interested in merging this stuff into the Portage tree, or if there's already somebody willing do to that.
Comment 104 Fabio Erculiani (RETIRED) gentoo-dev 2010-07-07 14:33:26 UTC
Thanks, I took the maintainership of net-nds/389-ds-base and I merged it into tree.


--- ChangeLog   1970-01-01 01:00:00.000000000 +0100
+++ ChangeLog.new       2010-07-07 16:36:03.331952701 +0200
@@ -0,0 +1,15 @@
+# ChangeLog for net-nds/389-ds-base
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*389-ds-base-1.2.6_rc3 (07 Jul 2010)
+
+  07 Jul 2010; Fabio Erculiani <lxnay@gentoo.org>
+  +files/1.2.6/selinux_gentoo.patch, +files/1.2.6/selinux_makefile.patch,
+  +files/389-ds.initd, +files/389-ds-snmp.initd,
+  +389-ds-base-1.2.6_rc3.ebuild, +files/restart-dirsrv, +files/start-dirsrv,
+  +metadata.xml:
+  new ebuild, 389 Directory Server server package, thanks to
+  Andreis_Vinogradovs ( slepnoga ) <spamslepnoga@inbox.ru> for the base
+  ebuild, closing #309553
+

I am going to close this bug once all its bug dependencies are closed.
Comment 105 Mario Fetka (geos_one) 2010-07-07 14:45:08 UTC
(In reply to comment #104)
> Thanks, I took the maintainership of net-nds/389-ds-base and I merged it into
> tree.
> 
great news now after more then 3 years maintaining this ebuilds they went into portage year.
so all my hard work leads to success

OT: thx to all the testers that mailed me bugreports to get some errors fixed and also to upstream for help fixing some gentoo related bugs.
Comment 106 Fabio Erculiani (RETIRED) gentoo-dev 2010-07-07 15:02:09 UTC
Thanks to you again. I've been able to squash every bug, including the admin interface one, caused by improper usage of apache by upstream.
Comment 107 Fabio Erculiani (RETIRED) gentoo-dev 2010-07-11 10:26:26 UTC
Thank you guys, we can now (yay!) close this bug.
Enjoy 389 Directory Server in Gentoo and feel free to file bugs if you find something broken.