Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 103615 - [Future EAPI] unpack jar files
Summary: [Future EAPI] unpack jar files
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: PMS/EAPI
URL:
Whiteboard:
Keywords:
Depends on: 100584 100588
Blocks: future-eapi
  Show dependency tree
 
Reported: 2005-08-24 12:58 UTC by Daniel Hancock
Modified: 2012-11-26 05:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild.sh.unpack_jar.patch (ebuild.sh.unpack_jar.patch,315 bytes, patch)
2005-08-24 12:59 UTC, Daniel Hancock
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hancock 2005-08-24 12:58:54 UTC
Fuck sakes! Portage's unpack command can't even handle jar files. Find 
attached a patch for ebuild.sh. Serious fucking software for real 
mathematicians like Maple needs this functionality; FOSS crap for amateurs 
like dev-java/junit and dev-java/bluej-bin could benefit too.
Comment 1 Daniel Hancock 2005-08-24 12:59:26 UTC
Created attachment 66789 [details, diff]
ebuild.sh.unpack_jar.patch
Comment 2 Brian Harring gentoo-dev 2005-08-24 13:19:11 UTC
Amateurs?  Your behaviour/comments on this bug and others imply you to be the
amateur frankly- either that or attempting to get a rise out of people.

Discontinue that crap when asking others to help if you want people to do what
you request.  The attitude is a bit much considering your rant is over 4
characters nobody else has yet seen need to request.
Comment 3 SpanKY gentoo-dev 2005-08-24 14:16:40 UTC
this may cause regressions in java ebuilds which rely on fallback behavior of
portage to simply copy the .jar to $WORKDIR

those ebuilds are broken already imo though, so it doesnt matter to me
Comment 4 Brian Harring gentoo-dev 2005-08-26 20:18:32 UTC
This is requested for 100584, which has been slapped shut.
So... Stuart's patch ain't going in.
Comment 5 Zac Medico gentoo-dev 2010-09-29 16:40:22 UTC
Re-assigning to pms-bugs since this is conceivable for a future EAPI.
Comment 6 Christoph Junghans gentoo-dev 2012-08-31 23:20:15 UTC
Is this still an issue? Wouldn't that be a good candidate for unpacker.eclass?
Comment 7 Arfrever Frehtes Taifersar Arahesis 2012-11-26 04:11:17 UTC
This bug was fixed in:
http://git.overlays.gentoo.org/gitweb/?p=proj/pms.git;a=commitdiff;h=a686e410fd4d20f1d67b1c991936de78379d00c1

+\item[unpack] Unpacks a source archive into the current directory. Must be able to unpack the
+    following file formats, if the relevant binaries are available:
...
+    \item zip files (\t{*.zip, *.ZIP, *.jar}) (with \t{unzip} available)
Comment 8 SpanKY gentoo-dev 2012-11-26 05:54:50 UTC
looks like PMS includes this in EAPI=0 already

    \item zip files (\t{*.zip, *.ZIP, *.jar}). Ebuilds must ensure that Info-ZIP Unzip is installed.