Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 102502 - media-sound/idjc-0.8.7 - A DJ console for ShoutCast/IceCast streaming
Summary: media-sound/idjc-0.8.7 - A DJ console for ShoutCast/IceCast streaming
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
: 115095 302931 410007 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-14 08:27 UTC by Stephen Fairchild
Modified: 2016-10-12 00:21 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-sound/idjc/idjc-0.3.1.ebuild (idjc-0.3.1.ebuild,753 bytes, text/plain)
2005-08-14 08:35 UTC, Stephen Fairchild
Details
Version 0.4.0 of idjc (idjc-0.4.0.ebuild,753 bytes, text/plain)
2005-08-27 13:14 UTC, Stephen Fairchild
Details
media-sound/idjc/idjc-0.3.1.ebuild (revised) (idjc-0.3.1.ebuild,752 bytes, text/plain)
2005-08-28 10:53 UTC, Stephen Fairchild
Details
media-sound/idjc/idjc-0.4.0.ebuild (revised) (idjc-0.4.0.ebuild,752 bytes, text/plain)
2005-08-28 10:55 UTC, Stephen Fairchild
Details
media-sound/idjc-0.3.1.ebuild (with emake) (idjc-0.3.1.ebuild,754 bytes, text/plain)
2005-08-30 14:41 UTC, Stephen Fairchild
Details
media-sound/idjc-0.4.0 (ebuild with emake) (idjc-0.4.0.ebuild,754 bytes, text/plain)
2005-08-30 14:44 UTC, Stephen Fairchild
Details
idjc version 0.4.1 ebuild (idjc-0.4.1.ebuild,754 bytes, text/plain)
2005-09-02 14:30 UTC, Stephen Fairchild
Details
Updated ebuild for Version 0.5.8 (idjc-0.5.8.ebuild,1.24 KB, application/octet-stream)
2006-03-09 14:43 UTC, Dominik Stadler (RETIRED)
Details
Updated attachment for version 0.5.9 (idjc-0.5.9.ebuild,1.21 KB, text/plain)
2006-03-17 09:50 UTC, Stephen Fairchild
Details
Internet DJ Console version 0.6.4a ebuild (idjc-0.6.4a.ebuild,1.25 KB, text/plain)
2006-08-05 15:06 UTC, Stephen Fairchild
Details
Internet DJ Console version 0.6.7a (idjc-0.6.7a.ebuild,1.32 KB, text/plain)
2006-09-25 13:27 UTC, Stephen Fairchild
Details
Ebuild for IDJC version 0.6.7b (idjc-0.6.7b.ebuild,1.32 KB, text/plain)
2006-10-17 05:01 UTC, Stephen Fairchild
Details
idjc version 0.6.11 ebuild (idjc-0.6.11.ebuild,1.32 KB, text/plain)
2007-03-22 23:25 UTC, Stephen Fairchild
Details
Version 0.7.0b of IDJC (idjc-0.7.0b.ebuild,1.39 KB, text/plain)
2007-08-27 20:42 UTC, Stephen Fairchild
Details
Ebuild for IDJC version 0.7.3 (idjc-0.7.3.ebuild,1.38 KB, text/plain)
2008-02-29 21:56 UTC, Stephen Fairchild
Details
idjc-0.7.7.ebuild (idjc-0.7.7.ebuild,1.55 KB, text/plain)
2008-07-16 11:27 UTC, Lars Wendler (Polynomial-C)
Details
idjc-0.7.7.ebuild (idjc-0.7.7.ebuild,1.55 KB, text/plain)
2008-07-16 11:31 UTC, Lars Wendler (Polynomial-C)
Details
Ebuild for idjc-0.7.10 (idjc-0.7.10.ebuild,2.01 KB, text/plain)
2008-10-11 13:57 UTC, Marek Szuba
Details
idjc-0.8.1.ebuild (idjc-0.8.1.ebuild,2.01 KB, text/plain)
2010-03-19 17:28 UTC, Helmuth Schmelzer
Details
proposed ebuild (idjc-0.8.3.ebuild,1.94 KB, text/plain)
2010-09-01 09:23 UTC, Markos Chandras (RETIRED)
Details
idjc-0.8.7.patch (0001-media-sound-idjc-version-bump-0.8.7.patch,3.31 KB, patch)
2012-03-28 14:34 UTC, Pavlos Ratis (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Fairchild 2005-08-14 08:27:54 UTC
Internet DJ console is a graphical shoutcast/icecast client that runs under  
GTK+ and jack-audio-connection-kit.  
  
In short it's and internet radio app for making a live radio show.  
  
It's features include 2 main media players with crossfader.  A jingles player.  
Microphone signal processing (compressor and noise gate).  IRC track  
annoucements with X-Chat.  Automatic stream shut-off timer.  Mp3 or ogg  
streaming at various bitrates.  Aux input for connecting any audio app that is  
compatible with JACK.  And various audio level meters. 
 
I suggest media-sound/idjc for this ebuild.
Comment 1 Stephen Fairchild 2005-08-14 08:35:46 UTC
Created attachment 65937 [details]
media-sound/idjc/idjc-0.3.1.ebuild
Comment 2 Stephen Fairchild 2005-08-27 13:14:04 UTC
Created attachment 67030 [details]
Version 0.4.0 of idjc
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-08-27 13:22:42 UTC
Please, fix the foo.bar.com homepage ;) and remove the RESTRICT if it's not
needed, otherwise uncomment it. Thanks.
Comment 4 Stephen Fairchild 2005-08-28 09:59:28 UTC
Comment on attachment 65937 [details]
media-sound/idjc/idjc-0.3.1.ebuild

># Copyright 1999-2005 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>
>inherit eutils
>
>DESCRIPTION="Internet DJ Console"
>HOMEPAGE="http://www.freshmeat.net/projects/idjc"
>SRC_URI="http://www.onlymeok.nildram.co.uk/${P}.tar.gz"
>LICENSE="GPL-2"
>SLOT="0"
>KEYWORDS="~x86"
>IUSE=""
>
>
>DEPEND=">=media-sound/jack-audio-connection-kit-0.99.0-r1
>	>=media-libs/libshout-2.1"
>
>RDEPEND=">=dev-python/pygtk-2.6.1
>	>=media-sound/vorbis-tools-1.0.1
>        >=media-video/mplayer-1.0_pre6-r4
>        >=media-sound/mp3info-0.8.4-r1
>        >=media-sound/lame-3.96.1
>        >=media-sound/id3v2-0.1.11
>        >=media-libs/flac-1.1.1"
>
>src_compile() {
>	make || die "make failed"
>}
>
>src_install() {
>	make install || die
>}
Comment 5 Stephen Fairchild 2005-08-28 10:01:55 UTC
Comment on attachment 67030 [details]
Version 0.4.0 of idjc

># Copyright 1999-2005 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>
>inherit eutils
>
>DESCRIPTION="Internet DJ Console"
>HOMEPAGE="http://www.freshmeat.net/projects/idjc/"
>SRC_URI="http://www.onlymeok.nildram.co.uk/${P}.tar.gz"
>LICENSE="GPL-2"
>SLOT="0"
>KEYWORDS="~x86"
>IUSE=""
>
>
>DEPEND=">=media-sound/jack-audio-connection-kit-0.99.0-r1
>	>=media-libs/libshout-2.1"
>
>RDEPEND=">=dev-python/pygtk-2.6.1
>	>=media-sound/vorbis-tools-1.0.1
>        >=media-video/mplayer-1.0_pre6-r4
>        >=media-sound/mp3info-0.8.4-r1
>        >=media-sound/lame-3.96.1
>        >=media-sound/id3v2-0.1.11
>        >=media-libs/flac-1.1.1"
>
>src_compile() {
>	make || die "make failed"
>}
>
>src_install() {
>	make install || die
>}
Comment 6 Stephen Fairchild 2005-08-28 10:01:56 UTC
Comment on attachment 67030 [details]
Version 0.4.0 of idjc

># Copyright 1999-2005 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>
>inherit eutils
>
>DESCRIPTION="Internet DJ Console"
>HOMEPAGE="http://www.freshmeat.net/projects/idjc/"
>SRC_URI="http://www.onlymeok.nildram.co.uk/${P}.tar.gz"
>LICENSE="GPL-2"
>SLOT="0"
>KEYWORDS="~x86"
>IUSE=""
>
>
>DEPEND=">=media-sound/jack-audio-connection-kit-0.99.0-r1
>	>=media-libs/libshout-2.1"
>
>RDEPEND=">=dev-python/pygtk-2.6.1
>	>=media-sound/vorbis-tools-1.0.1
>        >=media-video/mplayer-1.0_pre6-r4
>        >=media-sound/mp3info-0.8.4-r1
>        >=media-sound/lame-3.96.1
>        >=media-sound/id3v2-0.1.11
>        >=media-libs/flac-1.1.1"
>
>src_compile() {
>	make || die "make failed"
>}
>
>src_install() {
>	make install || die
>}
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-08-28 10:31:52 UTC
Please, attach a fixed ebuild and mark the previous one as obsolete, don't edit
this inline, this creates just a mess in the bug.
Comment 8 Stephen Fairchild 2005-08-28 10:53:59 UTC
Created attachment 67096 [details]
media-sound/idjc/idjc-0.3.1.ebuild (revised)

Fixed the homepage and removed the RESTRICT line.
Comment 9 Stephen Fairchild 2005-08-28 10:55:21 UTC
Created attachment 67097 [details]
media-sound/idjc/idjc-0.4.0.ebuild (revised)

Fixed the homepage and removed the RESTRICT line.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2005-08-30 06:10:49 UTC
Is there any reason to use make instead of emake in src_compile()? If so, then
include a comment explaining why emake does not work.
Comment 11 Stephen Fairchild 2005-08-30 14:41:22 UTC
Created attachment 67295 [details]
media-sound/idjc-0.3.1.ebuild (with emake)
Comment 12 Stephen Fairchild 2005-08-30 14:44:21 UTC
Created attachment 67296 [details]
media-sound/idjc-0.4.0 (ebuild with emake)
Comment 13 Stephen Fairchild 2005-09-01 02:47:11 UTC
mplayer-1.0_pre7-r1 is broken with respect to idjc for 2 reasons. 
 
Reason 1: bug 104456, which I filed myself. 
 
Reason 2: the -aofile and -nowaveheader options are "deprecated". In actual 
fact using either of these options will cause mplayer to exit with a 
deprecation error message.  The correct term to use would be obsolete. 
 
The new format is '-ao pcm:file="filename":nowaveheader'.  Unfortunately this 
can't be used with the previous version of mplayer. 
Comment 14 Stephen Fairchild 2005-09-02 14:30:18 UTC
Created attachment 67507 [details]
idjc version 0.4.1 ebuild

This release makes idjc compatible with the version of mplayer currently in
portage stable.  It retains compatibility with the previous versions of mplayer
also.
Comment 15 Dominik Stadler (RETIRED) gentoo-dev 2006-03-09 14:43:18 UTC
Created attachment 81807 [details]
Updated ebuild for Version 0.5.8

I tried to update the ebuild to Version 0.5.8
Comment 16 Dominik Stadler (RETIRED) gentoo-dev 2006-03-09 14:43:55 UTC
*** Bug 115095 has been marked as a duplicate of this bug. ***
Comment 17 Stephen Fairchild 2006-03-17 09:50:41 UTC
Created attachment 82393 [details]
Updated attachment for version 0.5.9
Comment 18 Stephen Fairchild 2006-08-05 15:06:48 UTC
Created attachment 93545 [details]
Internet DJ Console version 0.6.4a ebuild

Prospective maintainers please read this independent review: http://www.softpedia.com/reviews/linux/Internet-DJ-Console-Review-27569.shtml
Comment 19 Stephen Fairchild 2006-09-25 13:27:52 UTC
Created attachment 98063 [details]
Internet DJ Console version 0.6.7a
Comment 20 Stephen Fairchild 2006-10-17 05:01:59 UTC
Created attachment 99871 [details]
Ebuild for IDJC version 0.6.7b
Comment 21 Stephen Fairchild 2007-03-22 23:25:58 UTC
Created attachment 114086 [details]
idjc version 0.6.11 ebuild
Comment 22 Stephen Fairchild 2007-08-27 20:42:55 UTC
Created attachment 129364 [details]
Version 0.7.0b of IDJC

This version adds support for streaming to multiple servers at various bitrates in Ogg and mp3 format simultaneously if the user so chooses. Includes two stream recorders. Supports on-air bitrate changes.
Comment 23 Stephen Fairchild 2008-02-29 21:56:30 UTC
Created attachment 144971 [details]
Ebuild for IDJC version 0.7.3
Comment 24 CJ Kucera 2008-07-15 22:06:16 UTC
FWIW, this is up to 0.7.8a now (or 0.7.7 for the most recently-released version)...  Looks like the 0.7.3 ebuild above works just fine on it.

One thing I did notice was that the program will exit out right away if the environment var $LANG isn't specified when the program's run, so that might be something extra to note.
Comment 25 Alexis Ballier gentoo-dev 2008-07-16 10:53:17 UTC
still fails with recent ffmpeg here :(

if x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -Wall -std=gnu99 -O2       -I/usr/include/dirac   -I/usr/include/dirac    -march=athlon64 -O2 -pipe -g -ggdb -MT idjcmixer-compressor.o -MD -MP -MF ".deps/idjcmixer-compressor.Tpo" -c -o idjcmixer-compressor.o `test -f 'compressor.c' || echo './'`compressor.c; \
	then mv -f ".deps/idjcmixer-compressor.Tpo" ".deps/idjcmixer-compressor.Po"; else rm -f ".deps/idjcmixer-compressor.Tpo"; exit 1; fi
In file included from idjcmixer.c:46:
avcodecdecode.h:25:28: error: ffmpeg/avcodec.h: No such file or directory
avcodecdecode.h:26:29: error: ffmpeg/avformat.h: No such file or directory
distcc[18308] ERROR: compile idjcmixer.c on psyche-fbsd/1 failed
make[2]: *** [idjcmixer-idjcmixer.o] Error 1
Comment 26 Lars Wendler (Polynomial-C) gentoo-dev 2008-07-16 11:27:51 UTC
Created attachment 160541 [details]
idjc-0.7.7.ebuild

This ebuild should work with latest ffmpeg from ~arch. As this is another "automagic" dependency, I put ffmpeg into DEPEND without the ability to disable it via USE flag.
Comment 27 Lars Wendler (Polynomial-C) gentoo-dev 2008-07-16 11:31:12 UTC
Created attachment 160542 [details]
idjc-0.7.7.ebuild

Same ebuild but with fixed IUSE
Comment 28 Marek Szuba archtester gentoo-dev 2008-10-11 13:57:23 UTC
Created attachment 168032 [details]
Ebuild for idjc-0.7.10

Attached you will find an ebuild for idjc-0.7.10. All optional components depend on appropriate USE flags now, most of them global. Note that disabling the flags "flac" and/or "speex" does NOT stop idjc getting linked against respective libraries if they are present in the system, as configure appears to accept no options which could stop this.
Comment 29 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-11 17:01:56 UTC
If so the USE flags for flac and speex should be removed and the dep should be mandatory, or the configure fixed:
http://www.gentoo.org/proj/en/qa/automagic.xml
Comment 30 Justin Lecher (RETIRED) gentoo-dev 2010-01-31 15:16:26 UTC
*** Bug 302931 has been marked as a duplicate of this bug. ***
Comment 31 Justin Lecher (RETIRED) gentoo-dev 2010-01-31 15:17:10 UTC
Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Thanks,
On behalf of the Gentoo Sunrise Team,
Justin.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 32 Ivan c00kiemon5ter Kanakarakis 2010-03-19 15:17:25 UTC
Is this package going into sunrise any time soon ? 

On http://sourceforge.net/projects/idjc/files/ latest version is idjc-0.8.1.tar.gz

@Marek Szuba 
do you own an overlay to install via layman, so that I can get the ebuild or should I set up a local overlay for this ?
Comment 33 Samuli Suominen (RETIRED) gentoo-dev 2010-03-19 15:19:32 UTC
(In reply to comment #32)
> Is this package going into sunrise any time soon ? 

Sunrise is a user overlay, so it's really up to e.g. you. Write a ebuild, read the sunrise faq, join #gentoo-sunrise on IRC, Freenode, and get your ebuild reviewed and committed
Comment 34 Helmuth Schmelzer 2010-03-19 17:28:07 UTC
Created attachment 224261 [details]
idjc-0.8.1.ebuild

ebuild for the latest version of idjc available idjc-0.8.1, the ebuild already been tested in my local overlay and it works fine:)
Comment 35 Markos Chandras (RETIRED) gentoo-dev 2010-09-01 09:23:50 UTC
Created attachment 245569 [details]
proposed ebuild

I cleaned up the ebuild. Migrated to EAPI=2. Drop obsolete useflags and dependencies. It needs some further testing before reaching the tree. If anyone of you wants to become proxy maintainer for that I will be glad to help. Thanks
Comment 36 Pavlos Ratis (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-03-28 14:34:32 UTC
Created attachment 306983 [details, diff]
idjc-0.8.7.patch

Bumped to 0.8.7
Comment 37 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-03-28 14:35:59 UTC
*** Bug 410007 has been marked as a duplicate of this bug. ***
Comment 38 Pavlos Ratis (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2012-03-28 14:39:33 UTC
(In reply to comment #36)
> Created attachment 306983 [details, diff] [details, diff]
> idjc-0.8.7.patch
> 
> Bumped to 0.8.7

Also changed EAPI=2 to EAPI=4 and PYTHON_DEPEND at least 2.6 and not 3.0
Comment 40 Marek Szuba archtester gentoo-dev 2016-09-08 10:45:57 UTC
Upstream still looks very much alive, with considerable changes - the major one being that it now requires a modified version of libshout for which we would also require an ebuild. Alas, I am no longer interested in IDJC so I would rather not maintain it. Is there any other user demand for it?

Alternatively: Stephen, perhaps you would like to maintain IDJC-related ebuilds yourself? Gentoo has a dedicated team [1] responsible for the handling of changes user-maintained packages - and given you are the upstream developer of IDJC, it would definitely make sense to leave the ebuilds in your hands as well.

[1] https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers