Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 104456 - mplayer crashes when you specify a resample value that matches the actual sample rate
Summary: mplayer crashes when you specify a resample value that matches the actual sam...
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-01 01:53 UTC by Stephen Fairchild
Modified: 2006-08-05 15:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Fairchild 2005-09-01 01:53:00 UTC
media-video/mplayer-1.0_pre7-r1 crashes when you specify a resample value that  
matches the actual sample rate.  This is a new bug introduced in this package  

Reproducible: Always
Steps to Reproduce:
mplayer musicfile.mp3 -af resample=44100  
 
In order to reproduce the bug the music file needs to have a sample rate of 
44100. 
Actual Results:  
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le... 
 
 
MPlayer interrupted by signal 11 in module: af_preinit 
- MPlayer crashed by bad usage of CPU/FPU/RAM. 
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and 
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash. 
- MPlayer crashed. This shouldn't happen. 
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your 
  gcc version. If you think it's MPlayer's fault, please read 
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and 
  won't help unless you provide this information when reporting a possible bug. 
 

Expected Results:  
It should have played the music file.  The previous version worked just fine. 

This bug can be worked around by specifying 44101 as the sample rate.  
Specifying 48000 for a music file with a sample rate of 48000 also triggers 
this bug.
Comment 1 Steve Dibb (RETIRED) gentoo-dev 2006-06-21 17:06:26 UTC
Stephen, has this been fixed in newer versions?  If not, post your emerge --info
Comment 2 Steve Dibb (RETIRED) gentoo-dev 2006-06-22 08:10:53 UTC
resolving as needinfo
Comment 3 Stephen Fairchild 2006-08-05 15:14:33 UTC
(In reply to comment #2)
> resolving as needinfo
> 
All newer versions work just fine.