Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 84707

Summary: toolchain-binutils doesnt like re-emerges
Product: Gentoo Linux Reporter: Ralph Henneberger <ralix>
Component: New packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED WORKSFORME    
Severity: blocker CC: chris, christian, Heikki.Pernu, info, nathan
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: This shows the emerge removing the soft links.

Description Ralph Henneberger 2005-03-09 23:41:53 UTC
I have emerge binutils-2.15.92.0.2-r5. Than all emerge get errors : for example :  net-print/libgnomecups-0.2.0 and all others 

configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... :
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... Invalid configuration `i686-pc-linux-oldld': machine `i686-pc-linux' not recognized
configure: error: /bin/sh ./config.sub i686-pc-linux-oldld failed

emerge --info
Portage 2.0.51.19 (default-linux/x86/2004.2, gcc-3.4.3, glibc-2.3.4.20050125-r0, 2.6.11 i686)
=================================================================
System uname: 2.6.11 i686 Intel(R) Pentium(R) M processor 1.70GHz
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 18 2005, 06:11:15)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.6.3, 1.5, 1.8.5-r3, 1.7.9-r1, 1.4_p6, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r5
sys-devel/libtool:   1.5.10-r5
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium-m -pipe -O2 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium-m -pipe -O2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="de_DE@euro"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/local /usr/local/overlays/gentoo-de"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib alsa apm arts avi berkdb bitmap-fonts bonobo breakme cdr chroot crypt cups curl dvd emboss encode esd evo fam flac font-server foomaticdb fortran gcj gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml imagemagick imap imlib ipv6 java jpeg junit libg++ libwww mad maildir mikmod mldonkeypango mmx motif mozilla moznocompose moznoirc moznomail mp3 mpeg ncurses nls nptl oggvorbis opengl oss pam pdflib perl png python quicktime readline samba sdl shadow slang spell sse ssl svga tcltk tcpd tiff transcode truetype truetype-fonts type1-fonts wxwindows xml xml2 xmms xprint xv zlib linguas_de"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS
----------------------------------------------------------------------------
Then i emerge -K =binutils-2.14.90.0.8-r1 , all builds works fine.



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 SpanKY gentoo-dev 2005-03-12 14:54:01 UTC
*** Bug 84748 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Gabert (RETIRED) gentoo-dev 2005-03-13 19:55:56 UTC
hi, can you say if you have a binutils-config installed and are switched to the right binutils?

information about binutils-config can be found here:

http://www.gentoo-portage.com/sys-devel/binutils-config

Utility to change the binutils version being used

Probably there was just a mistake in the upgrade progress and you could intervene and try to fix it manually now,

Please report back to this bug report.

Thanks in advance,

Alex
Comment 3 SpanKY gentoo-dev 2005-03-14 08:58:44 UTC
there was a bug in toolchain-binutils.eclass but azarah fixed it ... i'm not sure if existing users will have that bug fix propogated to their installed ebuilds or not though :/
Comment 4 Nathan Sullivan 2005-03-14 16:29:27 UTC
*** Bug 85139 has been marked as a duplicate of this bug. ***
Comment 5 SpanKY gentoo-dev 2005-03-17 12:07:32 UTC
*** Bug 85598 has been marked as a duplicate of this bug. ***
Comment 6 Tom Howland 2005-04-09 00:02:20 UTC
Created attachment 55738 [details]
This shows the emerge removing the soft links.

I believe this happens when there is more than one binutils installed.
Comment 7 Tom Howland 2005-04-09 00:04:39 UTC
Comment on attachment 55738 [details]
This shows the emerge removing the soft links.

The sym links to ld, as, etc are removed but never replaced.
Comment 8 SpanKY gentoo-dev 2005-04-09 11:29:53 UTC
that's normal ... binutils-config will generate all the things you need in $PATH and such
Comment 9 SpanKY gentoo-dev 2005-04-09 18:02:10 UTC
*** Bug 88526 has been marked as a duplicate of this bug. ***
Comment 10 SpanKY gentoo-dev 2005-05-07 18:15:08 UTC
seems to be all set now