Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 85139 - gettext-0.14.2 fails to build due to invalid build system type in configure
Summary: gettext-0.14.2 fails to build due to invalid build system type in configure
Status: RESOLVED DUPLICATE of bug 84707
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-13 14:52 UTC by Nathan Sullivan
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
my bad :) heres the log (config.log,5.30 KB, text/plain)
2005-03-13 15:03 UTC, Nathan Sullivan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Sullivan 2005-03-13 14:52:37 UTC
gettext-0.14.2 fails during configure, as it cannot recognise i686-pc-linux as a build system type...

Reproducible: Always
Steps to Reproduce:
1. emerge gettext
2.
3.

Actual Results:  
failed ebuild.

Expected Results:  
successful emerge/compile.

>>> Source unpacked.
 * econf: updating
gettext-0.14.2/gettext-tools/examples/hello-c++-kde/admin/config.guess with
/usr/share/gnuconfig/config.guess
 * econf: updating
gettext-0.14.2/gettext-tools/examples/hello-c++-kde/admin/config.sub with
/usr/share/gnuconfig/config.sub
 * econf: updating gettext-0.14.2/config/config.guess with
/usr/share/gnuconfig/config.guess
 * econf: updating gettext-0.14.2/config/config.sub with
/usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --without-java --without-included-gettext --enable-nls
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... :
checking build system type... Invalid configuration `i686-pc-linux-oldld':
machine `i686-pc-linux' not recognized
configure: error: /bin/sh config/config.sub i686-pc-linux-oldld failed

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/gettext-0.14.2/work/gettext-0.14.2/config.log

!!! ERROR: sys-devel/gettext-0.14.2 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

====================================================

Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.4.3-20050110,
glibc-2.3.4.20050125-r0, 2.6.11-gentoo-r2 i686)
=================================================================
System uname: 2.6.11-gentoo-r2 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Mar  9 2005, 19:44:30)]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r5
sys-devel/libtool:   1.5.10-r5
virtual/os-headers:  2.4.22-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirror.isp.net.au/ftp/pub/gentoo
http://public.planetmirror.com/pub/gentoo http://mirror.gentoo.gr.jp
ftp://gg3.net/pub/linux/gentoo http://ftp-mirror.internap.com/pub/gentoo
ftp://gentoo.agsn.ca/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://172.17.0.1/portage"
USE="acl acpi alsa apache2 apm avi bitmap-fonts crypt curl devfs26 emboss encode
fam font-server foomaticdb fortran ftp gd gif gpm imap imlib ipv6 kerberos ldap
libg++ libwww mad mikmod mmx motif mp3 mpeg mysql ncurses nls oav oggvorbis oss
pam pdflib perl python quicktime readline sdl session slang snmp sockets spell
ssl svga tcpd truetype truetype-fonts type1-fonts usb userlocales x86 xml2
xmlrpc xmms xv zaptel zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Martin Schlemmer (RETIRED) gentoo-dev 2005-03-13 14:57:22 UTC
Please attach the config.log as the error message directed.
Comment 2 Nathan Sullivan 2005-03-13 15:03:58 UTC
Created attachment 53367 [details]
my bad :) heres the log
Comment 3 Nathan Sullivan 2005-03-13 17:00:42 UTC
log added.
Comment 4 SpanKY gentoo-dev 2005-03-13 21:01:24 UTC
what version of sys-devel/gnuconfig ?

what does `sh /usr/share/gnuconfig/config.guess` display ?
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2005-03-14 00:36:48 UTC
Please attach output of:


  # cd /; ld --help 2>&1 sed -ne '/supported emulations:/!d;s/[ ][ ]*/ /g; s/.*supported emulations: *//; s/ .*//'
Comment 6 Martin Schlemmer (RETIRED) gentoo-dev 2005-03-14 00:38:12 UTC
I am assuming config.guess display the `i686-pc-linux-oldld'.
Comment 7 Nathan Sullivan 2005-03-14 14:45:12 UTC
gnuconfig version is 20050223

sh /usr/share/gnuconfig/config.guess results in i686-pc-linux-oldld

btw, something weird i noticed....

/ # ld
bash: ld: command not found

last i remember ld should be there somewhere :)
Comment 8 SpanKY gentoo-dev 2005-03-14 15:15:59 UTC
if you run `binutils-config 1`, does `ld` and such work again ?
Comment 9 Nathan Sullivan 2005-03-14 16:29:27 UTC
yep, resolved. not sure where that issue originated...

as SpanKY said, this was related to a previous bug with toolchain-binutils.eclass

*** This bug has been marked as a duplicate of 84707 ***