Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 85598 - /usr/bin/ar missing from my system
Summary: /usr/bin/ar missing from my system
Status: RESOLVED DUPLICATE of bug 84707
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-17 01:45 UTC by Chris Moody - Linux Architect
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Moody - Linux Architect 2005-03-17 01:45:04 UTC
emerge -u runs into bison-2.0.  I see the following results:
##########
if i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..     -march=pentium2 -O3 -pipe -MT xalloc-die.o -MD -MP -MF ".deps/xalloc-die.Tpo" -c -o xalloc-die.o xalloc-die.c; \
then mv -f ".deps/xalloc-die.Tpo" ".deps/xalloc-die.Po"; else rm -f ".deps/xalloc-die.Tpo"; exit 1; fi
if i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..     -march=pentium2 -O3 -pipe -MT xstrndup.o -MD -MP -MF ".deps/xstrndup.Tpo" -c -o xstrndup.o xstrndup.c; \
then mv -f ".deps/xstrndup.Tpo" ".deps/xstrndup.Po"; else rm -f ".deps/xstrndup.Tpo"; exit 1; fi
rm -f liby.a
ar cru liby.a main.o yyerror.o 
make[3]: ar: Command not found
make[3]: *** [liby.a] Error 127
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/bison-2.0/work/bison-2.0/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/bison-2.0/work/bison-2.0/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/bison-2.0/work/bison-2.0'
make: *** [all] Error 2
##########

so, something in the bison build is calling "ar" as a command.

Here is this system's emerge info:
##########
flipper ~ # emerge info
Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.4.3, glibc-2.3.4.20041102-r0, 2.6.7-hardened-r18 i686)
=================================================================
System uname: 2.6.7-hardened-r18 i686 Pentium II (Deschutes)
Gentoo Base System version 1.6.8
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Dec 30 2004, 18:43:35)]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.8.5-r2, 1.6.3, 1.7.9, 1.4_p6, 1.9.3
sys-devel/binutils:  2.15.92.0.2-r6
sys-devel/libtool:   1.5.10-r2
virtual/os-headers:  2.4.22
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium2 -O3 -pipe"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium2 -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://192.168.1.10/portage"
USE="x86 X acl apache2 apm arts avi berkdb bitmap-fonts crypt cups emboss encode font-server foomaticdb fortran gd gdbm gif gnome gpm gps gtk gtk2 imlib ipv6 java jpeg kde ldap libg++ libwww mad mikmod motif mp3 mpeg mysql ncurses nls odbc oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sasl sdl snmp spell ssl svga tcpd tiff truetype truetype-fonts type1-fonts xml xml2 xmms xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
##########


Reproducible: Always
Steps to Reproduce:
1. emerge sync to my local mirror
2. emerge -u world
3. bison-2.0 starts to build...and dies




I will admit that this system needed help earlier today to recover from the
issues relayed in
"http://forums.gentoo.org/viewtopic-t-306469-highlight-aprutil.html?sid=9fa9120665659d1e166c6beecee8692b"
binutils and gcc needed fixed.

However, after successfully repairing gcc to a working state, emerge
successfully built the newest gcc and binutils with -0- error (nice work folks)
and worked to get several other outdated ebuilds up to date.
Comment 1 SpanKY gentoo-dev 2005-03-17 06:55:05 UTC
try running `binutils-config 1 && emerge bison && emerge binutils && emerge bison`
Comment 2 SpanKY gentoo-dev 2005-03-17 12:07:32 UTC

*** This bug has been marked as a duplicate of 84707 ***