Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 582524

Summary: sys-devel/gcc[vtv]: libstdc++ insecure RUNPATH
Product: Gentoo Linux Reporter: Jonas Stein <jstein>
Component: Current packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED FIXED    
Severity: normal CC: andrewammerlaan, conikost, corbinbird, d0.paddy, eil.jan, hololeap, itumaykin+gentoo, jstein, mail, mgorny, pbrilius, perfect007gentleman, salikov.alexey, silmano, sliwa, slyfox, srcshelton, tsmksubc, vaibhav.niku, waebbl-gentoo
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://gcc.gnu.org/PR85884
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log.xz

Description Jonas Stein gentoo-dev 2016-05-09 09:20:09 UTC
[..]
>>> Completed installing gcc-4.9.3 into /var/tmp/portage/sys-devel/gcc-4.9.3/image/

 * Final size of build directory: 2046584 KiB
 * Final size of installed tree: 272604 KiB

Fixing .la files
   usr/lib64/gcj-4.9.3-15/libjvm.la
   usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/libgij.la
   usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/libgfortran.la
   usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/libgcj-tools.la
   usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libgij.la
   usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libgfortran.la
   usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libgcj-tools.la
   usr/lib32/gcj-4.9.3-15/libjvm.la
Auto fixing rpaths for /var/tmp/portage/sys-devel/gcc-4.9.3/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libstdc++.so.6.0.20
Auto fixing rpaths for /var/tmp/portage/sys-devel/gcc-4.9.3/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/libstdc++.so.6.0.20

 * QA Notice: The following files contain insecure RUNPATHs
 *  Please file a bug about this at http://bugs.gentoo.org/
 *  with the maintaining herd of the package.
 *   /var/tmp/portage/sys-devel/gcc-4.9.3/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libstdc++.so.6.0.20
 *   /var/tmp/portage/sys-devel/gcc-4.9.3/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/libstdc++.so.6.0.20
 *
Comment 1 SpanKY gentoo-dev 2016-05-09 17:02:10 UTC
you must attach full build logs in all of your reports, as well as emerge info
Comment 2 SpanKY gentoo-dev 2016-05-12 02:32:33 UTC
Created attachment 434018 [details]
build.log.xz
Comment 3 Jonas Stein gentoo-dev 2016-05-12 12:38:56 UTC
Spanky, I did not expect useful information in the other lines, but I agree, that it is better to attach it completely. Thank you for doing this in my place.
Best, JS
Comment 4 SpanKY gentoo-dev 2016-05-12 21:33:06 UTC
seems to only happen when building w/USE=vtv.  at least, that's what the bad rpaths are pointing to.  not sure why the QA log didn't show that in the first place.  i'll fix up portage.
Comment 5 SpanKY gentoo-dev 2016-05-12 22:10:37 UTC
rpath output is improved here:
https://gitweb.gentoo.org/proj/portage.git/commit/?id=9266e8e8d5709b9046e085baf3521a9e7a744d5b

but that doesn't explain why libstdc++ is linking/caring about libvtv in the first place
Comment 6 Coacher 2016-06-14 08:29:59 UTC
*** Bug 585902 has been marked as a duplicate of this bug. ***
Comment 7 Perfect Gentleman 2016-06-14 11:31:54 UTC
so that is not a bug ?
Comment 8 D'juan McDonald (domhnall) 2017-01-14 02:26:44 UTC
 emerge --info https://paste.pound-python.org/show/ouINVoJzDU7327M8i86W/

same issue on gcc 4.9.4
Comment 9 D'juan McDonald (domhnall) 2017-01-14 02:32:37 UTC
(In reply to Dajuan Mcdonald from comment #8)
>  emerge --info https://paste.pound-python.org/show/ouINVoJzDU7327M8i86W/
> 
> same issue on gcc 4.9.4

QA Notice: The following files contain insecure RUNPATHs
 Please file a bug about this at http://bugs.gentoo.org/
 with the maintainer of the package.
  /var/tmp/portage/sys-devel/gcc-4.9.4/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/32/libstdc++.so.6.0.20
    RPATH: /var/tmp/portage/sys-devel/gcc-4.9.4/work/build/x86_64-pc-linux-gnu/32/libstdc++-v3/../libvtv/.libs
  /var/tmp/portage/sys-devel/gcc-4.9.4/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6.0.20
    RPATH: /var/tmp/portage/sys-devel/gcc-4.9.4/work/build/x86_64-pc-linux-gnu/libstdc++-v3/../libvtv/.libs
Comment 10 SpanKY gentoo-dev 2017-02-15 08:42:02 UTC
*** Bug 605286 has been marked as a duplicate of this bug. ***
Comment 11 Arfrever Frehtes Taifersar Arahesis 2017-02-27 19:18:46 UTC
*** Bug 611124 has been marked as a duplicate of this bug. ***
Comment 12 Coacher 2017-04-18 15:06:26 UTC
*** Bug 615934 has been marked as a duplicate of this bug. ***
Comment 13 Arfrever Frehtes Taifersar Arahesis 2017-05-13 05:57:22 UTC
*** Bug 618188 has been marked as a duplicate of this bug. ***
Comment 14 Coacher 2017-06-05 13:27:27 UTC
*** Bug 620890 has been marked as a duplicate of this bug. ***
Comment 15 Bernd 2017-11-24 22:27:32 UTC
Same issue on gcc-6.4.0 when updating form 5.4.0-r3:

Fixing .la files
   usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/libcilkrts.la
Auto fixing rpaths for /var/tmp/portage/sys-devel/gcc-6.4.0/image/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/libstdc++.so.6.0.22

 * QA Notice: The following files contain insecure RUNPATHs
 *  Please file a bug about this at https://bugs.gentoo.org/
 *  with the maintainer of the package.
 *   /var/tmp/portage/sys-devel/gcc-6.4.0/image/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/libstdc++.so.6.0.22
 *     RPATH: /var/tmp/portage/sys-devel/gcc-6.4.0/work/build/x86_64-pc-linux-gnu/libstdc++-v3/../libvtv/.libs
 * 


morgaine /etc # emerge --info =gcc-6.4.0
Portage 2.3.13 (python 3.5.4-final-0, hardened/linux/amd64/no-multilib, gcc-5.4.0, glibc-2.25-r9, 4.13.8-pentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.13.8-pentoo-x86_64-AMD_Athlon-tm-_II_X2_255_Processor-with-gentoo-2.4.1
KiB Mem:     3518200 total,   2559492 free
KiB Swap:    8388604 total,   8384764 free
Timestamp of repository gentoo: Fri, 24 Nov 2017 18:45:01 +0000
Head commit of repository gentoo: 41682d1eb1c6fba307b3c3b0b2cce8607f2d2432
Timestamp of repository pentoo: Wed, 22 Nov 2017 16:01:46 +0000
Head commit of repository pentoo: f312ae9c6ddeb903225a5172d9ba8ac6dbc68e1d

sh bash 4.3_p48-r1
ld GNU gold (Gentoo 2.29.1 p3 2.29.1) 1.14
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo, 3.5.4::gentoo, 3.6.3::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.8::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://mirror.manitu.net/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 

pentoo
    location: /usr/src/pentoo
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/pentoo.git
    masters: gentoo

Installed sets: @base, @blender, @cloud, @dep-kernel, @keep, @media, @net, @sys, @text, @virt
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=n --complete-graph --keep-going"
FCFLAGS="-O2 -pipe -march=native"
FEATURES="assume-digests binpkg-logs buildsyspkg candy cgroup clean-logs config-protect-if-modified distlocks downgrade-backup ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=native"
GENTOO_MIRRORS="http://mirror.manitu.net/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb branding bzip2 cli cracklib crypt cxx dbus dri gdbm hardened iconv idn ipv6 justify modules ncurses nls nptl openmp pam pcre pie python readline seccomp session ssl ssp tcpd udev unicode urandom xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext popcnt sse sse2 sse3 sse4a" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en en_US de de_DE" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US de de_DE" NGINX_MODULES_HTTP="access auth_basic auth_pam autoindex browser charset empty_gif fancyindex fastcgi geo geoip gunzip gzip gzip_static headers_more image_filter limit_conn limit_req map memc memcached metrics mp4 naxsi proxy push_stream referer rewrite scgi secure_link split_clients ssi stub_status sub upload_progress upstream_hash upstream_ip_hash upstream_keepalive upstream_least_conn upstream_zone userid uwsgi xslt" NGINX_MODULES_STREAM="access geo geoip limit_conn map return split_clients ssl_preread upstream_hash upstream_least_conn upstream_zone" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" QEMU_SOFTMMU_TARGETS="aarch64 arm i386 x86_64" QEMU_USER_TARGETS="aarch64 arm armeb i386 x86_64" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-devel/gcc-6.4.0::gentoo was built with the following:
USE="cilk cxx fortran graphite hardened nls nptl openmp pgo (pie) (ssp) vtv (-altivec) (-awt) -debug -doc (-fixed-point) (-gcj) -go (-jit) (-libssp) -mpx (-multilib) -objc -objc++ -objc-gc (-pch) -regression-test (-sanitize) -vanilla"
Comment 16 Garri 2017-12-14 18:39:20 UTC
Got it too:

sys-devel/gcc-7.2.0: The following files contain insecure RUNPATHs:

  /var/tmp/portage/sys-devel/gcc-7.2.0/image/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/libstdc++.so.6.0.24
    RPATH: /var/tmp/portage/sys-devel/gcc-7.2.0/work/build/x86_64-pc-linux-gnu/libstdc++-v3/../libvtv/.libs
  /var/tmp/portage/sys-devel/gcc-7.2.0/image/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/32/libstdc++.so.6.0.24
    RPATH: /var/tmp/portage/sys-devel/gcc-7.2.0/work/build/x86_64-pc-linux-gnu/32/libstdc++-v3/../libvtv/.libs


Thanks.
Comment 17 Arfrever Frehtes Taifersar Arahesis 2018-01-12 17:21:39 UTC
*** Bug 644294 has been marked as a duplicate of this bug. ***
Comment 18 SpanKY gentoo-dev 2018-01-20 18:30:57 UTC
*** Bug 644904 has been marked as a duplicate of this bug. ***
Comment 19 Sergei Trofimovich (RETIRED) gentoo-dev 2018-01-20 20:59:53 UTC
(In reply to SpanKY from comment #5)
> rpath output is improved here:
> https://gitweb.gentoo.org/proj/portage.git/commit/
> ?id=9266e8e8d5709b9046e085baf3521a9e7a744d5b
> 
> but that doesn't explain why libstdc++ is linking/caring about libvtv in the
> first place

Why linking (mechanically):

./configure unconditionally injects -rpath into LDFLAGS at:

https://gcc.gnu.org/git/?p=gcc.git;a=blob;f=libstdc%2B%2B-v3/acinclude.m4;h=3bd669a4cc8f5ca07347528b608882e43693a92e;hb=HEAD#l2769

libstdc++-v3/acinclude.m4;h
2753   if test $enable_vtable_verify = yes; then
...
2768       *)
2769         VTV_CXXFLAGS="-fvtable-verify=std -Wl,-u_vtable_map_vars_start,-u_vtable_map_vars_end"
2770         VTV_CXXLINKFLAGS="-L${toplevel_builddir}/libvtv/.libs -Wl,--rpath -Wl,${toplevel_builddir}/libvtv/.libs"
2771         ;;
2772     esac

and uses it in make at:

https://gcc.gnu.org/git/?p=gcc.git;a=blob;f=libstdc%2B%2B-v3/src/Makefile.am;h=ba30dde8fecbef2990f89d12e0729f3727d86b00;hb=HEAD#l220

libstdc++-v3/src/Makefile.am
 216 CXXLINK = \
 ...
 220         $(VTV_CXXLINKFLAGS) \

All of it was added in the initial commit of VTV support: https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=b710ec859aae2bc828140010517b8b5855ace5ef

Why caring: I think libstdc++ does not care about libvtv and it's a bug to try to link against it.

libstdc++ is supposed to export new functions:

+    # Virtual table verification stub functions.
+    _Z17__VLTRegisterPair*;
+    _Z22__VLTRegisterPairDebug*;
+    _Z16__VLTRegisterSet*;
+    _Z21__VLTRegisterSetDebug*;
+    _Z24__VLTVerifyVtablePointer*;
+    _Z29__VLTVerifyVtablePointerDebug*;
+    __VLTChangePermission;

but these are defined as weak no-op symbols in libsupc++.
Comment 20 Sergei Trofimovich (RETIRED) gentoo-dev 2018-01-27 18:30:23 UTC
*** Bug 645902 has been marked as a duplicate of this bug. ***
Comment 21 Sergei Trofimovich (RETIRED) gentoo-dev 2018-05-23 07:08:03 UTC
Filed bug upstream: https://gcc.gnu.org/PR85884

To clarify: libstdc++ does not link against libvtv but only has RUNPATH embedded into it.
Comment 22 Sergei Trofimovich (RETIRED) gentoo-dev 2018-06-08 19:23:36 UTC
*** Bug 657432 has been marked as a duplicate of this bug. ***
Comment 23 Sergei Trofimovich (RETIRED) gentoo-dev 2018-06-21 19:44:18 UTC
*** Bug 647646 has been marked as a duplicate of this bug. ***
Comment 24 Larry the Git Cow gentoo-dev 2018-10-20 09:40:05 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=b016826c93875380dc8f570a54bc3652de2fc79e

commit b016826c93875380dc8f570a54bc3652de2fc79e
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-20 09:28:23 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-20 09:28:23 +0000

    8.2.0: drop libstdc++ libking against libvtv
    
    libstdc++ itself provides weak symbols to work
    both against present and missing libvtv. Final
    binary desides whetned to use vtv or not by
    linking against libvtv.
    
    The change drops libvtv RPATH=${build_dir} injection.
    
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 8.2.0/gentoo/112_all_libstdcxx-no-vtv.patch | 61 +++++++++++++++++++++++++++++
 8.2.0/gentoo/README.history                 |  1 +
 2 files changed, 62 insertions(+)
Comment 25 Larry the Git Cow gentoo-dev 2018-10-27 11:46:20 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f7c3c14f0c483e882c5a8aebb07365241d68611a

commit f7c3c14f0c483e882c5a8aebb07365241d68611a
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 09:04:08 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 11:46:03 +0000

    sys-devel/gcc: cut 1.5 patchset for 8.2.0
    
    3 new patches:
    + 111_all_ubd-hog-PR85704.patch:
      fix initialization of empty structs
    U 105_all_libgfortran-Werror.patch:
      patch configure.ac as well
    + 112_all_libstdcxx-no-vtv.patch:
      drop libstdc++ libking against libvtv
    + 113_all_ICE-on-strncmp-PR87099.patch:
      fix SIGSEGV on strncmp() VRP checks
    
    Closes: https://gcc.gnu.org/PR85704
    Closes: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Reported-by: Toralf Förster
    Closes: https://bugs.gentoo.org/668044
    Bug: https://gcc.gnu.org/PR87099
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-8.2.0-r4.ebuild | 20 ++++++++++++++++++++
 2 files changed, 21 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd

commit 7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 09:23:45 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 11:46:08 +0000

    sys-devel/gcc: cut 1.8 patchset for 6.4.0
    
    Eight new patches:
    + 103_all_remove-lieee.patch:
      drop assumed -lieee from -mieee-fp
    + 104_all_libgfortran-Werror.patch:
    + 105_all_libgomp-Werror.patch
    + 106_all_libitm-Werror.patch
    + 107_all_libatomic-Werror.patch
    + 108_all_libbacktrace-Werror.patch
    + 109_all_libsanitizer-libbacktrace-Werror.patch:
      pull in all -Werror patches from 8.2.0
    + 110_all_libstdcxx-no-vtv.patch:
      drop libvtv RPATH from libstdc++
    
    Bug: https://bugs.gentoo.org/667104
    Bug: https://bugs.gentoo.org/475350
    Bug: https://bugs.gentoo.org/229059
    Bug: http://gcc.gnu.org/PR38436
    Bug: https://bugs.gentoo.org/433435
    Bug: http://gcc.gnu.org/PR54724
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-6.4.0-r5.ebuild | 24 ++++++++++++++++++++++++
 2 files changed, 25 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2277fa55f1dd056891a5c7037741ee753df8f819

commit 2277fa55f1dd056891a5c7037741ee753df8f819
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 09:15:23 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 11:46:08 +0000

    sys-devel/gcc: cut 1.8 patchset for 7.3.0
    
    Five new patches:
    + 101_all_remove-lieee.patch:
      drop assumed -lieee from -mieee-fp
    + 102_all_libgfortran-Werror.patch:
    + 103_all_libgomp-Werror.patch
    + 104_all_libitm-Werror.patch
    + 105_all_libatomic-Werror.patch
    + 106_all_libbacktrace-Werror.patch
    + 107_all_libsanitizer-libbacktrace-Werror.patch:
      pull in all -Werror patches from 8.2.0
    + 108_all_libstdcxx-no-vtv.patch:
      drop libvtv RPATH from libstdc++
    
    Bug: https://bugs.gentoo.org/667104
    Bug: https://bugs.gentoo.org/475350
    Bug: https://bugs.gentoo.org/229059
    Bug: http://gcc.gnu.org/PR38436
    Bug: https://bugs.gentoo.org/433435
    Bug: http://gcc.gnu.org/PR54724
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-7.3.0-r6.ebuild | 24 ++++++++++++++++++++++++
 2 files changed, 25 insertions(+)
Comment 26 Larry the Git Cow gentoo-dev 2018-10-27 19:22:10 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c84f250076a6a6f33202c022a256b34284d91111

commit c84f250076a6a6f33202c022a256b34284d91111
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 19:17:52 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 19:21:54 +0000

    sys-devel/gcc: cut 1.11 patchset for 5.4.0
    
    Eight new patches:
    + 99_all_remove-lieee.patch:
      drop assumed -lieee from -mieee-fp
    + 100_all_libgfortran-Werror.patch:
    + 101_all_libgomp-Werror.patch
    + 102_all_libitm-Werror.patch
    + 103_all_libatomic-Werror.patch
    + 104_all_libbacktrace-Werror.patch
    + 105_all_libsanitizer-libbacktrace-Werror.patch:
      pull in all -Werror patches from 8.2.0
    + 106_all_libstdcxx-no-vtv.patch:
      drop libvtv RPATH from libstdc++
    
    Bug: https://bugs.gentoo.org/667104
    Bug: https://bugs.gentoo.org/475350
    Bug: https://bugs.gentoo.org/229059
    Bug: http://gcc.gnu.org/PR38436
    Bug: https://bugs.gentoo.org/433435
    Bug: http://gcc.gnu.org/PR54724
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Closes: https://bugs.gentoo.org/621178
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-5.4.0-r6.ebuild | 44 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 45 insertions(+)
Comment 27 Larry the Git Cow gentoo-dev 2021-02-22 22:00:14 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=63c16d8b5e71b5f8e6185965062cf9c836800c29

commit 63c16d8b5e71b5f8e6185965062cf9c836800c29
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2021-02-22 21:57:22 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2021-02-22 22:00:10 +0000

    eclass/toolchain.eclass: disable USE=vtv on gcc-10 and above
    
    USE=vtv has a few problems:
    - it's build system has a few quirks: bug #767706, bug #582524
    - it's developed in gcc for a while
    
    Bug: https://bugs.gentoo.org/582524
    Bug: https://bugs.gentoo.org/767706
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 eclass/toolchain.eclass | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)