Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 644904 - sys-devel/gcc-7.2.0-r1 - libstdc++.so contains insecure RUNPATHs
Summary: sys-devel/gcc-7.2.0-r1 - libstdc++.so contains insecure RUNPATHs
Status: RESOLVED DUPLICATE of bug 582524
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-18 03:41 UTC by Will S
Modified: 2018-01-20 18:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/sys-devel/gcc-7.2.0-r1/temp/build.log (build.log.xz,226.47 KB, application/x-xz)
2018-01-18 03:42 UTC, Will S
Details
emerge --info (emerge-info.txt,18.76 KB, text/plain)
2018-01-18 03:42 UTC, Will S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will S 2018-01-18 03:41:12 UTC
I am getting the following error after the installation phase on gcc-7.2.0-r1:

 * QA Notice: The following files contain insecure RUNPATHs
 *  Please file a bug about this at https://bugs.gentoo.org/
 *  with the maintainer of the package.
 *   /var/tmp/portage/sys-devel/gcc-7.2.0-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/32/libstdc++.so.6.0.24
 *     RPATH: /var/tmp/portage/sys-devel/gcc-7.2.0-r1/work/build/x86_64-pc-linux-gnu/32/libstdc++-v3/../libvtv/.libs
 *   /var/tmp/portage/sys-devel/gcc-7.2.0-r1/image/usr/lib/gcc/x86_64-pc-linux-gnu/7.2.0/libstdc++.so.6.0.24
 *     RPATH: /var/tmp/portage/sys-devel/gcc-7.2.0-r1/work/build/x86_64-pc-linux-gnu/libstdc++-v3/../libvtv/.libs
 * 


Reproducible: Always
Comment 1 Will S 2018-01-18 03:42:33 UTC
Created attachment 515210 [details]
/var/tmp/portage/sys-devel/gcc-7.2.0-r1/temp/build.log
Comment 2 Will S 2018-01-18 03:42:59 UTC
Created attachment 515212 [details]
emerge --info
Comment 3 Will S 2018-01-18 03:50:24 UTC
Turning off the stricter FEATURE allows qmerge to finish. This is an effective workaround.
Comment 4 SpanKY gentoo-dev 2018-01-20 18:30:57 UTC

*** This bug has been marked as a duplicate of bug 582524 ***