Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 611124 - QA Notice: sys-devel/gcc-4.9.4
Summary: QA Notice: sys-devel/gcc-4.9.4
Status: RESOLVED DUPLICATE of bug 582524
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 611126 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-27 17:24 UTC by Corbin
Modified: 2017-02-27 19:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Corbin 2017-02-27 17:24:55 UTC
Package:    sys-devel/gcc-4.9.4
Repository: gentoo
Maintainer: toolchain@gentoo.org
USE:        abi_x86_64 amd64 cxx elibc_glibc fortran gcj graphite kernel_linux multilib nls nptl objc objc++ objc-gc openmp sanitize userland_GNU vtv
FEATURES:   compressdebug preserve-libs sandbox splitdebug userpriv usersandbox

-----

 QA Notice: The following files contain insecure RUNPATHs
  Please file a bug about this at https://bugs.gentoo.org/
  with the maintainer of the package.
   /var/tmp/portage/sys-devel/gcc-4.9.4/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6.0.20
     RPATH: /var/tmp/portage/sys-devel/gcc-4.9.4/work/build/x86_64-pc-linux-gnu/libstdc++-v3/../libvtv/.libs
   /var/tmp/portage/sys-devel/gcc-4.9.4/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/32/libstdc++.so.6.0.20
     RPATH: /var/tmp/portage/sys-devel/gcc-4.9.4/work/build/x86_64-pc-linux-gnu/32/libstdc++-v3/../libvtv/.libs

-----

emerge --info

Portage 2.3.3 (python 2.7.13-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.4, glibc-2.23-r3, 4.10.0-gentoo-AMDFX9590 x86_64)
=================================================================
System uname: Linux-4.10.0-gentoo-AMDFX9590-x86_64-AMD_FX-tm-9590_Eight-Core_Processor-with-gentoo-2.3
KiB Mem:    32910512 total,  29654008 free
KiB Swap:    8191996 total,   8191996 free
Timestamp of repository gentoo: Mon, 27 Feb 2017 00:45:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.3_rc4::gentoo
dev-lang/python:          2.7.13::gentoo, 3.4.6::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: webrsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

Testing
    location: /usr/local/portage
    masters: gentoo

palemoon
    location: /var/lib/layman/palemoon
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
CXXFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
FFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
FCFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs cgroup compress-build-logs compress-index compressdebug config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles ipc-sandbox merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="7z S3TC X a52 aac aalib acl acpi alsa amd64 amr amrenc ansi archive asm audacious audiofile audit autotrace avcodec avformat avfs bash-completion bat bcmath berkdb bidi binary-drivers blas bluray bmp branding bs2b bzip2 c++0x cacert cairo caps cdda cddb cdparanoia cdr celt charmap clang clients clipboard clisp colordiff commander common-lisp compact compiler-rt cracklib cron crypt crywrap css csv cue cups curl cvs cxx daemon dbi dbm dbus dds defineformat devhelp devil dga dhcpd diff directfb djvu dmx dns docbook dot double-precision doxygen doxysearch dri dri3 drm drmkms dts dvbpsi dvd dvdnav dvdr dvi ecc ecdsa ecm edit efi efiemu egl emacs enca enchant encode enscript evdev exif expat experimental ext2 ext4 extra-cardsets extras faac faad fat fbcon fbdev fdk ffmpeg fftw finger firmware flac flatfile fltk fontconfig fonts foomatic foomaticdb fortran fortune fpx free frontend-optional ftp fuse fusionsound gbm gc gcj gcrypt gd gdb gdbm geany gecko geoip geolocation ggi gif gimp git glade gles gles2 glib glut gmp gnome-keyring gnuplot gnutls gold gopher gpg gpm gps gptfdisk graphicsmagick graphite graphviz grub gsf gsl gsm gstreamer gtk gtk2 gtkspell gtkstyle guile gzip hardened havege highlight hostname htmltidy http hunspell hwdb icons iconv icq icu id3tag idn ieee1394 imagemagick imap imlib imlib2 infinality info inotify input_hub interlaced introspection iodbc iptables ipv4 ipv6 iso jbig jfs joystick jpeg jpeg2k kernel-helper kill kmod kms lame lapack launch-frontend launch-frontend-setuid lcms leaps_timezone libass libatomic libburn libcaca libcanberra libdrm libev libexif libffi libindicate libkms libmpv libnormaliz libnotify libopts libproxy libsamplerate libsoxr libunwind libvisual libwww libxml2 llvm lock logrotate lprng-compat lqr lto lua lz4 lzma lzo mac mad magic maildir man manpages matroska mbox mclib md5 md5sum mdadm mdb memlimit metalink mhash midi mikmod mime minizip mktemp mmap mng mod modplug modules mount mozilla mp3 mp4 mpeg mpeg2 mpeg3 mpfr mpg123 mplayer ms mta mudflap mule multicore multilib musepack music musicbrainz mvl nas ncurses neXt net netifrc netlink netpbm nettle network networking nfct nflog nfqueue nftables nls normalize nptl nsplugin ntfs ntfsdecrypt ntfsprogs numa numpy nyx objc objc++ objc-gc odbc odf offensive ogg omxil openal opencl opencv openexr opengl openh264 openmax openmp opus orc osc osdmenu osmesa oss pam pango pcap pcf pcf-unicode-only pci pciutils pcm pcntl pcre pcre16 pcre2 pcre32 pdf perl physfs pie pinentry pixmaps player playtools plotutils plugins png portaudio posix postproc postscript python qdbm rar raw readline recode recommended recovery regex replaygain rsync rtc s3tc sanitize sasl sbcl schroedinger sctp sdl sdl-image sdl-sound sdl2 sdlaudio sdlgfx sdlsound seccomp session setproctitle sftp sha512 shadow sharedmem shm shorten sid sigsegv simplexml skey slang smp smpeg snappy sndfile soap sockets socks5 sound soundtouch sox speex spell sqlite squashfs ssl ssp staging startup-notification static-analyzer static-libs subversion suid svg symlink syslog system-sqlite sysvipc szip taglib tcl tcpd text tga themes theora threads tidy tiff timidity tinfo tk tools tracepath traceroute truetype tsmuxer ttf udev udf udis86 unicode unwind unzip usb utils vcd vdpau vhosts vorbis vpx vte vtv vulkan wav wavpack wayland webkit webp wmf wxwidgets x264 x265 xattr xcb xcf xcomposite xdg xdm-auth xface xfce xfconf xfig xfs xft xine xinerama xkb xklavier xlib-xcb xls xml xmlrpc xorg xosd xpm xps xrandr xref xrender xscreensaver xslt xspf xv xvid xvmc xwidgets xz zip zlib"
ABI_X86="64 32"
ALSA_CARDS="XonarDX CMI8788 AV200 AV100"
COLLECTD_PLUGINS="df memory syslog cgroups cpu smart thermal write_log"
CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3 sse4a sse4_1 sse4_2 fma fma4 avx xop aes pclmul popcnt xsave"
CURL_SSL="gnutls"
ELIBC="glibc"
GRUB_PLATFORMS="efi-64 pc multiboot"
INPUT_DEVICES="evdev mouse keyboard joystick"
KERNEL="linux"
L10N="en en-US"
LINGUAS="en en_US"
LLVM_TARGETS="AMDGPU BPF"
PYTHON_SINGLE_TARGET="python2_7"
PYTHON_TARGETS="python2_7 python3_4"
RUBY_TARGETS="ruby21 ruby22"
USERLAND="GNU"
VIDEO_CARDS="nouveau amdgpu i915 intel"
XFCE_PLUGINS="brightness clock trash power"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jonas Stein gentoo-dev 2017-02-27 18:01:30 UTC
*** Bug 611126 has been marked as a duplicate of this bug. ***
Comment 2 Arfrever Frehtes Taifersar Arahesis 2017-02-27 19:18:46 UTC

*** This bug has been marked as a duplicate of bug 582524 ***