Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 260441

Summary: x11-drivers/nvidia-drivers-180.35 and weird behaviour
Product: Gentoo Linux Reporter: Tommaso Pasini <tommaso.pasini>
Component: [OLD] UnspecifiedAssignee: Ricardo Mendoza (RETIRED) <ricmm>
Status: RESOLVED UPSTREAM    
Severity: blocker CC: alexxy, aoz.syn, axiator, betelgeuse, blshadow, boltomli, cardoe, converter42, Dessa, devurandom, dimanish, dpblnt, dragonheart, emond.papegaaij, filipe, gengor, ikelos, imgvg, ivan.kanak, jdaluz, jlec, jrmalaq, korvin, mark+gentoobugs, Martin.vGagern, maxbritov, mgorny, midnightflash, pacho, patrizio.bassi, rb6, rk, seventhguardian, spatz, t4bs, thomasheinz, tinaught
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
URL: http://www.nvnews.net/vbulletin/showthread.php?t=128959
Whiteboard:
Package list:
Runtime testing required: ---

Description Tommaso Pasini 2009-02-26 21:09:20 UTC
Sorry for the strange summary, maybe you can help me find a better one.

I upgraded to nvidia-drivers-180.35 this morning, I'm using xorg-server-1.5. on stable x86. After a reboot I found out that my system had a strange behaviour:

-inside gnome-terminal, Ctrl-C didn't work anymore
-all mono-based applications (gnome-do, tomboy, tasque) were unable to start
-portage froze when building packages related to mono (mono itself, but even gettext during the configure script, checking for a c# compiler)
-inside gnome-terminal, typing exit couldn't close the window
-evince needed many seconds to start, while other applications were responsive as always
-the gnome login process was freezing for a few seconds at startup

I tried to rebuild the packages regarding xorg that I upgraded in the last days, I completely removed mono-related packages, I rebuilt other packages - nothing. At the end I chose to try to downgrade nvidia-drivers, and everything seems to be working again.

Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-Genuine_Intel-R-_CPU_T2400_@_1.83GHz-with-glibc2.0
Timestamp of tree: Thu, 26 Feb 2009 10:35:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -fforce-addr -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -fforce-addr -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://de-mirror.org/distro/gentoo/ http://de-mirror.org/distro/gentoo/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LANG="it_IT.utf8"
LC_ALL="it_IT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="bzip2"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gnome /usr/portage/local/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa bash-completion berkdb bluetooth branding bzip2 cairo caps cddb cdparanoia cdr cli consolekit cracklib crypt dbus dmx dri dv dvd dvdr dvdread emboss encode evo fam ffmpeg firefox flac fortran gdbm gif glib gnome gnome-keyring gstreamer gtk hal iconv isdnlog java java5 java6 jpeg jpeg2k latex lcms libnotify mad midi mikmod mmap mmx mng mp3 mpeg musepack nautilus ncurses networkmanager nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp pam pch pcre pdf perl png ppds pppd python quicktime readline reflection samba sdl semantic-desktop session sndfile spell spl sse sse2 sse3 ssl startup-notification svg sysfs tcpd theora threads tiff tracker truetype unicode usb vcd vorbis win32codecs wxwindows x86 xcomposite xine xinerama xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2 sierra" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Reproducible: Always

Steps to Reproduce:
1.Upgrade to nvidia-drivers-180.35 using xorg-1.5
2.Open up gnome-terminal and launch `ls -R`
3.Try to block it using Ctrl-C
Comment 1 Mike Auty gentoo-dev 2009-02-26 21:35:22 UTC
I can verify that these issues occur (I get lots of defunct processes after gnome-session starts, the gnome dialogs don't close, Ctrl+C doesn't get handled and killall -9 appeared not to work).  Downgrading to 180.29 appears to have solved these problems (although the firefox/glitz issues have returned).
Comment 2 Pacho Ramos gentoo-dev 2009-02-26 21:40:54 UTC
*** Bug 260442 has been marked as a duplicate of this bug. ***
Comment 3 Pacho Ramos gentoo-dev 2009-02-26 21:45:13 UTC
Same problem here with gnome-terminal and also gnome-screensaver doesn't work properly, seems that we are not alone on this:
http://www.nvnews.net/vbulletin/showthread.php?t=128959

Maybe this should be masked until a new release is launched

Thanks!
Comment 4 Mike Auty gentoo-dev 2009-02-26 22:00:38 UTC
A brief summary of the forum posts Pacho mentioned are that it hits both KDE and Gnome equally.

"The driver isn't breaking signal handling on further investigation. There are programs quering the xserver which is looking at some property that the video card driver is supposed to give back. Unfortunately the request goes into the xserver and never comes back because the driver eats the request and doesn't respond."

It's possible that this doesn't break under xorg-server-1.6, but that's yet to be confirmed...
Comment 5 RB 2009-02-26 22:21:15 UTC
Definitely WM-agnostic - experienced it on Xfce4.  Several signals are screwed up: INTR, SUSP, and KILL at least.  Strange thing is that, although signals don't work on local terminals (xterm + ^C), they do on remote terminals (xterm + ssh remote + ^C).  Since I caught the libXi and libdrm updates in the same round, I lost some time chasing those rabbits until figuring out it was definitely the NVidia driver.
Comment 6 Patrizio Bassi 2009-02-26 23:26:08 UTC
similar issue for me on kde 4
patrizio 10540  0.0  0.0      0     0 ?        Z    Feb26   0:00 [amarok] <defunct>
patrizio 10542  0.0  0.0      0     0 ?        Z    Feb26   0:00 [audacious] <defunct>
patrizio 10543  0.0  0.0      0     0 ?        Z    Feb26   0:00 [ekiga] <defunct>
patrizio 10545  0.0  0.0      0     0 ?        Z    Feb26   0:00 [keys] <defunct>
patrizio 10546  0.0  0.0      0     0 ?        Z    Feb26   0:00 [kmess] <defunct>
patrizio 10547  0.0  0.0      0     0 ?        Z    Feb26   0:00 [kopete] <defunct>

since i upgraded....it's defenetly a driver issue.
Comment 7 Yaroslav Isakov 2009-02-27 01:02:20 UTC
I also want to confirm strange behviour, and add this sympthom:
mozilla-firefox doesn't started from alt-f2 in gnome, but from console it is startin
Comment 8 Harris Landgarten 2009-02-27 06:23:37 UTC
Add vmware-workstation to the list of applications broken the nvidia-drivers-180.35
Comment 9 Olivier Mondoloni 2009-02-27 09:19:47 UTC
Same issues for me on Xfce4 version 4.4.3. Exo and exo-helper become defunct processes after launching Terminal application. I tried 180.29 nvidia-drivers and everything became ok.
Comment 10 Alexey Shvetsov gentoo-dev 2009-02-27 09:54:50 UTC
nvidia-drivers 180.35 are quite broken and should be masked
see semiofficial refrence
http://www.nvnews.net/vbulletin/showthread.php?t=128959&page=2
Comment 11 Stefan G. Weichinger 2009-02-27 10:22:39 UTC
One more strange-behavior-story:
thunderbird-bin-2.0.0.19 crashes with x11-drivers/nvidia-drivers-180.35 when I try to reply ... no problem with nvidia-drivers-180.29.

Comment 12 Stefan G. Weichinger 2009-02-27 10:24:20 UTC
(In reply to comment #11)
> One more strange-behavior-story:
> thunderbird-bin-2.0.0.19 crashes with x11-drivers/nvidia-drivers-180.35 when I
> try to reply ... no problem with nvidia-drivers-180.29.

Just to be correct on this: it's not mail-client/mozilla-thunderbird-bin here but mail-client/mozilla-thunderbird-2.0.0.19
Comment 13 Alexey Shvetsov gentoo-dev 2009-02-27 10:59:20 UTC
simple test that signalling not working properly with nvidia-drivers-180.35
start some xtreminal for example xterm
start screen in this terminal
try to detach screen
it wil hang with 180.35
if you'll run 
$ ps -A -ostat,ppid,pid,cmd | grep screen
PID TTY STAT TIME COMMAND
S+ 18538 18542 screen
Zs 18542 18543 [screen]

while with nvidia-drivers !=180.35 it will works as expected
Comment 14 Renato Caldas 2009-02-27 14:54:07 UTC
Whenever I try to run bluetooth-applet, it segfaults leaving these on the dmesg output:

[  296.977368] bluetooth-apple[17345] general protection ip:7f1e4c3e1e5e sp:7fff589baec0 error:0 in libGL.so.180.35[7f1e4c38b000+a4000]
Comment 15 Mark Nowiasz 2009-02-27 14:54:27 UTC
*** Bug 260425 has been marked as a duplicate of this bug. ***
Comment 16 Mark Nowiasz 2009-02-27 14:58:40 UTC
I've encountered the following problem: after upgrading to 180.35, my screensaver (KDE 4.2) won't release the screen again: when running, I can't make it stop again - even when moving the mouse or pressing keys. In very rare cases (once or twice) pressing a function key (like f5) did work - or changing to a virtual terminal and back again (but I was unable to duplicate this circumstance).

I totally agree with everyone - this version should be hard masked with a vengeance!
Comment 17 Doug Goldstein gentoo-dev 2009-02-27 15:25:24 UTC
I can not reproduce this issue on any of my machines. The referenced threads on the forums do not contain a response from NVIDIA and they have yet to respond to my e-mails. I also do not see anyone using the nvidia-bug-report.sh tool and posting it to the forum thread.

At present my test machines contain the following:
Quadro NVS 290
GeForce 8600 GT
GeForce 9600 GTX

On all three of these cards work fine with 180.35 and have been tested using X.org server 1.5.3 and 1.6.0. Alexey's steps to reproduce are unreproducible on any of these three machines.

How you can help this issue to be resolved is to use the nvidia-bug-report.sh and post your results on the forum thread. Additionally, include your card information and what X.org version you are using.
Comment 18 Doug Goldstein gentoo-dev 2009-02-27 15:31:59 UTC
As a follow up, this driver won't be masked. This is a complete thread with nvidia drivers. What breaks for one person, improves the situation for others. For as many reports that you guys have made wrt to 180.35 breaking, I've received an equal number where people are saying 180.35 finally fixes crashers or other issues for them.

As with all NVIDIA driver releases, I always recommend people find a version that works best for them and peg themselves to it.
Comment 19 RB 2009-02-27 18:15:12 UTC
comment #17:
> At present my test machines contain the following:
> Quadro NVS 290
> GeForce 8600 GT
> GeForce 9600 GTX

Perhaps the issue is isolated to mobile chipsets (mine is a GeForce Go 7400).  Not having had any recent issues with previous drivers, I can't speak to what .35 may have fixed, but can provide very clear documentation as to what it has broken; please don't dismiss the issue out-of-hand simply because you are unable to reproduce it with your limited test environment.
Comment 20 Yaroslav Isakov 2009-02-27 18:19:35 UTC
comment #19:
>Perhaps the issue is isolated to mobile chipsets (mine is a GeForce Go 7400).
No, desktop cards are also affected - I have a 9800GT.
Comment 21 Mark Nowiasz 2009-02-27 18:22:28 UTC
(In reply to comment #20)
> comment #19:
> >Perhaps the issue is isolated to mobile chipsets (mine is a GeForce Go 7400).
> No, desktop cards are also affected - I have a 9800GT.

Same here (9800GTX+).

Comment 22 Yaroslav Isakov 2009-02-27 18:28:34 UTC
I also see strange behaviour on revdep-rebuild, which show me grep with 'broken pipe' (or so, I cannot remember correctly) messages. Downgrade to 180.29 solved this problem.
Comment 23 larstobi 2009-02-27 18:34:21 UTC
(In reply to comment #19)
> Perhaps the issue is isolated to mobile chipsets (mine is a GeForce Go 7400). 

I am also experiencing this issue and my graphics card is GeForce GTX 280, not the mobile edition. The shell will not respond to Control-C or Control-Z.

- I am not experiencing crashes with =mail-client/mozilla-thunderbird-2.0.0.19, contrary to what Stefan has reported.
- I am also experiencing some defunct processes, as Mike has reported.
- I use =x11-base/xorg-x11-7.4.
- I only have these issues with bash, under a pts in X (xterm, rxvt, gnome-terminal), not under a tty not in X.
- tcsh and zsh does respond to Control-C and handles SIGINT with no issues, also Control-Z works.
Comment 24 Alexey Shvetsov gentoo-dev 2009-02-27 18:46:09 UTC
My hardware is 01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
xorg-server-1.5.3-r2
gentoo-sources 2.6.28-r2

btw if i remove module 180.35 all starts working again

arch is x86_64
Comment 25 Doug Goldstein gentoo-dev 2009-02-27 21:38:47 UTC
I'm still not seeing you guys attaching nvidia-bug-report.sh output to the related Nvidia forum thread and I haven't heard back from Nvidia wrt to the issue yet. Just as fast as you guys are hitting my mail box with issues, I'm receiving mails saying that 180.35 is the first version in a while that works for people. So you're asking me to mask this version, which would cause breakage for an equal number of users at this point.

Additionally, are you using evdev or mouse/keyboard?
Comment 26 Mark Nowiasz 2009-02-27 21:48:42 UTC
(In reply to comment #25)
> I'm still not seeing you guys attaching nvidia-bug-report.sh output to the
> related Nvidia forum thread and I haven't heard back from Nvidia wrt to the
> issue yet. Just as fast as you guys are hitting my mail box with issues, I'm
> receiving mails saying that 180.35 is the first version in a while that works
> for people. So you're asking me to mask this version, which would cause
> breakage for an equal number of users at this point.

You've got a point . What about a compromise? Leave 180.35 unmasked but add a big fat warning about reported issues (signals like CTRL+C being ignored, xlock unable to stop, etc.)? Something like "if you experience weird behaviour like.. revert to 180.29 (see bug..)"?

> Additionally, are you using evdev or mouse/keyboard?

I'm using evdev (for keyboard and mouse).
Comment 27 Trevor Forbes 2009-02-27 22:02:09 UTC
My arch is x86_64 and this release is clearly very very very bad... (It broke
many other applications because it breaks signaling)..
Comment 28 RB 2009-02-28 05:12:58 UTC
Here's another thread (that was noted on the first bug here that outlined the issue) on the forum with two reports attached, Mooninite.

http://www.nvnews.net/vbulletin/showthread.php?t=128992

How many reports are enough?  Are you going to somehow insist that each of the 14 people reporting the issue here go sign up for a forum account just to post a me-too tarball before you do something in our tree?  Do you have more than 14 people (not to mention those on NVidia's forum) saying .29 prevented them from working and .35 is that much better?  I've already masked it here, no more issue for me, I'm just surprised at how resistant you are to masking it or even providing a warning with so many reporting precisely the same breakage.

I'm using 'kbd' and 'synaptics', no evdev at all.
Comment 29 Pacho Ramos gentoo-dev 2009-02-28 09:14:54 UTC
I have just attached log to upstream forum thread:
http://www.nvnews.net/vbulletin/showpost.php?p=1944352&postcount=41

I am using evdev and I get the wrong behavior in all cards I have tried (7300Go and 6600, I will wait for newer releases for trying also on 8400M)
Comment 30 Andrew Cowie 2009-02-28 10:26:00 UTC
My version of this problem was gnome-terminal not exiting when given a `logout`, and ^C not working. And lots of defunct processes. Yuk.

AfC
Comment 31 Andrew Cowie 2009-02-28 10:31:07 UTC
Reverting to nvidia-drivers-180.29 fixed the problem.

AfC
Comment 32 Harris Landgarten 2009-02-28 13:02:01 UTC
If you go to nvidia.com and try to download the most recent driver you get .29, not .35. .35 is still on their ftp but you have to hunt for it. Looks like it has been pulled.
Comment 33 Nicolas 2009-02-28 14:57:32 UTC
i can't start gnome with nvidia-drivers-180.35

when i startx, it freezes and it logs : 

gnome-session: Fatal IO error 11 (Ressource temporairement non disponible) on X 
server :0.0.

Downgrading to nvidia-drivers-180.29 fix the problem
Comment 35 Alexander Weber 2009-02-28 23:33:03 UTC
In german forum i found this: http://www.gentooforum.de/post/117426/prozesse-reagieren-nicht-auf-sigterm.html
With new nvidia driver all X-Processes does not receive kill-Signals like sigterm.

"ps s" return a high "BLOCKED" value on most (but not all) X Processes.
Comment 36 Jose daLuz 2009-02-28 23:42:32 UTC
I just posted my bug report to the "terminal issues" thread: http://www.nvnews.net/vbulletin/showpost.php?p=1944764&postcount=43

Gentoo-specific info:

Portage 2.2_rc23 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28.7 x86_64)
=================================================================
System uname: Linux-2.6.28.7-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-glibc2.2.5
Timestamp of tree: Sat, 28 Feb 2009 09:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.8
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/zugaina /usr/local/overlays/sunrise /usr/local/overlays/gnome /usr/local/overlays/desktop-effects /usr/local/overlays/vmware /usr/local/overlays/ikelos /usr/local/overlays/java-overlay /usr/local/overlays/berkano /usr/local/overlays/myoverlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt css cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo fam ffmpeg flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kde kdehiddenvisibility ldap libnotify mad midi mikmod mmx mono mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl pic png ppds pppd python qt3support qt4 quicktime readline reflection ruby samba sdl session spell spl sqlite sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb userlocales vcd vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="cmipci hdaintel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 37 Gordon Malm (RETIRED) gentoo-dev 2009-03-01 03:36:54 UTC
*** Bug 260449 has been marked as a duplicate of this bug. ***
Comment 38 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-03-01 11:30:50 UTC
Confirming with 7300GT & =xorg-server-1.5.3-r2.

Issues include:
* xfce terminal problems with ^C, ^Z;
* screen hanging on detach;
* screen resizing itself to 80x25 after any action;
* wine segvs.
Comment 39 Alexey Shvetsov gentoo-dev 2009-03-01 12:02:35 UTC
Doug Goldstein i think its enough 
so 180.35 should be masked
also nvidia hides this driver =) so you cannot download it from nvidias website
Comment 40 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-01 20:29:51 UTC
*** Bug 260730 has been marked as a duplicate of this bug. ***
Comment 41 Doug Goldstein gentoo-dev 2009-03-02 16:22:41 UTC
The driver isn't hidden by NVIDIA. NVIDIA unfortunately has their PR dept maintain the list of driver releases on their website and not their development team. If you speak to anyone from their development team they will tell you to never trust the website. The official statement on Linux drivers is always contained in this sticky post:

http://www.nvnews.net/vbulletin/showthread.php?t=122606
Comment 42 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-02 16:31:55 UTC
Lads, this stuff needs to be masked.
I hate spammed #gentoo-kde channel just because of bug in the drivers (lots of spam, even when we have the note about it in the topic...).
Since this happens across all DM (hell i hit that too ;]) it would be really nice to have it masked ASAP.

Tomas
Comment 43 d00p 2009-03-02 18:16:22 UTC
I also recognized weird behavior, like some apps not opening or crashing right after starting, no logoff possible in KDE-4.2, etc.

Gfx-Card: GeForce 9300M GS

Downgrade to .29 fixed all this for me ;-)
Comment 44 Emond Papegaaij 2009-03-02 18:39:12 UTC
This driver really should be masked. With 35, ctrl-c didn't work in konsole, I couldn't logoff. I even had to use kill -9 to kill a tail -f on a log file (normal kill didn't even work). Downgrading to 29 fixed all those issues.
Comment 45 Gonçalo Silva 2009-03-02 18:43:17 UTC
Confirming this behavior.

I reverted to the previous version of nvidia-drivers and everything works fine.

The package should be masked, in my opinion.
Comment 46 Emond Papegaaij 2009-03-02 18:43:36 UTC
Just to be complete, this is with xorg-server-1.5.3-r2 on a Quadro NVS 140M.
Comment 47 Dennis Schridde 2009-03-02 20:25:12 UTC
me too:
GeForce 7900GS.
SIGTERM, SIGQUIT being ignored, SIGKILL not.
Dozens of zombies / defunct processes.
^C and "exit" in a terminal does not work.
KDE logout does work neither.
Sometimes input devices seem to "vanish" (mouse cursor gone, moving mouse/hacking keyboard has no results), but appear again after a few minutes.
Happens both with xorg-server-1.5.3 and 1.6.0 (from x11 overlay).
Comment 48 Alex Alexander (RETIRED) gentoo-dev 2009-03-02 23:57:49 UTC
Weird stuff here as well, firefox lockups when scrolling gmail and ctrl-c in urxvt not responding. Back to nice 180.29 :)
Comment 49 Herb Molenda 2009-03-03 00:30:18 UTC
Extremely annoying, reverted back to 180.29 and above-mentioned issues have been resolved. Took me forever to track it down to an nvidia bug however....


Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Dual-Core_AMD_Opteron-tm-_Processor_2216-with-glibc2.2.5
Timestamp of tree: Mon, 02 Mar 2009 14:00:01 +0000
distcc 3.0 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_GB en_US en_CA pl"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise"
SYNC="rsync://gen2/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 avahi berkdb branding bzip2 cairo cdr cleartype cli corefonts cracklib crypt cups curl dbus divx dri dvd dvdr eds exif ffmpeg flac fortran gdbm gif gnome gpm gsm gstreamer gtk gtk2 hal hamlib iconv ipv6 isdnlog java jpeg libnotify lm_sensors midi mmx mmxext mono mp3 mpeg mudflap multilib nautilus ncurses nfs nls nptl nptlonly nsplugin nvtv ogg opengl openmp pam pcre pdf perl png ppds pppd pulseaudio python quicktime rar readline reflection ruby samba session smp spl sqlite sse sse2 ssl sysfs tcl tcpd tiff unicode v4l v4l2 vorbis x264 xcb xinerama xml xorg xulrunner xvid zeroconf zlib" ALSA_CARDS="hda-intel emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB en_US en_CA pl" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 50 Jose daLuz 2009-03-03 00:51:56 UTC
Per this comment on the nvnews forum, nvidia has found the problem and will fix it in the next release: http://www.nvnews.net/vbulletin/showpost.php?p=1946545&postcount=46
Comment 51 Korvin 2009-03-03 13:06:02 UTC
*** Bug 261046 has been marked as a duplicate of this bug. ***
Comment 52 Doug Goldstein gentoo-dev 2009-03-03 16:31:10 UTC
I'd like to thank the Gentoo users that took the time to run nvidia-bug-report.sh and submit the data back. Your data was used to track down the cause and the proper fix for this bug. Discussing this further with NVIDIA yesterday it was decided this version will be masked as a hands off version, however it will still result in improved support for a fair margin of users, but those users will have to unmask the package on a case by case basis.

The fix will appear in the next driver version.
Comment 53 Pacho Ramos gentoo-dev 2009-03-04 20:59:17 UTC
(In reply to comment #41)
> The driver isn't hidden by NVIDIA. NVIDIA unfortunately has their PR dept
> maintain the list of driver releases on their website and not their development
> team. If you speak to anyone from their development team they will tell you to
> never trust the website. The official statement on Linux drivers is always
> contained in this sticky post:
> 
> http://www.nvnews.net/vbulletin/showthread.php?t=122606
> 

All this has been just clarified in:
http://www.nvnews.net/vbulletin/showpost.php?p=1948791&postcount=61

Regards! :-)
Comment 54 Martin von Gagern 2009-03-05 08:51:36 UTC
Thanks for the package mask.

For those technically inclined, the following information might be interesting, albeit none too useful, as I expect there is little we can do about it.

I encountered the issue with rxvt-unicode, causing all commands in my console to ignore SIGINT. stracing urxvt showed these:
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, ~[RTMIN RT_1], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, ~[RTMIN RT_1], ~[KILL STOP RTMIN RT_1], 8) = 0
rt_sigprocmask(SIG_SETMASK, ~[KILL STOP RTMIN RT_1], NULL, 8) = 0

As you can see, the second syscall blocks allmost all signals, while later invocations don't unblock them again. ltrace showed that the syscall was run even before the main function of the application. It had to be during initialization. With a little self-written ptrace application, I traced the critical syscall back through these memory areas:
[vdso]                                     + 0x000424
/lib/libpthread-2.9.so                     + 0x00acc2
/usr/lib/opengl/nvidia/lib/libGL.so.180.35 + 0x03fa86
/lib/ld-2.9.so                             + 0x00ece4
The position in libpthread probably corresponds to pthread_create, though I'm not sure there.

On the whole, it looks like the initialization code of libGL were somehow broken, dealing with threads in a way it should not, or something like that.
I wouldn't have dreamed of the nvidia drivers being responsible for this mess (it was part of a huge world update for me), and was happy to find the mask already in place once I had identified the culprit.
Comment 55 Ricardo Mendoza (RETIRED) gentoo-dev 2009-03-05 13:08:09 UTC
*** Bug 260459 has been marked as a duplicate of this bug. ***
Comment 56 Serkan Kaba (RETIRED) gentoo-dev 2009-03-06 18:16:02 UTC
*** Bug 261477 has been marked as a duplicate of this bug. ***
Comment 57 Rémi Cardona gentoo-dev 2009-03-07 07:52:54 UTC
*** Bug 260700 has been marked as a duplicate of this bug. ***
Comment 58 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-07 17:29:58 UTC
*** Bug 261492 has been marked as a duplicate of this bug. ***
Comment 59 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-07 22:44:46 UTC
*** Bug 261625 has been marked as a duplicate of this bug. ***
Comment 61 Maxim Britov 2009-03-08 23:41:30 UTC
I'm on 180.37 and it seems everything works fine again. Seems fixed.
Comment 62 Matt 2009-03-18 21:23:13 UTC
Hey guys,

could the following problem posted over at nvnews be related to this "weird behavior" ?

http://www.nvnews.net/vbulletin/showthread.php?t=129839

you're very experienced in this area so I'm posting it here, also

thanks
Comment 63 Jason 2009-05-14 00:10:16 UTC
hey folks, im also having the hang on the emerge of coreutils at 
(in a screen session over ssh)
checking for working nanosleep... 

but this server is headless and do not have any nvidia drivers installed.

*  x11-drivers/nvidia-drivers
      Latest version available: 180.29
      Latest version installed: [ Not Installed ]

any ideas?

-db
Comment 64 RB 2009-05-14 01:10:56 UTC
No.  This was a specific issue with nvidia-drivers-180.35.
Comment 65 Jason 2009-05-14 12:31:09 UTC
but this bug http://bugs.gentoo.org/show_bug.cgi?id=260459
was marked a dup of 260441.. I guess ill open a new one then..

-db
Comment 66 Magnus Bergman 2013-12-20 02:55:39 UTC
This behaviour seems to be back with version 331.20. From what I can see new processes always blocks most signals, "grep SigBlk < /proc/PID/status" gives "SigBlk: 000000007ffafeff". Before staring X it never happens. But some time after launching X it starts to happen and spreads like a disease. (For example it happened to xfdestop but not to xfce4-panel which seems quite random.) It also happens to non X applications started from affected X applications (for example "yes" or simple hello world examples started in an X terminal). I also found that sudo (but not su -l) can get around the problem and spawn normal behaving processes.

Before I found this bug I stumbled upon a mentioning of blocking signals as a recommended way of preventing debuging and thus reverse engineering. Could this perhaps be a DRM "feature" we just have to live with if we want to use the proprietary drivers?