Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 99823 - app-portage/genlop looks for /tmp/sandboxpids.tmp, while recent versions of sandbox do not use it anymore
Summary: app-portage/genlop looks for /tmp/sandboxpids.tmp, while recent versions of s...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-21 12:26 UTC by Jeroen Roovers (RETIRED)
Modified: 2007-07-16 07:39 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
strace output for genlop (app-portage/genlop-0.30.3) (genlop.strace,109.51 KB, text/plain)
2005-07-21 12:28 UTC, Jeroen Roovers (RETIRED)
Details
patch against app-portage/genlop-0.30.3 (genlop_current.patch,794 bytes, patch)
2005-07-26 10:12 UTC, CJ van den Berg
Details | Diff
genlop-0.30.3-r1.ebuild (genlop-0.30.3-r1.ebuild,819 bytes, text/plain)
2005-07-29 19:34 UTC, Chris Brundage
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2005-07-21 12:26:23 UTC
Starting with a recent sys-apps/sandbox version, /tmp/sandboxpids.tmp is no 
longer used. A strace on 'genlop --current' reveals it uses that file to find 
currently running merges so it always returns the same result.

Reproducible: Always
Steps to Reproduce:
1. While merging something (anything)
2. Do: genlop --current
Actual Results:  
epia ~ # genlop -c
!!! Error: no working merge found.

Expected Results:  
Info about the currently merging package.

Gentoo Base System version 1.6.13
Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.5-
r0, 2.6.11.7-JeR i686)
=================================================================
System uname: 2.6.11.7-JeR i686 VIA Nehemiah
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=i686 -mmmx -msse -mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/
share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /
usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config 
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=i686 -mmmx -msse -mfpmath=sse -pipe"
DISTDIR="/keeps/gentoo/portage/distfiles"
FEATURES="autoconfig notitles parallel-fetch prelink sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.easynet.nl/mirror/gentoo/ http://ftp.snt.utwente.nl/
pub/os/linux/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/keeps/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://10.0.0.153/gentoo-portage"
USE="x86 X aac aalib acpi alsa apm arts avi bash-completion berkdb bitmap-fonts 
cdparanoia cdr chroot cle266 crypt cups curl dga directfb dvd dvdr dvdread dxr3 
edl emboss encode esd fam fbcon flac flash foomaticdb fortran gd gdbm ggi gif 
gimpprint glut gpm gtk gtk2 imagemagick imlib ipv6 jack java jpeg kerberos krb4 
lcms libcaca libg++ libwww lzo mad matroska mikmod mmx mmxext mng motif mozilla 
mozsvg mozxmlterm mp3 mpeg multitarget mysql nas ncurses network nls nptl 
nptlonly ogg oggvorbis opengl oss pam pdflib perl physfs pic png ppds python qt 
quicktime readline real rtc samba screenshot sdl server sftplogging slang speex 
spell sse ssl svg svga sysfs tcpd theora threads tiff truetype truetype-fonts 
type1-fonts unicode usb userlocales v4l v4l2 video_cards_via vorbis winbind wmf 
xanim xine xml xml2 xmms xosd xprint xv xvid xvmc zlib userland_GNU kernel_linux 
elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2005-07-21 12:28:52 UTC
Created attachment 64005 [details]
strace output for genlop (app-portage/genlop-0.30.3)

Output from this command: strace -ogenlop.strace genlop -c
Comment 2 Barry Grussling 2005-07-21 22:48:51 UTC
Same thing here on a fresh install.
Comment 3 Roger 2005-07-24 00:12:56 UTC
I've got the same problem here also with app-portage/genlop-0.30.2

$ genlop -c
!!! Error: no working merge found.
Comment 4 Jerry Kiely 2005-07-26 05:41:35 UTC
Same problem here, both with app-portage/genlop-0.30.2 and 
app-portage/genlop-0.30.3. 
 
J.K. 
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2005-07-26 06:00:26 UTC
Please stop reporting confirmations.

The problem is not caused by any specific version of genlop, but by a change in 
recent versions of sys-apps/sandbox which are now (being) keyworded as stable.
Comment 6 CJ van den Berg 2005-07-26 10:12:23 UTC
Created attachment 64361 [details, diff]
patch against app-portage/genlop-0.30.3

Here's a little patch that I use.
It uses ps instead of /tmp/sandboxpids.tmp

It probably doesn't need to use xargs, but my perl sucks.
Comment 7 Chris Brundage 2005-07-29 19:34:26 UTC
Created attachment 64698 [details]
genlop-0.30.3-r1.ebuild

Here's the ebuild that uses CJ's patch to fix the problem. The patch needs to
be named genlop-0.30.3-r1-sandbox.patch for it to work. It's my first ebuild so
sorry if I made a mistake.
Comment 8 CJ van den Berg 2005-08-02 05:31:56 UTC
This is fixed in genlop-0.30.4 (see bug #100938)
Comment 9 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-10-18 07:22:56 UTC
Since it's fixed there :)

*** This bug has been marked as a duplicate of 100938 ***
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2007-07-16 07:39:28 UTC
Wrong reason to close...