Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 96470 - Add incremental support for revdep-rebuild enviroment variables
Summary: Add incremental support for revdep-rebuild enviroment variables
Status: RESOLVED WONTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Portage team
URL: http://bugs.gentoo.org/show_bug.cgi?i...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-18 09:52 UTC by Paul Varner (RETIRED)
Modified: 2005-09-25 07:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Varner (RETIRED) gentoo-dev 2005-06-18 09:54:37 UTC
In order to provide the greatest flexibilty to the architecture teams and
package maintainers. I would like to see the SEARCH_DIRS, SEARCH_DIRS_MASK, and
LD_LIBRARY_MASK variables used by revdep-rebuild be added as incremental
variables to portage.

This allows the architecture teams the flexibility to set the variables in the
appropriate profiles, and allows package maintainers to add appropriate settings
to /etc/env.d files.

A patch is located at http://bugs.gentoo.org/attachment.cgi?id=61451&action=view
in bug #62644

Reproducible: Always
Steps to Reproduce:
n/a


Actual Results:  
n/a

Expected Results:  
n/a
Comment 1 SpanKY gentoo-dev 2005-06-18 16:40:12 UTC
i dont see the point

those variables are *only* used by revdep rebuild so exporting them via env.d
entries is wrong

you should setup a system where packages can dump files into say
/etc/portage/revdep-rebuild/ and then have your revdep-rebuild script parse those
Comment 2 Paul Varner (RETIRED) gentoo-dev 2005-06-19 08:40:12 UTC
The point is to make it easier for both devs and users to be able to customize
revdep-rebuild to match their gentoo systems and thus hopefully reduce some bug
reports. I have had requests to be able have these variables in the profiles and
environment from other devs.  To me, the best method was to let portage handle
that since it already does it for other variables.

Having said all that, I'm not attached to any specific method of implementation
and I won't be offended if this enhancement request is rejected.
Comment 3 SpanKY gentoo-dev 2005-06-19 12:05:21 UTC
to 'let portage handle it' means to install env.d entries and have that variable
make it into profile.env which all users will have in their environment which is
wrong

the amount of work to have an ebuild guy install a custom file into /etc/env.d
or into /etc/portage/revdep-rebuild is the same ... it would just take a bit of
work on your part to have revdep-rebuild add all the files together
Comment 4 Jason Stubbs (RETIRED) gentoo-dev 2005-07-28 07:24:58 UTC
Putting a hold on feature requests for portage as they are drowning out the 
bugs. Most of these features should be available in the next major version of 
portage. But for the time being, they are just drowning out the major bugs and 
delaying the next version's progress. 
 
Any bugs that contain patches and any bugs for etc-update or dispatch-conf can 
be reopened. Sorry, I'm just not good enough with bugzilla. ;) 
Comment 5 Paul Varner (RETIRED) gentoo-dev 2005-09-25 07:52:52 UTC
Reopening to resolve as wontfix.  I'm going with Spanky's suggestion.
Comment 6 Paul Varner (RETIRED) gentoo-dev 2005-09-25 07:54:06 UTC
revdep-rebuild will use its own files instead of /etc/env.d files.