Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 96424 - app-pda/orange-0.2-r1 failed to compile
Summary: app-pda/orange-0.2-r1 failed to compile
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Low normal (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-17 18:30 UTC by Daevid Vincent
Modified: 2006-08-08 10:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daevid Vincent 2005-06-17 18:30:28 UTC
i've tried several times to emerge app-pda/orange

tried with conservative CFLAGS, recompiled all DEPENDS and still no go...

/bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -
I. -I..    -g -ansi -Wall -Wno-long-long -Werror -march=pentium4  -I.. -
march=pentium4 -c -o inno.lo `test -f 'inno.c' || echo './'`inno.c
rm -f .libs/inno.lo
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -g -ansi -Wall -Wno-long-
long -Werror -march=pentium4 -I.. -march=pentium4 -c inno.c -MT inno.lo -MD -
MP -MF .deps/inno.TPlo  -fPIC -DPIC -o .libs/inno.lo
rm -f .libs/helper.lo
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -g -ansi -Wall -Wno-long-
long -Werror -march=pentium4 -I.. -march=pentium4 -c helper.c -MT helper.lo -
MD -MP -MF .deps/helper.TPlo  -fPIC -DPIC -o .libs/helper.lo
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -g -ansi -Wall -Wno-long-
long -Werror -march=pentium4 -I.. -march=pentium4 -c helper.c -MT helper.lo -
MD -MP -MF .deps/helper.TPlo -o helper.o >/dev/null 2>&1
inno.c: In function `SEInflateBlockRead':
inno.c:387: warning: use of cast expressions as lvalues is deprecated
inno.c: In function `FreeStrings':
inno.c:410: warning: use of cast expressions as lvalues is deprecated
inno.c: In function `ReadEntries':
inno.c:474: warning: use of cast expressions as lvalues is deprecated
inno.c: In function `FreeEntries':
inno.c:493: warning: use of cast expressions as lvalues is deprecated
make[2]: *** [inno.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .libs/helper.lo helper.lo
make[2]: Leaving directory `/var/tmp/portage/orange-0.2-r1/work/orange-0.2/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/orange-0.2-r1/work/orange-0.2'
make: *** [all] Error 2

Reproducible: Always
Steps to Reproduce:
emerge -Dav synce
Actual Results:  
!!! ERROR: app-pda/orange-0.2-r1 failed.
!!! Function src_compile, Line 29, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

Expected Results:  
compiled and installed cleanly

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-
2.3.4.20041102-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 
2.00GHz
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5,dev-lang/python-2.2.3-r6 [2.3.5 
(#1, Apr 27 2005, 23:45:13)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) 
[disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5, 2.2.3-r6
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.8.5-r3, 1.9.5, 1.7.9-r1, 1.6.3, 1.4_p6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde
/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/
kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11
/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks fixpackages parallel-fetch 
sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib acpi alsa apm arts avi berkdb bitmap-fonts cdr crypt curl eds 
emboss encode esd evo fam flac foomaticdb fortran gd gdbm ggi gif gnome gpm 
gstreamer gtk gtk2 imagemagick imlib ipv6 java jpeg kde libg++ libwww mad 
mikmod motif mozilla mp3 mpeg mysql ncurses nls ogg oggvorbis opengl oss pam 
pdflib perl png python qt quicktime readline samba sdl slang spell ssl svga 
tcltk tcpd tiff truetype truetype-fonts type1-fonts vorbis wifi xine xml2 xmms 
xv zlib linguas_en userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2005-06-20 08:01:15 UTC
emm, not quite sure because it works for me for gcc 3.4. it seems like you've got -Werror in the CFLAGS 
that it is using. not quite sure why, but tahts why it is aborting for you.
Comment 2 Alastair Tse (RETIRED) gentoo-dev 2005-07-08 03:51:59 UTC
can you attach the full build log to this bug?
Comment 3 Chris White (RETIRED) gentoo-dev 2006-08-08 10:15:11 UTC
Resolved as TEST-REQUEST until requested test request is handled.