Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 96314 - poor quality mp3 playback with noatun, amarok - akode issue?
Summary: poor quality mp3 playback with noatun, amarok - akode issue?
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2005-06-16 15:00 UTC by Jannick Kuhr
Modified: 2005-12-25 05:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jannick Kuhr 2005-06-16 15:00:00 UTC
When playing mp3files (and only mp3files - no problems with ogg or wave) with the kde apps amarok and noatun (probably others too) the playback quality is very poor (noticeable crackles especially whitin the beginning of a track). When I play the same file using mplayer, realplayer10 or even kaffeine the playback quality is almost perfect, so this doesn't seem to be an arts issue or a problem with mp3files in general.

In this debian related bugreport ( there is described a similar behaviour. Possibly it's here a problem with aKode too.

I'm using kde-3.4.1 on amd64.

Portage (default-linux/amd64/2005.0, gcc-3.4.3, glibc-, 2.6.11-gentoo-r11 x86_64) 
 System uname: 2.6.11-gentoo-r11 x86_64 AMD Athlon(tm) 64 Processor 3000+ 
 Gentoo Base System version 1.6.12 
 Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Jun 16 2005, 00:47:33)] 
 ccache version 2.3 [enabled] 
 dev-lang/python:     2.3.5 
 sys-apps/sandbox:    [Not Present] 
 sys-devel/autoconf:  2.13, 2.59-r6 
 sys-devel/automake:  1.5, 1.8.5-r3, 1.6.3, 1.7.9-r1, 1.4_p6, 1.9.5 
 sys-devel/libtool:   1.5.16 
 CFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer" 
 CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control" 
 CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
 CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer" 
 FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict" 
 USE="amd64 X acpi alsa arts artswrappersuid berkdb bitmap-fonts cddb cdr crypt cups curl dvd dvdr encode esd fam flac font-server foomaticdb fortran gd gdbm gif gimpprint gphoto2 gpm gtk gtk2 imagemagick imlib ipv6 java jp2 jpeg kde lzw lzw-tiff mad mozilla mp3 mpeg nas ncurses network nls nptl nptlonly ogg oggvorbis opengl oss pam perl png ppds python qt quicktime readline samba sdl spell ssl tcpd tidy tiff truetype truetype-fonts type1-fonts unicode usb userlocales vorbis xine xml2 xpm xrandr xv zlib linguas_de userland_GNU kernel_linux elibc_glibc" 
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-06-16 15:29:11 UTC
The Akode engine was never well supported by Amarok and in svn disabled now. Use
Xine or GStreamer as backend.
Comment 2 Jannick Kuhr 2005-06-17 05:04:58 UTC
Using GStreamer as backend doesn't change anything and using xine crashes 
Comment 3 Jannick Kuhr 2005-06-18 09:20:04 UTC
If I compile the program with USE="-mp3" the problem is gone, but I don't think 
this is really a solution. 
Comment 4 Carsten Lohrke (RETIRED) gentoo-dev 2005-06-27 08:15:14 UTC
Um, I'm just noticing that only the new beta release has a mp3 flag and it's
only used for gst-plugins-mad. Please always start a summary of your bug report
with $category/$ebuild-x.y, otherwise I assume we speak about the latest stable

>but I don't think this is really a solution. 

If I'm right and we speak about beta software marked testing (well, even masked
in between), it's not a hot issue to be solved asap.
Comment 5 Jannick Kuhr 2005-06-28 02:43:11 UTC
Sorry, I mentioned that I am using kde-3.4.1, but of course I have to make this 
clearer. At the moment this software is marked testing but not (hard)masked. 
Btw if I remove the line "options snd-via82xx index=0 dxs_support=3" 
from /etc/modules.d/alsa the sound is much better. It is not as good as a 
system compiled with USE="-mp3", but it's more or less ok. 
I think it would be enough to wait until kde-3.4.1 becomes stable and see if 
someone else has the same problems. 
Comment 6 Carsten Lohrke (RETIRED) gentoo-dev 2005-06-28 08:09:58 UTC
Hm!? I spoke about Amarok, not KDE. The latter has nothing to with it, when you
have problems with GStreamer or Xine as backend.
Comment 7 Jannick Kuhr 2005-06-28 08:36:01 UTC
Hmm, confusion ;-) I use the latest stable version of amarok. But I don't think 
that this is a problem of amarok, because noatun for example has the same 
problems. The problem is gone if i compile _kde_ with USE=-mp3. 
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-06-28 08:46:13 UTC
Hmm I'm having a similar problem but this involves every type of files... the  
problem seems to be with new alsa-driver and/or with new linux kernel. 
I'm trying to find this further... 
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-06-28 08:57:53 UTC
options snd-via82xx dxs_support=4  
this fixed for me (disables dxs support), seems like the default changed and  
now it defaults to something that disrupts gstreamer (or something like that).  
Try to see if it works for you and in such case try with other values for  
dxs_support (0 for example).  
The problem seems to be that gstreamer transcodes to 48kHz instead of  
retaining on 44kHz.  
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-06-28 17:31:04 UTC
Ok dxs_support=4 worked fine for ogg/flac files but some mp3 still got 
dxs_support=5 (always enabled) without dmix and setting gstreamer and xine to 
work directly on 'hw:0,0' worked better and now I'm not having strange sound 
for now. 
Comment 11 Carsten Lohrke (RETIRED) gentoo-dev 2005-07-08 13:32:37 UTC
(In reply to comment #7)
> Hmm, confusion ;-) I use the latest stable version of amarok. But I don't think 
> that this is a problem of amarok, because noatun for example has the same 
> problems. The problem is gone if i compile _kde_ with USE=-mp3. 

When you have the same problem with gstreamer, it hardly can be a kde issue. The
mp3 use flag invokes media-libs/libmad, so can it seems to be a problem
somewhere between libmad and the alsa-driver. 

Did Diego's comments help you? Which alsa-driver are you using? Usually the ones
shipping with your kernel should work. Otherwise you may try newer or older
external ones. Same goes for libmad. Did you look at the log files, if the alsa
driver spit out anything?
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-12-02 04:26:36 UTC
Please provide updated information. 
Comment 13 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-25 05:36:43 UTC
No feedback.