Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 94701 - Request for ebuild: dev-java/pluto
Summary: Request for ebuild: dev-java/pluto
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Java team
URL: http://portals.apache.org/pluto/index...
Whiteboard:
Keywords:
: 217275 (view as bug list)
Depends on:
Blocks: 63276 94434
  Show dependency tree
 
Reported: 2005-05-31 22:00 UTC by Josh Nichols (RETIRED)
Modified: 2015-10-31 09:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for pluto 1.0.1 (pluto-1.0.1.ebuild,1.16 KB, text/plain)
2012-06-09 12:47 UTC, Ivan Baidakou (dmol)
Details
ant build.xml patch (pluto-1.0.1-build-xml.patch,909 bytes, patch)
2012-06-09 12:48 UTC, Ivan Baidakou (dmol)
Details | Diff
pluto ebuild (pluto-1.0.1.ebuild,918 bytes, text/plain)
2012-06-10 10:39 UTC, Ivan Baidakou (dmol)
Details
pluto-1.0.1.ebuild (pluto-1.0.1.ebuild,908 bytes, text/plain)
2012-06-10 11:43 UTC, Ivan Baidakou (dmol)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Nichols (RETIRED) gentoo-dev 2005-05-31 22:00:17 UTC
"Pluto is the Reference Implementation of the Java Portlet Specfication."

pluto is a dependency of myfaces, which in turn is a dependency of jboss-4.0.2.

The source download link on their homepage seems to be inaccessible for that particular apache mirror, but others seem to work fine ( like http://www.ip97.com/apache.org/portals/pluto/pluto-src-1.0.1-rc2.tar.gz )
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2008-04-11 12:45:51 UTC
*** Bug 217275 has been marked as a duplicate of this bug. ***
Comment 2 Ivan Baidakou (dmol) 2012-06-09 12:47:52 UTC
Created attachment 314787 [details]
ebuild for pluto 1.0.1
Comment 3 Ivan Baidakou (dmol) 2012-06-09 12:48:25 UTC
Created attachment 314789 [details, diff]
ant build.xml patch
Comment 4 Ivan Baidakou (dmol) 2012-06-09 15:43:54 UTC
Comment on attachment 314787 [details]
ebuild for pluto 1.0.1

change mime type to text/plain
Comment 5 Ivan Baidakou (dmol) 2012-06-10 10:39:48 UTC
Created attachment 314859 [details]
pluto ebuild

new pluto ebuild, thanks for critical review of Chewi and sera on #gentoo-java.
Comment 6 Ivan Baidakou (dmol) 2012-06-10 11:43:05 UTC
Created attachment 314865 [details]
pluto-1.0.1.ebuild

Updated version
Comment 7 Patrice Clement gentoo-dev 2015-10-31 09:39:17 UTC
It's a huge project that doesn't have much momentum since 2011 and isn't required by anything so far. Let's scrap it.