Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 94136 - Ebuild for media-sound/wired-0.6
Summary: Ebuild for media-sound/wired-0.6
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Other
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://bloodshed.net/wired/?sid=1
Whiteboard:
Keywords: EBUILD
: 126819 (view as bug list)
Depends on: 90614 94354
Blocks:
  Show dependency tree
 
Reported: 2005-05-26 20:30 UTC by Mike Crawford (ali3nx)
Modified: 2017-07-21 09:22 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
wired-0.11.ebuild (wired-0.11.ebuild,839 bytes, text/plain)
2005-05-26 20:31 UTC, Mike Crawford (ali3nx)
Details
portaudio-19.ebuild (portaudio-19.ebuild,786 bytes, text/plain)
2005-05-26 20:34 UTC, Mike Crawford (ali3nx)
Details
media-sound/wired-0.11.ebuild (wired-0.11.ebuild,984 bytes, text/plain)
2005-05-29 21:21 UTC, Bel Zébute
Details
media-sound/wired-0.11-r1.ebuild (wired-0.11-r1.ebuild,988 bytes, text/plain)
2005-08-04 07:01 UTC, Toffanin
Details
wired 0.2.1 ebuild (wired-0.2.1.ebuild,1.28 KB, text/plain)
2006-04-11 17:02 UTC, Jonathan Huot
Details
wired 0.2.2 ebuild (wired-0.2.2.ebuild,1.27 KB, text/plain)
2006-05-23 13:04 UTC, Jonathan Huot
Details
media-sound/wired-0.3.1.ebuild (wired-0.3.1.ebuild,1.62 KB, text/plain)
2006-09-24 08:59 UTC, Jonathan Huot
Details
media-sound/wired-0.4alpha.ebuild (wired-0.4alpha.ebuild,1.62 KB, text/plain)
2006-11-20 06:17 UTC, Jonathan Huot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Crawford (ali3nx) 2005-05-26 20:30:05 UTC
Would like to submit this ebuild for Wired. Wired aims to be a professional
music production and creation software running on the Linux operating system.
Ebuild created by myself ali3nx, emorphix and various contributors of #gentoo on
efnet

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Mike Crawford (ali3nx) 2005-05-26 20:31:48 UTC
Created attachment 59919 [details]
wired-0.11.ebuild
Comment 2 Mike Crawford (ali3nx) 2005-05-26 20:34:16 UTC
has a dependancy on a specific version of portaudio and mono.eclass. ebuild to
satisfy dependancies provided and scripted by emorphix
Comment 3 Mike Crawford (ali3nx) 2005-05-26 20:34:57 UTC
Created attachment 59920 [details]
portaudio-19.ebuild
Comment 4 Kito (RETIRED) gentoo-dev 2005-05-27 10:50:35 UTC
application/octet-stream shouldn't really be used for plain text...

Taking the lazy route, and not looking to far into it, portaudio should definitely be slotted to allow 
concurrent installs of v.18 and v.19. If noone beats me to it, I'll hack on that in a few days.
Comment 5 Mike Crawford (ali3nx) 2005-05-27 14:09:54 UTC
I used the auto mime feature in bugzilla. I've corrected the mime types and
added EBUILD keywords
Comment 6 Bel Zébute 2005-05-29 01:11:07 UTC
Since portaudio is already in Portage, I thought it would be nice to unconceal
the ebuild from under the bug of Wired.  As such, I have augmented the ebuild
from here and posted it in bug #94354.

The new ebuild got fixed by removing the unneeded dependency to zip, the
unconventional C var also has been supressed.

The new ebuild has been enhanced to make use of alsa, oss and jack USE flags.
Comment 7 Bel Zébute 2005-05-29 21:21:35 UTC
Created attachment 60140 [details]
media-sound/wired-0.11.ebuild

This one works.  Now, if only I knew how to use it.  I can make Wired emmit
sounds but I sure can't edit yet.  Docs seem skinny.

Done:
- Removed mono eclass (since I can't see why it's needed).
- Added wxwidget eclass inheritance
- Removed funky C and MY_P vars and use more a conventional scheme.
- Added missing dependency to libsndfile
- Updated dependency to wxGTK-2.6.0 since the eclass does not support 2.5.x
- Detects that wxGTK is of 2.6 and not compiled with unicode
- The jack enabled portaudio works,  Started Wired and jackd picked it up.

To do:
- More fine grained src_install() section that make use of the "doc" USE flag.
- To test the "static" USE flag.
- More testing...
Comment 8 Mark Knecht 2005-05-30 15:00:15 UTC
Where do I place this test ebuild to try this out?

Happy to do a little testing.
Comment 9 CJ Kucera 2005-06-19 19:01:04 UTC
wxGTK-2.6.0-r1 seems to be SLOTted so that the wx-config binary is installed as
wx-config-2.6, at least on my system.  I'm not sure whether that happens only
when you've got a previously-installed 2.4 wxGTK or if it's just always like
that, but regardless on my system that's how it is, and that breaks this ebuild.

In order to get the wired-0.11 ebuild to work on my system, I had to make two
changes.

1) Use "wx-config-2.6" in the second line of src_compile, instead of "wx-config"
2) Added the following to the ebuild:

src_unpack() {
    unpack ${A}
    cd ${S}
    for file in `grep -r wx-config * | cut -d: -f1 | sort | uniq`
    do
        sed -i -e 's:wx-config:wx-config-2.6:g' $file
    done
}

... as I said, I'm not sure if that wx-config-2.6 is *always* present on 2.6
ebuilds, so it may be worthwhile to check for the existance of a wx-config-2.6
binary first before making these changes.  But anyway, there's that.

Of course, when I try to run Wired now, I get:
[PLUGLOADER] Error: Cannot open library: /usr/lib/libWiredBeatBox.so: undefined
symbol: _ZN14BeatNoteToPlayC1EifmP14BeatBoxChannelPPf

... but I think that's a problem with Wired itself, not the wxGTK stuff.
Comment 10 Bel Zébute 2005-06-19 20:48:49 UTC
Funny.  I have more than one version too, but it build fine.

In the src_conpile section, WX_GTK_VER=2.6 is suppose to take care on which
version it will compile.

Are you using the last ebuild version (there are two ebuild in this bug, but I
can't set the first one as obsolete).
Comment 11 CJ Kucera 2005-06-19 21:10:50 UTC
Yeah, I was using the second ebuild.  I had to change the wx-config in
src_compile to wx-config-2.6 before I could even get past the 'if' block, and
then I had to do the recursive sed on all the Makefiles before it would compile
properly.  I haven't synced in a week or so; perhaps something's been updated in
the wxlibs eclass or something since then...  Anyway, back to figuring out
what's up with that dlopen problem I'm having (looks like it goes away when I
just do a "./configure && make" outside of Portage, so something in there is
screwing it up).
Comment 12 Bel Zébute 2005-06-20 09:27:30 UTC
I had similar problems when I used the first ebuild, so I took a look at other
ebuilds that make use of the wxGTK widgets and did some experimentations.

for i in /usr/portage/*/*/*.ebuild; do [ "`sed '/wxGTK-2.6/!d' $i`" ] && echo
$i; done

This onliner should list ebuilds that depends on wxGTK.  I based myself on amule
because it starts by 'a' ;)
Comment 13 Toffanin 2005-08-04 07:01:28 UTC
Created attachment 65067 [details]
media-sound/wired-0.11-r1.ebuild

New ebuild version.
The wired-0.11.ebuild use the command "wx-config" to determine the wxGTK
version, but this command is for wxGTK =< 2.4, for the 2.6 serie must be used
the command "wx-config-2.6"; so i changed the line:

if need-wxwidgets gtk2 && wx-config --version | grep 2.6

to

if need-wxwidgets gtk2 && wx-config-2.6 --version | grep 2.6

otherwise the ebuild show an error about wrong wxGTK, also if the right wxGTK
is installed. (however i dont understand why the ebuild must check the wxGTK
version if there is: >=x11-libs/wxGTK-2.6.0 as dependency)
Comment 14 Jouni Rinne 2005-08-16 11:14:42 UTC
I'm trying to emerge wired-0.11-r1, but the compilation fails with the error:

<snip>
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../src/include  
-I/usr/lib/wx/include/gtk2-2.4 -DGTK_NO_CHECK_CASTS -D__WXGTK__
-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -I../audio -I../plugins -I../fileloader
-I/opt/gnome/include -I../sequencer -I../redist -I../engine -I../mixer -I../midi
-I../midi/portmidi/pm_common -I../midi/portmidi/porttime -I../asm -I../editmidi
-I../undo -I../libs/WiredWidgets/src -g3 -O3  -ggdb -MT HelpCtrl.o -MD -MP -MF
".deps/HelpCtrl.Tpo" -c -o HelpCtrl.o HelpCtrl.cpp; \
then mv -f ".deps/HelpCtrl.Tpo" ".deps/HelpCtrl.Po"; else rm -f
".deps/HelpCtrl.Tpo"; exit 1; fi
HelpCtrl.cpp: In constructor `HelpCtrl::HelpCtrl(wxWindow*, wxWindowID,
wxString, const wxPoint&, const wxSize&)':
HelpCtrl.cpp:8: error: `wxHW_NO_SELECTION' undeclared (first use this function)
HelpCtrl.cpp:8: error: (Each undeclared identifier is reported only once for
each function it appears in.)
make[2]: *** [HelpCtrl.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/wired-0.11-r1/work/wired/src/gui'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/wired-0.11-r1/work/wired/src'
make: *** [all-recursive] Error 1

!!! ERROR: media-sound/wired-0.11-r1 failed.
!!! Function src_compile, Line 31, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.

The strange thing in this is, the output above is talking about gtk2-2.4, but at
the start of compilation there's a message:

<snip>
>>> Unpacking wired-0.11.tar.gz to /var/tmp/portage/wired-0.11-r1/work
>>> Source unpacked.
 * Using /usr/lib/wx/config/gtk2-ansi-release-2.6
2.6.1
<snip>

Is wired somehow using the wrong wxGTK library, in spite of the message? Or is
there something wrong in my wxGTK setup? The output of 'wx-config-2.6 --list' is:

    Default config is gtk2-ansi-release-2.6

  Default config will be used for output

  Legacy configs available in /usr:
    wxgtk2-2.4

Other wxGTK-using programs (audacity, scorched3d etc.) have compiled without any
errors. wxGTK-2.6.1 is emerged with USE="-unicode".
Comment 15 F mayer 2005-08-27 12:41:12 UTC
Well media-sound/wired-0.11.ebuild has got a little bug.
sed 's/xwGTK/wxGTK/' /path/to/ebuild should fix it 
Comment 16 F mayer 2005-08-27 13:11:23 UTC
Im getting another error too:
Making all in src
make[1]: Entering directory `/var/tmp/portage/wired-0.11-r1/work/wired/src'
Making all in gui
make[2]: Entering directory `/var/tmp/portage/wired-0.11-r1/work/wired/src/gui'
if g++ -DHAVE_CONFIG_H -I. -I. -I../../src/include   -I/usr/lib/wx/include/gtk2u
-2.4 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -I..
/audio -I../plugins -I../fileloader -I/opt/gnome/include -I../sequencer -I../red
ist -I../engine -I../mixer -I../midi -I../midi/portmidi/pm_common -I../midi/port
midi/porttime -I../asm -I../editmidi -I../undo -I../libs/WiredWidgets/src -g3 -O
3  -ggdb -MT ChannelGui.o -MD -MP -MF ".deps/ChannelGui.Tpo" -c -o ChannelGui.o 
ChannelGui.cpp; \
then mv -f ".deps/ChannelGui.Tpo" ".deps/ChannelGui.Po"; else rm -f ".deps/Chann
elGui.Tpo"; exit 1; fi
ChannelGui.cpp: In constructor `ChannelGui::ChannelGui(Channel*, wxImage*, 
   wxImage*, wxWindow*, int, const wxPoint&, const wxSize&, const wxString&)':
ChannelGui.cpp:40: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:57: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:58: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:59: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:71: error: conversion from `const char[4]' to `const wxString' 
   is ambiguous
/usr/include/wx/string.h:306: error: candidates are: 
   wxString::wxString(wchar_t, unsigned int) <near match>
/usr/include/wx/string.h:284: error:                 wxString::wxString(int) 
   <near match>
ChannelGui.cpp:74: error: conversion from `const char[4]' to `const wxString' 
   is ambiguous
/usr/include/wx/string.h:306: error: candidates are: 
   wxString::wxString(wchar_t, unsigned int) <near match>
/usr/include/wx/string.h:284: error:                 wxString::wxString(int) 
   <near match>
ChannelGui.cpp:89: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:91: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:93: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp:95: error: call of overloaded `wxImage(const char*, wxBitmapType
   )' is ambiguous
/usr/include/wx/image.h:121: error: candidates are: wxImage::wxImage(const 
   wxString&, const wxString&, int) <near match>
/usr/include/wx/image.h:120: error:                 wxImage::wxImage(const 
   wxString&, long int, int) <near match>
/usr/include/wx/image.h:118: error:                 wxImage::wxImage(int, int) 
   <near match>
ChannelGui.cpp: In member function `void 
   ChannelGui::OnFaderLeft(wxScrollEvent&)':
ChannelGui.cpp:141: error: no matching function for call to `wxString::Printf(
   const char[3], int)'
/usr/include/wx/string.h:733: error: candidates are: int wxString::Printf(const 
   wxChar*, ...)
ChannelGui.cpp: In member function `void 
   ChannelGui::OnFaderRight(wxScrollEvent&)':
ChannelGui.cpp:165: error: no matching function for call to `wxString::Printf(
   const char[3], int)'
/usr/include/wx/string.h:733: error: candidates are: int wxString::Printf(const 
   wxChar*, ...)
ChannelGui.cpp: In constructor `MasterChannelGui::MasterChannelGui(Channel*, 
   wxImage*, wxImage*, wxWindow*, int, const wxPoint&, const wxSize&)':
ChannelGui.cpp:287: error: conversion from `const char[7]' to `const wxString' 
   is ambiguous
/usr/include/wx/string.h:306: error: candidates are: 
   wxString::wxString(wchar_t, unsigned int) <near match>
/usr/include/wx/string.h:284: error:                 wxString::wxString(int) 
   <near match>
ChannelGui.cpp: In member function `void 
   MasterChannelGui::OnFaderLeft(wxScrollEvent&)':
ChannelGui.cpp:300: error: no matching function for call to `wxString::Printf(
   const char[3], int)'
/usr/include/wx/string.h:733: error: candidates are: int wxString::Printf(const 
   wxChar*, ...)
ChannelGui.cpp: In member function `void 
   MasterChannelGui::OnFaderRight(wxScrollEvent&)':
ChannelGui.cpp:324: error: no matching function for call to `wxString::Printf(
   const char[3], int)'
/usr/include/wx/string.h:733: error: candidates are: int wxString::Printf(const 
   wxChar*, ...)
make[2]: *** [ChannelGui.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/wired-0.11-r1/work/wired/src/gui'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/wired-0.11-r1/work/wired/src'
make: *** [all-recursive] Error 1
Comment 17 Carsten Lohrke (RETIRED) gentoo-dev 2006-03-19 08:38:12 UTC
*** Bug 126819 has been marked as a duplicate of this bug. ***
Comment 18 Jonathan Huot 2006-04-11 17:02:01 UTC
Created attachment 84473 [details]
wired 0.2.1 ebuild 

New ebuild for version 0.2.1 of Wired.
Comment 19 Jonathan Huot 2006-05-23 13:04:41 UTC
Created attachment 87340 [details]
wired 0.2.2 ebuild

Ebuild for new release 0.2.2 of Wired.
Comment 20 Jonathan Huot 2006-09-24 08:59:10 UTC
Created attachment 97952 [details]
media-sound/wired-0.3.1.ebuild

Wired is no more dependent of Portaudio v19.
Wired can be installed without it, because it integrate a built-in version.

Since this version, I think that nothing block its integration in main tree of portage.
Comment 21 Jonathan Huot 2006-11-20 06:17:36 UTC
Created attachment 102397 [details]
media-sound/wired-0.4alpha.ebuild

New version.
Bump for delete deprecated version (< 0.4, and portaudio-v19.ebuild)
Comment 22 Samuli Suominen gentoo-dev 2008-05-22 08:39:00 UTC
Wired 0.6 seems to be out, and it's using internal copy of Portaudio v19 and Portmidi ( http://portmedia.wiki.sourceforge.net/portmidi ). This is unacceptable
as it should be using the external system libraries. It's also shipping autogen.sh, which copies gettext from system into the source directory using autopoint. Also wrong. It should be using the gettext from system.

Bug 90614 needs to be solved first, then patch Wired to use system libraries.

Overall, I don't see acceptable ebuild attached here yet.
Comment 23 Marek Szuba gentoo-dev 2017-02-28 13:09:18 UTC
Upstream seems to be dead: the Web site is gone, the latest version available on SourceForge (0.7.0) was released in July 2009, and there hasn't been any Subversion commits since July 2010. Is there still any interest in adding this software to the tree? Unless there are any indications to the contrary, I will close this bug as WONTFIX in 30 days.