Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 93705 - muine-0.6.3-r3 ebuild needs XML::Parser perl module
Summary: muine-0.6.3-r3 ebuild needs XML::Parser perl module
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-23 08:52 UTC by James Lambert
Modified: 2005-05-25 08:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Lambert 2005-05-23 08:52:18 UTC
I did an 'emerge muine'and the build failed with the following error during
configure

configure: error: XML::Parser perl module is required for intltool

Installing the XML::Parser module using 'perl -MCPAN -e 'install XML::Parser'
resolved the issue




Reproducible: Always
Steps to Reproduce:
1.emerge muine
2.wait
3.read the error message

Actual Results:  
build fails with 
configure: error: XML::Parser perl module is required for intltool


Expected Results:  
This should have been installed as a dependency.

Portage 2.0.51.22-r1 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.5-r0,
2.6.11-gentoo-r8 i686)
=================================================================
System uname: 2.6.11-gentoo-r8 i686 Intel(R) Pentium(R) 4 CPU 3.06GHz
Gentoo Base System version 1.6.12
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.5-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.16
sys-devel/libtool:   1.5.18
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -mcpu=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe -mcpu=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mir.zyrianes.net/gentoo ftp://mir.zyrianes.net/gentoo/"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="x86 X alsa apm avi berkdb bitmap-fonts cdparanoia cdr cdrw crypt cups curl
directfb eds emboss encode esd fam flac foomaticdb fortran gdbm gif gnome
gnome-vfs gpm gstreamer gtk gtk2 hal imlib ipv6 java jpeg libg++ libwww mad
mikmod mmx motif mp3 mpeg ncurses nls nptl nptlonly nvidia ogg oggvorbis opengl
oss pam pdflib perl png python quicktime readline sdl spell sse sse2 ssl svga
tcpd tiff truetype truetype-fonts type1-fonts udev vorbis xml2 xmms xv zlib
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-05-23 09:10:57 UTC
!!! Step 1 - search for your bug !!!

This is really just wasting dev
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-05-23 09:10:57 UTC
!!! Step 1 - search for your bug !!!

This is really just wasting dev´s and bug wrangler´s time. :-(

*** This bug has been marked as a duplicate of 41124 ***
Comment 3 Michael Cummings (RETIRED) gentoo-dev 2005-05-23 09:24:30 UTC
This isn't a dup, its a new bug. latexter - the configure script for muine 
0.6.3 is looking for XML::Parser: 
 
f `perl -e "require XML::Parser" 2>/dev/null`; then 
: 
else 
   { { echo "$as_me:$LINENO: error: XML::Parser perl module is required for 
intltool" >&5 
echo "$as_me: error: XML::Parser perl module is required for intltool" >&2;} 
   { (exit 1); exit 1; }; } 
fi 
 
Comment 4 Michael Cummings (RETIRED) gentoo-dev 2005-05-23 09:25:35 UTC
latexer - see last comment, didn't realize I couldn't reassign it to you 
directly while marking reopen (wasn't a dup of the gnome bug, not sure why 
jakub assigned it such) 
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-05-23 09:41:09 UTC
Oh well, my mistake. Sorry guys... 
Comment 6 James Lambert 2005-05-23 15:40:47 UTC
I did check first... Had me worried for a second there :-)

Comment 7 foser (RETIRED) gentoo-dev 2005-05-25 07:09:21 UTC
I'm pretty sure it is the same bug as #41124 . muine should depend on
>=intltool-0.29 to work around this.
Comment 8 Michael Cummings (RETIRED) gentoo-dev 2005-05-25 08:00:15 UTC
So long as XML::Parser gets pulled in, I guess so. 
Comment 9 Peter Johanson (RETIRED) gentoo-dev 2005-05-25 08:22:16 UTC
Ok, I've just added the dep on the new enough intltool. Marking this FIXED. If
anyone disagrees, they can feel free to re-open the bug. Thanks.