Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 933173 - Open app-misc/tmux session in x11-terms/rxvt-unicode terminal
Summary: Open app-misc/tmux session in x11-terms/rxvt-unicode terminal
Status: RESOLVED DUPLICATE of bug 926608
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Shell Tools project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-05-30 09:53 UTC by Stas
Modified: 2024-06-03 14:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Xresources for urxvt (urxvt-unicode,3.22 KB, patch)
2024-05-30 10:00 UTC, Stas
Details | Diff
Make.conf (make.conf,1.17 KB, text/plain)
2024-05-30 10:01 UTC, Stas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stas 2024-05-30 09:53:17 UTC
After recent updates and the news "2024-05-07 dev-lang/perl useflags become a PERL_FEATURES use-expand", I noticed on all my machines an oddity of "x11-terms/rxvt-unicode" working with an open or newly created "tmux" session, namely:

* when creating a new session on behalf of a user (tmux new -s session), the session opens like this:
user@localhost ~ $ $ 10;rgb:b200/b200/b200/b200]11;rgb:0300/2100/2600

* when creating a new session as root (tmux new -s session), the session opens like this:
root@localhost /home/user # 10;rgb:b200/b200/b200/b200]11;rgb:0300/2100/2600

* If you connect to this session from another terminal "x11-terms/rxvt-unicode", this sequence of characters will be repeated:
user@localhost ~ $ 10;rgb:b200/b200/b200]11;rgb:0300/2100/2600]10;rgb:b200/b200/b200]11;rgb:0300/2100/2600

I installed "x11-terms/terminator" additionally - everything works fine! Normal until you connect to the session from the terminal "x11-terms/rxvt-unicode"!
When connecting to a session in "x11-terms/terminator" from "x11-terms/rxvt-unicode" it gives:
user@localhost ~ $ $ 10;rgb:b200/b200/b200/b200]11;rgb:0300/2100/2600

What I did to eliminate the error:
* Removed one by one all "USE" flags with recompilation until I removed them all!
* Reinstalled "tmux". * Opened a session from another user
* Opened "tmux" session on other machines
* Deleted my "bashrc" and "bash_profile" settings
* Installed a clean Gentoo system in a virtual machine with "tmux" & "rxvt-unicode" installed.

Tried deleting "X resources" settings - deleted configuration file from "Xresources"....
Exited "X" and even tried rebooting the machine...
Terminal reset to default settings...
The line in the "tmux" sessions changed to:
user@localhost ~ $ $ 10;rgb:0000/0000/0000/0000]11;rgb:ffff/ffffff/ffffff
Comment 1 Stas 2024-05-30 10:00:27 UTC
Created attachment 894636 [details, diff]
Xresources for urxvt
Comment 2 Stas 2024-05-30 10:01:44 UTC
Created attachment 894638 [details]
Make.conf
Comment 3 Stas 2024-05-30 10:07:43 UTC
eix x11-terms/rxvt-unicode
[I] x11-terms/rxvt-unicode
     Available versions:  9.31-r2 ~9.31-r3 {24-bit-color 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel perl startup-notification unicode3 wide-glyphs xft}
     Installed versions:  9.31-r2(11:53:25 30.05.24)(256-color blink fading-colors font-styles gdk-pixbuf mousewheel perl startup-notification unicode3 wide-glyphs xft -24-bit-color -iso14755)
     Homepage:            http://software.schmorp.de/pkg/rxvt-unicode.html
     Description:         rxvt clone with xft and unicode support
Comment 4 Stas 2024-05-30 10:08:47 UTC
USE flags:
x11-terms/rxvt-unicode 256-color blink fading-colors font-styles gdk-pixbuf mousewheel perl startup-notification unicode3 wide-glyphs xft -24-bit-color -iso14755
Comment 5 Marek Szuba archtester gentoo-dev 2024-06-03 14:43:28 UTC
Already reported and fixed in -r3.

*** This bug has been marked as a duplicate of bug 926608 ***