Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 927813 - dev-qt/qtmultimedia-5.15.12 does not emerge in profile default/linux/amd64/23.0/split-usr/desktop/plasma
Summary: dev-qt/qtmultimedia-5.15.12 does not emerge in profile default/linux/amd64/23...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
Depends on:
Reported: 2024-03-25 14:13 UTC by Stefan Trenker
Modified: 2024-03-25 19:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge log (dev-qt:qtmultimedia-5.15.12:20240325-135547.log.gz,12.25 KB, application/gzip)
2024-03-25 14:14 UTC, Stefan Trenker
emerge --info (emerge-info,10.77 KB, text/plain)
2024-03-25 14:15 UTC, Stefan Trenker
cpu flags (cpuid2cpuflags-i5-9600K,104 bytes, text/plain)
2024-03-25 14:15 UTC, Stefan Trenker

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Trenker 2024-03-25 14:13:27 UTC
emerge -1 =dev-qt/qtmultimedia-5.15.12 fails after profile change from 17.1 (default/linux/amd64/17.1/desktop/plasma) to 23.0 (default/linux/amd64/23.0/split-usr/desktop/plasma)

Under 17.1 it emerges w/o any problems, under 23.0 it bails out. Please see attached logs.

Problem seems to be Intel AVX related in combination with embedded assembler code.

Reproducible: Always
Comment 1 Stefan Trenker 2024-03-25 14:14:13 UTC
Created attachment 888542 [details]
emerge log
Comment 2 Stefan Trenker 2024-03-25 14:15:07 UTC
Created attachment 888543 [details]
emerge --info
Comment 3 Stefan Trenker 2024-03-25 14:15:51 UTC
Created attachment 888544 [details]
cpu flags
Comment 4 Stefan Trenker 2024-03-25 14:16:25 UTC
Changed Platform to amd64
Comment 5 Ionen Wolkens gentoo-dev 2024-03-25 14:24:58 UTC
>CXXFLAGS="-O2 -pipe"
Have you tried with -march=native added?

Not that things should normally fail if omitted (haven't tried), unless.. you *used* to have it set and Qt (that has a tendency to remember things that were used to build qtcore/qtbase) is now confused.
Comment 6 Stefan Trenker 2024-03-25 14:53:47 UTC
Good hint!

Creating a file /etc/portage/env/dev-qt/qtmultimedia-5.15.12 containing:

CFLAGS="-march=native -O2 -pipe"       
CXXFLAGS="-march=native -O2 -pipe"       

works as workaround.

But it should somehow be fixed in the ebuild itself.