Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 927655 - app-emacs/gnuplot-mode-0.8.1: void function gnuplot-context-sensitive-mode
Summary: app-emacs/gnuplot-mode-0.8.1: void function gnuplot-context-sensitive-mode
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GNU Emacs project
Depends on:
Reported: 2024-03-24 00:29 UTC by Lemon Lime
Modified: 2024-03-24 15:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Lemon Lime 2024-03-24 00:29:34 UTC
I downloaded the app-emacs/gnuplot-mode package, version 0.8.1 from the main portage tree.

When I tried using org-plot, I kept getting the error "void function gnuplot-context-sensitive-mode". Furthermore, all the gnuplot-mode related functions had the same error message. 

I was kinda stuck, I tried moving function definitions from my init.el file around but nothing seemed to work.
I even had all the setting the gnuplot-mode github page suggested.

So, I decided to install version 0.8.0 (also from the main portage tree), and everything worked fine.

Emacs version 29