Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 926223 - sys-auth/pam_p11 - update request - v0.3.0 outdated, upstream has 0.4.0 and 0.50
Summary: sys-auth/pam_p11 - update request - v0.3.0 outdated, upstream has 0.4.0 and 0.50
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on: 926225
  Show dependency tree
Reported: 2024-03-05 21:51 UTC by genBTC
Modified: 2024-03-08 22:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description genBTC 2024-03-05 21:51:22 UTC
New Release Packages have been available @
for some time now, Version 0.4.0 and version 0.5.0 are available.
Both add support for OpenSSL 3.0 so thats the rationale behind why we need it.

I have tested them locally, and they work, (with the exception I had to comment out a libressl patch in the 0.3.0.ebuild, that will have to be dealt with separately)

In addition, the existing 0.3.0 package pulls in dev-libs/libp11 - which has a blocker in its ebuild for openssl >=3.0.12+ so I have to file a 2nd bug for that to get that removed as well, because it does work on 3.0.12+ if there was some confusion. This one package was a blocker for all OpenSSL @world upgrades so it was keeping me on 3.0.11.

Reproducible: Always

Expected Results:  
Expect latest version of pam_p11 working with OpenSSL 3.0.12+ .