Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 926047 - app-text/lesspipe-2.13 installs bash completion in legacy location
Summary: app-text/lesspipe-2.13 installs bash completion in legacy location
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-03-02 20:39 UTC by Agostino Sarubbo
Modified: 2024-06-27 02:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,42.05 KB, text/plain)
2024-03-02 20:39 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2024-03-02 20:39:09 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-text/lesspipe-2.11-r1 installs bash completion in legacy location.
Discovered on: arm64 (internal ref: tinderbox_arm64)
System: GCC-14-SYSTEM (https://wiki.gentoo.org/wiki/Project:Tinderbox/Common_Issues_Helper#GCC-14)
Comment 1 Agostino Sarubbo gentoo-dev 2024-03-02 20:39:11 UTC
Created attachment 886551 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2024-04-15 07:27:33 UTC
ci has reproduced this issue with version 2.12 - Updating summary.
Comment 3 Agostino Sarubbo gentoo-dev 2024-06-02 09:57:38 UTC
ci has reproduced this issue with version 2.13 - Updating summary.
Comment 4 Larry the Git Cow gentoo-dev 2024-06-27 02:58:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c04518a1840f3481e2b21b7934204986a26b6beb

commit c04518a1840f3481e2b21b7934204986a26b6beb
Author:     Eli Schwartz <eschwartz93@gmail.com>
AuthorDate: 2024-06-26 17:01:17 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2024-06-27 02:57:32 +0000

    app-text/lesspipe: avoid a false positive bash-completion QA warning
    
    We leave an empty directory behind after moving the completion files
    around. Portage's QA check thinks that means we are actually using a
    legacy dynamic loader location??
    
     * QA Notice: Bash completions were installed in legacy location. Please update
     * the ebuild to get the install paths using bash-completion-r1.eclass.
    
    But the eclass doesn't support the eager-loader directory at all, and
    the QA notice isn't warning about it either -- the warning is simply
    because we have that empty directory (that gets cleaned up after the QA
    checks run, since keepdir isn't used).
    
    No revbump. It only affects an install-time warning and rmdir cannot
    change the resulting package contents.
    
    Closes: https://bugs.gentoo.org/926047
    Signed-off-by: Eli Schwartz <eschwartz93@gmail.com>
    Signed-off-by: Sam James <sam@gentoo.org>

 app-text/lesspipe/lesspipe-2.11-r1.ebuild | 1 +
 app-text/lesspipe/lesspipe-2.12.ebuild    | 1 +
 app-text/lesspipe/lesspipe-2.13.ebuild    | 1 +
 3 files changed, 3 insertions(+)