Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 92562 - libbonobo-2.8.1 failed looking for XML::Parser (even when emerged XML-Parser)
Summary: libbonobo-2.8.1 failed looking for XML::Parser (even when emerged XML-Parser)
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2005-05-13 23:24 UTC by Harlan H. Bloom
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Harlan H. Bloom 2005-05-13 23:24:40 UTC
I have reinstalled Gentoo Linux from source (2005.0 stage 1 - base install good and booting just fine); as part of this, I had to do an "emerge sync", all fine.  I tried to install packages from Package CD.  Some went ok.  Many packages didn't:  mozilla-firefox, k3b, arson, simplecdx, xine-ui,some others I can't remember right now).  They all failed saying they couldn't find XML::Parser.  I successfully emerged the XML-Parser from the Package CD.  Still no joy.  I did "emerge sync", tried to emerge the applications, same error.  I emerged XML-Parser, then I finally got libbonobo to emerge successully.  The applications are now building.

I recommend the ebuild file to libbonobo to include XML-Parser (including specific version).



Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. emerge dev-perl/XML-Parser
3. emerge gnome-base/libbonobo
4. emerge {applications}

Actual Results:  
Applications finally build correctly. 

Expected Results:  
emerge gnome-base/libbonobo should have found and included dev-perl/XML-Parser 

Hardware:  IBM Thinkpad T21 (2648), 100GB HD, 256 MB RAM, 800 MHz CPU 
OS:  Gentoo Linux 2005.0 stage 1 install, booting on it's own - no issues 
Any application that relied on libbonobo failed to compile when libbonobo 
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-05-13 23:40:15 UTC
No, you are supposed to run /usr/portage/dev-lang/perl/files/perl-cleaner which will fix your perl install to a sane state. Please search before filing bugs. Thanks.

*** This bug has been marked as a duplicate of 41124 ***