Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 923315 - sci-geosciences/gpsd-3.25 installs deprecated .egg/.egg-info
Summary: sci-geosciences/gpsd-3.25 installs deprecated .egg/.egg-info
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: 921639
  Show dependency tree
 
Reported: 2024-01-30 09:11 UTC by Agostino Sarubbo
Modified: 2024-06-02 00:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,152.72 KB, text/plain)
2024-01-30 09:11 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2024-01-30 09:11:07 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sci-geosciences/gpsd-3.25 installs deprecated .egg/.egg-info.
Discovered on: amd64 (internal ref: gcc14_tinderbox)
System: GCC-14-SYSTEM (https://wiki.gentoo.org/wiki/Project:Tinderbox/Common_Issues_Helper#GCC-14)

Info about the issue:
https://wiki.gentoo.org/wiki/Project:Tinderbox/Common_Issues_Helper#QA0076
Comment 1 Agostino Sarubbo gentoo-dev 2024-01-30 09:11:09 UTC
Created attachment 883690 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2024-06-02 00:52:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a0cad067d3e13f52f9ca54c37910d3fe2a0455ba

commit a0cad067d3e13f52f9ca54c37910d3fe2a0455ba
Author:     Kyle Elbert <kcelbert@gmail.com>
AuthorDate: 2024-05-31 12:15:32 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2024-06-02 00:47:35 +0000

    sci-geosciences/gpsd: 3.25-r1: many cleanups, python 3.12 bump
    
    Switched to PEP517 Build
    Python 3.12 bump
    Made sockets mandatory
    Corrected License
    Added missing BDEPEND DISTUTILS_DEPS
    Added missing PYTHON_USEDEP for pyserial
    Ensured python scripts were correctly wrapped
    
    Closes: https://bugs.gentoo.org/900891
    Closes: https://bugs.gentoo.org/910024
    Closes: https://bugs.gentoo.org/912732
    Closes: https://bugs.gentoo.org/929766
    Closes: https://bugs.gentoo.org/923315
    Signed-off-by: Kyle Elbert <kcelbert@gmail.com>
    Signed-off-by: Sam James <sam@gentoo.org>

 sci-geosciences/gpsd/gpsd-3.25-r1.ebuild | 240 +++++++++++++++++++++++++++++++
 1 file changed, 240 insertions(+)