Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 912692 - x11-misc/autorandr 1.14: udev rule broken for openrc users
Summary: x11-misc/autorandr 1.14: udev rule broken for openrc users
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Florian Schmaus
Depends on:
Reported: 2023-08-20 18:49 UTC by Alexander Weber
Modified: 2024-04-10 09:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Weber 2023-08-20 18:49:23 UTC
If x11-misc/autorandr-1.14 is installed, the udev rule refers to systemd service instead of autorandr call. 

cat /lib/udev/rules.d/40-monitor-hotplug.rules
ACTION=="change", SUBSYSTEM=="drm", RUN+="/bin/systemctl start --no-block autorandr.service"

Therefore autorandr is broken for openrc users in this version.

It seems the same issue is back like the second one in
Comment 1 Alexander Weber 2024-04-10 09:58:23 UTC
The issue is still not solved in x11-misc/autorandr-1.15

I thing the cause of comeback the issue is this change:
that was merged into 1.14