Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 912645 - media-gfx/inkscape-1.2.2[spell] fails to compile
Summary: media-gfx/inkscape-1.2.2[spell] fails to compile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
Depends on:
Reported: 2023-08-19 16:16 UTC by Carlos Konstanski
Modified: 2023-08-20 16:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build.log (build.log.tar.gz,84.67 KB, application/gzip)
2023-08-19 16:24 UTC, Carlos Konstanski
emerge --info (,11.28 KB, text/plain)
2023-08-19 16:25 UTC, Carlos Konstanski

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Konstanski 2023-08-19 16:16:51 UTC
The following error is thrown while compiling:

/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/ undefined reference to `g_assertion_message_cmpint'

Reproducible: Always
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-08-19 16:17:27 UTC
Please include the full build.log and emerge --info.
Comment 2 Carlos Konstanski 2023-08-19 16:24:21 UTC
Created attachment 868230 [details]

Gzipped because it was too big to upload in plaintext.
Comment 3 Carlos Konstanski 2023-08-19 16:25:22 UTC
Created attachment 868231 [details]
emerge --info
Comment 4 Carlos Konstanski 2023-08-19 17:36:58 UTC
I tried again with USE=-spell and it worked. Not a fix but a workaround.