Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 909012 - =mail-mta/exim-4.94.2-r7 - tls-openssl.c:230:5: error: missing binary operator before token "1"
Summary: =mail-mta/exim-4.94.2-r7 - tls-openssl.c:230:5: error: missing binary operato...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Fabian Groffen
Depends on: 909016
Blocks: openssl-3.0
  Show dependency tree
Reported: 2023-06-22 20:15 UTC by Bertrand Jacquin
Modified: 2023-11-08 07:53 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,5.40 KB, text/x-log)
2023-06-22 20:15 UTC, Bertrand Jacquin
emerge --info (info.log,19.37 KB, text/x-log)
2023-06-22 20:15 UTC, Bertrand Jacquin

Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Jacquin 2023-06-22 20:15:11 UTC

=mail-mta/exim-4.94.2-r7 fails to build with dev-libs/openssl:3 with the following error message:

x86_64-pc-linux-gnu-gcc -DMACRO_PREDEF tls.c
x86_64-pc-linux-gnu-gcc -c -march=native -O2 -pipe -fomit-frame-pointer -I/usr/include/db5.3 -DMACRO_PREDEF  -o macro-tls.o tls.c
In file included from sha_ver.h:38,
                 from hash.h:14,
                 from exim.h:530,
                 from tls.c:20:
tls-openssl.c:230:5: error: missing binary operator before token "1"
  230 | #if SSL_OP_NO_TLSv1_1 == 0x00000400L
      |     ^~~~~~~~~~~~~~~~~
make[1]: *** [Makefile:274: macro-tls.o] Error 1
make[1]: Leaving directory '/var/tmp/portage/mail-mta/exim-4.94.2-r7/work/exim-4.94.2/build-exim-gentoo'
make: *** [Makefile:35: all] Error 2
 * ERROR: mail-mta/exim-4.94.2-r7::gentoo failed (compile phase):
 *   emake failed

Please attached build log and emerge --info

Reproducible: Always
Comment 1 Bertrand Jacquin 2023-06-22 20:15:34 UTC
Created attachment 864429 [details]
Comment 2 Bertrand Jacquin 2023-06-22 20:15:59 UTC
Created attachment 864430 [details]
emerge --info
Comment 3 ascendant512+gentoo 2023-06-22 21:29:04 UTC
Got the same error with the same version of exim and dev-libs/openssl-3.0.9-r1:0/3::gentoo
Comment 4 ascendant512+gentoo 2023-06-22 23:02:05 UTC
Worked around by upgrading to mail-mta/exim-4.96-r4
Comment 5 Frank Mariën 2023-06-27 17:00:50 UTC
Confirm Bertrand's build error with mail-mta/exim-4.94.2-r7 and dev-libs/openssl-3.0.9-r1:0/3

Confirm ascendant512's successful workaround with mail-mta/exim-4.96-r4
Comment 6 Fabian Groffen gentoo-dev 2023-11-08 07:53:25 UTC
thanks, please update to 4.96-r4