Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 908832 - x11-apps/igt-gpu-tools-1.27.1 fails to compile (MUSL-SYSTEM): gem_engine_topology.c:619:33: error: unknown type name ino64_t
Summary: x11-apps/igt-gpu-tools-1.27.1 fails to compile (MUSL-SYSTEM): gem_engine_topo...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2023-06-19 07:18 UTC by Agostino Sarubbo
Modified: 2023-06-19 07:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,101.29 KB, text/plain)
2023-06-19 07:18 UTC, Agostino Sarubbo

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-06-19 07:18:15 UTC

Issue: x11-apps/igt-gpu-tools-1.27.1 fails to compile (MUSL-SYSTEM).
Discovered on: amd64 (internal ref: tinderbox_musl)

(MUSL-SYSTEM) in the summary means that bug was found on a machine that runs MUSL libc but this bug MAY or MAY NOT BE related to musl.
Comment 1 Agostino Sarubbo gentoo-dev 2023-06-19 07:18:17 UTC
Created attachment 864204 [details]

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-06-19 07:18:18 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:

FAILED: lib/libigt-i915_gem_engine_topology_c.a.p/i915_gem_engine_topology.c.o 
Message: WARNING: leg command not found, disabling overlay; try : apt-get install peg
Program xmlrpc-c-config found: NO
Run-time dependency cairo-xlib found: NO (tried pkgconfig and cmake)
Run-time dependency liboping found: NO (tried pkgconfig and cmake)
Run-time dependency xmlrpc found: NO (tried pkgconfig and cmake)
Run-time dependency xmlrpc_client found: NO (tried pkgconfig and cmake)
Run-time dependency xmlrpc_util found: NO (tried pkgconfig and cmake)
Run-time dependency xv found: NO (tried pkgconfig and cmake)
fatal: not a git repository (or any parent up to mount point /var/tmp)
../igt-gpu-tools-1.27.1/lib/i915/gem_engine_topology.c:619:33: error: unknown type name 'ino64_t'