Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 907440 - media-plugins/gst-plugins-oss-1.22.3 fails to compile with dev-lang/python-exec[-native-symlinks]
Summary: media-plugins/gst-plugins-oss-1.22.3 fails to compile with dev-lang/python-ex...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 762406
  Show dependency tree
 
Reported: 2023-05-30 20:17 UTC by Agostino Sarubbo
Modified: 2023-05-30 20:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,61.82 KB, text/plain)
2023-05-30 20:17 UTC, Agostino Sarubbo
Details
1-meson-log.txt (1-meson-log.txt,134.01 KB, text/plain)
2023-05-30 20:17 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-05-30 20:17:38 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: media-plugins/gst-plugins-oss-1.22.3 fails to compile with dev-lang/python-exec[-native-symlinks].
Discovered on: amd64 (internal ref: ci)

NOTE:
Please take a look at the tracker bug for more info.
Comment 1 Agostino Sarubbo gentoo-dev 2023-05-30 20:17:41 UTC
Created attachment 862924 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-05-30 20:17:42 UTC
Created attachment 862925 [details]
1-meson-log.txt

1-meson-log.txt
Comment 3 Agostino Sarubbo gentoo-dev 2023-05-30 20:17:43 UTC
Error(s) that match a know pattern:


Dependency libsoup-2.4 from subproject libsoup found: NO (subproject failed to configure)
Dependency libsoup-3.0 from subproject libsoup3 found: NO (subproject failed to configure)
../gst-plugins-good-1.22.3/meson.build:511:15: ERROR: Command `/var/tmp/portage/media-plugins/gst-plugins-oss-1.22.3/work/gst-plugins-good-1.22.3/scripts/extract-release-date-from-doap-file.py 1.22.3 /var/tmp/portage/media-plugins/gst-plugins-oss-1.22.3/work/gst-plugins-good-1.22.3/gst-plugins-good.doap` failed with status 127.
Message: Hotdoc not found, not building the documentation
Message: Orc Compiler not found, will use backup C code
Program hotdoc found: NO
Program moc-qt5 moc found: NO
qmake found: NO need ['>= 5', '< 6']
qmake found: NO need ['>= 6', '< 7']
Run-time dependency gudev-1.0 found: NO (tried pkgconfig and cmake)
Run-time dependency libsoup-2.4 found: NO (tried pkgconfig and cmake)
Run-time dependency libsoup-3.0 found: NO (tried pkgconfig and cmake)
Run-time dependency libv4l2 found: NO (tried pkgconfig and cmake)
Run-time dependency qt5 (modules: Core, Gui, Qml, Quick) found: NO (tried pkgconfig and config-tool)
Run-time dependency qt6 (modules: Core) found: NO (tried pkgconfig and config-tool)
Run-time dependency valgrind found: NO (tried pkgconfig)
Run-time dependency xdamage found: NO (tried pkgconfig and cmake)