Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 906651 - dev-lang/elixir-1.14.3 invalid dependency
Summary: dev-lang/elixir-1.14.3 invalid dependency
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Haelwenn (lanodan) Monnier
URL: https://hexdocs.pm/elixir/1.14/compat...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-05-17 21:33 UTC by tomas charvat
Modified: 2023-05-20 14:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomas charvat 2023-05-17 21:33:27 UTC
According to URL elixie 1.14 support Erlang23-25, following limitation is not needed

>=dev-lang/erlang-23:0/25.1.2=[ssl] required by (dev-lang/elixir-1.14.3:0/0::gentoo, installed)

This report is related to https://bugs.gentoo.org/show_bug.cgi?id=906650
Elixir is pulled in by rabbitmq and they both depend on old erlang.

Reproducible: Always
Comment 1 tomas charvat 2023-05-17 21:35:27 UTC
This may be solved by dev-lang/elixir-1.14.4 version bump 
https://github.com/elixir-lang/elixir/blob/v1.14.4/CHANGELOG.md
Comment 2 Haelwenn (lanodan) Monnier 2023-05-20 14:00:36 UTC
Did you misread?
It's just `>=dev-lang/erlang-23:0=[ssl]` in the recipe, meaning 24.x and 25.x are fine (in fact 25.x is what I run on my machines), it just needs a rebuild not a recipe change.