Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 90081 - dev-dotnet/libgdiplus-1.1.5 failed. cairo problem.
Summary: dev-dotnet/libgdiplus-1.1.5 failed. cairo problem.
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-22 15:35 UTC by Gregg
Modified: 2005-04-23 08:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,34.83 KB, text/plain)
2005-04-22 15:37 UTC, Gregg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gregg 2005-04-22 15:35:32 UTC
configure:19913: error: "Did not find Cairo == 0.3.0"

I dont have 0.3.0 installed.  I have 0.4.0 installed.  They are all masked of course.  Cairo 0.4.0 and libgdiplus1.1.5.

I was attempting to install mono-1.1.6 to test.  It required the cairo and libgdiplus upgrades.



Reproducible: Always
Steps to Reproduce:
1. Emerge cairo 0.4.0
2. Try to emerge libgdiplus 1.1.5
3. Error message

Actual Results:  
The error messages 

Expected Results:  
libgdiplus should have installed and mono after it. 

 configure:19913: error: "Did not find Cairo == 0.3.0" 
 
Is what happened.  config.log will be attached.
Comment 1 Gregg 2005-04-22 15:37:29 UTC
Created attachment 56952 [details]
config.log

The ebuild told me to attach this file.
Comment 2 Peter Johanson (RETIRED) gentoo-dev 2005-04-23 08:50:24 UTC
libgdiplus does *not* work with 0.4.0 version of cairo. Pretty much every cairo release changes the API drastically. Please downgrade to cairo-0.3.0 if you want to use libgdiplus.

Marking CANTFIX, upstream is working on trying to get libgdiplus working against 0.4.0, until then we're stuck with 0.3.0. Thanks.

(feel free to re-open if libgdiplus doesn't work against cairo-0.3.0)