Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 895516 - dev-qt/qtlocation-5.15.8 fails to compile (MUSL-CLANG-SYSTEM): integral_wrapper.hpp:73:31: error: integer value -1 is outside the valid range of values [0, 3] for this enumeration type [-Wenum-constexpr-conversion]
Summary: dev-qt/qtlocation-5.15.8 fails to compile (MUSL-CLANG-SYSTEM): integral_wrapp...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Qt Bug Alias
Keywords: PATCH
: 913205 926743 (view as bug list)
Depends on:
Reported: 2023-02-20 08:21 UTC by Agostino Sarubbo
Modified: 2024-05-09 21:09 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,552.37 KB, text/plain)
2023-02-20 08:21 UTC, Agostino Sarubbo
Patch to fix integer value compile errors (qtlocation-bundled-boost-1.65.1-clang.patch,4.63 KB, patch)
2023-11-19 08:09 UTC, Roman Zimmermann
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-02-20 08:21:27 UTC

Issue: dev-qt/qtlocation-5.15.8 fails to compile (MUSL-CLANG-SYSTEM).
Discovered on: amd64 (internal ref: tinderbox_musl)

(MUSL-CLANG-SYSTEM) in the summary means that bug was found on a machine that runs MUSL libc + clang16 but this bug MAY or MAY NOT BE related to musl/clang16.
Comment 1 Agostino Sarubbo gentoo-dev 2023-02-20 08:21:30 UTC
Created attachment 853172 [details]

build log and emerge --info
Comment 2 Arniii 2023-09-20 07:15:04 UTC
got the same error at glibc-clang profile.
Comment 3 Arniii 2023-09-20 07:16:31 UTC
at version 5.15.10
Comment 4 Anna Vyalkova 2023-10-13 07:09:20 UTC
Still fails here (v5.15.11, Clang 16, glibc)
Comment 5 Roman Zimmermann 2023-11-19 08:09:35 UTC
Created attachment 875168 [details, diff]
Patch to fix integer value compile errors

I have found that applying this patch ( to the boost-1.65.1 instance in the checked out mapbox-gl version fixes the issue. I found this being referenced by which seemed to have the same error I observe.

Iā€™m attaching a patch that can be used in /etc/portage/patches for convenience.
Comment 6 Andreas Sturmlechner gentoo-dev 2023-12-26 09:23:22 UTC
*** Bug 913205 has been marked as a duplicate of this bug. ***
Comment 7 Scott Furry 2024-02-13 08:36:50 UTC
Problem persists with:

I had previously encountered this issue with LLVM-16 and filed a bug w/ QT. See This seems to be an upstream issue between Qt and Boost.
Comment 8 Andreas Sturmlechner gentoo-dev 2024-03-11 09:49:29 UTC
*** Bug 926743 has been marked as a duplicate of this bug. ***