Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 893628 - app-admin/entr-5.3 fails tests: FAIL: spacebar triggers utility
Summary: app-admin/entr-5.3 fails tests: FAIL: spacebar triggers utility
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Petr Vaněk
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2023-02-08 18:45 UTC by Agostino Sarubbo
Modified: 2023-02-15 09:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,43.04 KB, text/plain)
2023-02-08 18:45 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-02-08 18:45:54 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-admin/entr-5.3 fails tests.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2023-02-08 18:45:56 UTC
Created attachment 850192 [details]
build.log

build log and emerge --info
Comment 2 Petr Vaněk 2023-02-12 16:53:31 UTC
This is a bug I have encountered while I was bumping entr-5.3.ebuild. I thought the issue was solved by exporting SHELL=/bin/bash in the ebuild, but it is probably not enough. The issue is in tmux related tests. In my case the tests do not pass when the tmux server runs /bin/zsh because it tries to interpret input in different way than bash.

Is it possible that there is an open tmux session for portage user with different shell than bash in your case? Because I am able to reproduce this issue only if I open tmux in one terminal:

   $ sudo -u portage env SHELL=/bin/zsh tmux

and run the package test in other terminal.

If this is the case, the issue will be solved by exporting TMUX_TMPDIR="${T}" in the ebuild in order to avoid interferences between tmux sessions.
Comment 3 Agostino Sarubbo gentoo-dev 2023-02-14 09:13:27 UTC
tinderbox runs under tmux but with bash

To reproduce you may try to launch emerge from tmux
Comment 4 Larry the Git Cow gentoo-dev 2023-02-15 08:31:53 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=23873c94cd4a4e55527136a26696c53dee787d8c

commit 23873c94cd4a4e55527136a26696c53dee787d8c
Author:     Petr Vaněk <arkamar@atlas.cz>
AuthorDate: 2023-02-12 17:21:13 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2023-02-15 08:31:28 +0000

    app-admin/entr: fix prepare and test phases issues
    
    - Use correct name of PATCHES array in order to apply patch
    - Fix issue with interfering tmux sessions in test phase by exporting
      TMUX_TMPDIR="${T}"
    
    Fixes: 8a7dc41ca137 ("app-admin/entr: add 5.3")
    Closes: https://bugs.gentoo.org/893628
    Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
    Closes: https://github.com/gentoo/gentoo/pull/29577
    Signed-off-by: Sam James <sam@gentoo.org>

 app-admin/entr/{entr-5.3.ebuild => entr-5.3-r1.ebuild} | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)