Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 892732 - dev-util/roctracer-6.1.1 adds -Werror flag on its own
Summary: dev-util/roctracer-6.1.1 adds -Werror flag on its own
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: werror
  Show dependency tree
 
Reported: 2023-01-31 14:28 UTC by Agostino Sarubbo
Modified: 2024-06-27 01:25 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,87.60 KB, text/plain)
2023-01-31 14:28 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-01-31 14:28:10 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-util/roctracer-5.3.3 adds -Werror flag on its own.
Discovered on: amd64 (internal ref: ci)

NOTE:
-Werror is not recommended for releases and should always be disabled when encountered in build-logs, because there are numerous cases where this breaks without purpose.
See also: https://devmanual.gentoo.org/ebuild-writing/common-mistakes/index.html.
Comment 1 Agostino Sarubbo gentoo-dev 2023-01-31 14:28:13 UTC
Created attachment 849560 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2024-06-26 12:02:02 UTC
ci has reproduced this issue with version 6.1.1 - Updating summary.
Comment 3 Larry the Git Cow gentoo-dev 2024-06-27 01:25:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8c5386403a9a166230b29924b19568d5140ca9be

commit 8c5386403a9a166230b29924b19568d5140ca9be
Author:     Sv. Lockal <lockalsash@gmail.com>
AuthorDate: 2024-06-26 13:09:22 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2024-06-27 01:24:13 +0000

    dev-util/roctracer: bugfixes for 6.1.1
    
    * specify python executable for cmake, otherwise it uses latest
    * remove -Werror from hardcoded flags
    * enable py3.13
    
    Closes: https://bugs.gentoo.org/934969
    Closes: https://bugs.gentoo.org/892732
    Signed-off-by: Sv. Lockal <lockalsash@gmail.com>
    Closes: https://github.com/gentoo/gentoo/pull/37310
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-util/roctracer/roctracer-6.1.1.ebuild | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)