Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 892023 - sys-cluster/pmix-5.0.2 adds -Werror flag on its own (USR-MERGE-SYSTEM)
Summary: sys-cluster/pmix-5.0.2 adds -Werror flag on its own (USR-MERGE-SYSTEM)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Cluster Team
URL:
Whiteboard:
Keywords:
: 906972 (view as bug list)
Depends on:
Blocks: werror
  Show dependency tree
 
Reported: 2023-01-25 18:57 UTC by Agostino Sarubbo
Modified: 2024-07-03 21:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,568.62 KB, text/plain)
2023-01-25 18:57 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2023-01-25 18:57:50 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sys-cluster/pmix-4.2.2-r1 adds -Werror flag on its own (USR-MERGE-SYSTEM).
Discovered on: amd64 (internal ref: usr-merge_tinderbox)

NOTE:
(USR-MERGE-SYSTEM) in the summary means that the bug was found on a machine that runs default/linux/amd64/17.1/systemd/merged-usr profile but this bug MAY or MAY NOT BE related to the new profile.
-Werror is not recommended for releases and should always be disabled when encountered in build-logs, because there are numerous cases where this breaks without purpose.
See also: https://devmanual.gentoo.org/ebuild-writing/common-mistakes/index.html.
Comment 1 Agostino Sarubbo gentoo-dev 2023-01-25 18:57:52 UTC
Created attachment 849197 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-01-25 18:58:09 UTC
Different than 884883
Comment 3 Agostino Sarubbo gentoo-dev 2024-06-14 08:37:25 UTC
ci has reproduced this issue with version 5.0.2 - Updating summary.
Comment 4 Eli Schwartz gentoo-dev 2024-07-01 01:50:06 UTC
*** Bug 906972 has been marked as a duplicate of this bug. ***
Comment 5 Larry the Git Cow gentoo-dev 2024-07-03 21:25:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3cb521ed1eda151aaf605d6da3fc49b128816ccc

commit 3cb521ed1eda151aaf605d6da3fc49b128816ccc
Author:     Eli Schwartz <eschwartz93@gmail.com>
AuthorDate: 2024-07-01 00:31:16 +0000
Commit:     Eli Schwartz <eschwartz@gentoo.org>
CommitDate: 2024-07-03 21:24:57 +0000

    sys-cluster/pmix: stop enabling -Werror via ./configure
    
    The aptly-named --enable-werror flag provided by upstream will carefully
    enable -Werror in CI builds, even if you pass --disable-werror or
    --enable-werror=no. This excellent diagnostics pass brought to you by
    the world's most intuitive string validation and checking library, GNU
    autoconf.
    
    It is unclear to me why "sys-cluster/pmix: add 4.2.2" entailed adding
    this configure option. The option was new in that version bump but
    refraining from passing the option would do the correct thing...
    
    Fixes: 8ad34c5cb767676d6cb5e9249565d2e4c17d838e
    Bug: https://bugs.gentoo.org/906972
    Bug: https://bugs.gentoo.org/908551
    Closes: https://bugs.gentoo.org/892023
    Signed-off-by: Eli Schwartz <eschwartz93@gmail.com>
    Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>

 sys-cluster/pmix/pmix-4.2.2-r1.ebuild | 3 +--
 sys-cluster/pmix/pmix-4.2.8.ebuild    | 1 -
 sys-cluster/pmix/pmix-5.0.2.ebuild    | 1 -
 3 files changed, 1 insertion(+), 4 deletions(-)