Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88970 - openvrml does not build
Summary: openvrml does not build
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo TreeCleaner Project
URL:
Whiteboard: REMOVED
Keywords:
: 95781 132982 (view as bug list)
Depends on:
Blocks: 137775
  Show dependency tree
 
Reported: 2005-04-13 08:35 UTC by Christopher G. Stach II
Modified: 2007-11-04 12:35 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to compile openvrml-0.14.3 with gcc-3.4.6 (openvrml-0.14.3-name.patch,87.38 KB, patch)
2006-05-11 02:45 UTC, Honza Macháček
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher G. Stach II 2005-04-13 08:35:08 UTC
/bin/sh ../../../libtool --mode=compile c++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../lib      -O3 -march=pentium3 -funroll-loops -fforce-addr -pipe -c VrmlNodeScript.cpp
rm -f .libs/VrmlNodeScript.lo
c++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../lib -O3 -march=pentium3 -funroll-loops -fforce-addr -pipe -c VrmlNodeScript.cpp  -fPIC -DPIC -o .libs/VrmlNodeScript.lo
VrmlNodeScript.cpp:36:26: strstream.h: No such file or directory
In file included from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/include/g++-v3/backward/iostream.h:31,
                 from field.h:25,
                 from vrml97node.h:27,
                 from VrmlNodeScript.h:30,
                 from VrmlNodeScript.cpp:38:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/include/g++-v3/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <sstream> instead of the deprecated header <strstream.h>. To disable this warning use -Wno-deprecated.
make[4]: *** [VrmlNodeScript.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2/src/openvrml/OpenVRML'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2/src/openvrml'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2'
make: *** [all-recursive-am] Error 2

!!! ERROR: media-libs/openvrml-0.11.2 failed.
!!! Function src_compile, Line 35, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


# emerge info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r5 i686)
=================================================================
System uname: 2.6.11-gentoo-r5 i686 Intel(R) Pentium(R) III CPU family      1400MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Apr  7 2005, 17:19:29)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.8.5-r3, 1.5, 1.7.9-r1, 1.6.3, 1.4_p6, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium3 -funroll-loops -fforce-addr -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -funroll-loops -fforce-addr -pipe"
DISTDIR="/com/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks fixpackages notitles sandbox sfperms userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://gentoo.netnitco.net ftp://gentoo.mirrors.tds.net/gentoo"
MAKEOPTS="-j3"
PKGDIR="/com/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/com/portage/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X Xaw3d aalib acl acpi aim alsa apache2 apm berkdb bitmap-fonts bzlib cjk cluster crypt cscope cups curl emboss encode esd ethereal exif fam foomaticdb fortran gd gdbm geometry gif gmp gnome gnutls gstreamer gtk gtk2 gtkhtml icq imagemagick imap imlib innodb ipv6 jabber java jce jikes jpeg junit kerberos ldap libg++ libwww maildir mbox mime mmap mmx motif mozilla mp3 mpi msn mysql ncurses nls nptl nptlonly offensive opengl oscar pam pcre pdflib perl plotutils png python readline samba sasl sharedmem snmp spell sse ssl tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode usb utf8 xml2 xv yahoo zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2005-05-15 05:20:31 UTC
what about openvrml-0.14.3 or openvrml-0.15.7?
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-06-11 08:42:10 UTC
*** Bug 95781 has been marked as a duplicate of this bug. ***
Comment 3 MAL 2005-12-08 02:53:40 UTC
openvrml-0.14.3

 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../lib/antlr -I../../../java -I
../../../src/libopenvrml -DOPENVRML_LIBDIR_=\"/usr/lib\" -
DOPENVRML_PKGDATADIR_=\"/usr/share/openvrml\" -I/usr/include/freetype2 -I/opt/
blackdown-jdk-1.4.2.02/include -I/opt/blackdown-jdk-1.4.2.02/include/linux -
march=athlon-xp -mtune=athlon-xp -O2 -fomit-frame-pointer -pipe -MT ScriptJDK.lo 
-MD -MP -MF .deps/ScriptJDK.Tpo -c ScriptJDK.cpp  -fPIC -DPIC -o .libs/
ScriptJDK.o
In file included from /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3/
backward/strstream:51,
                 from ScriptJDK.cpp:39:
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3/backward/backward_warning.h:
32:2: warning: #warning This file includes at least one deprecated or antiquated 
header. Please consider using one of the 32 headers found in section 17.4.1.2 of 
the C++ standard. Examples include substituting the <X> header for the <X.h> 
header for C++ includes, or <iostream> instead of the deprecated header 
<iostream.h>. To disable this warning use -Wno-deprecated.
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFBool_CreateObject(JNIEnv*, _jobject*, jboolean)':
ScriptJDK.cpp:623: error: `sfbool' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFColor_CreateObject(JNIEnv*, _jobject*, jfloat, jfloat, 
jfloat)':
ScriptJDK.cpp:766: error: `sfcolor' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFFloat_CreateObject(JNIEnv*, _jobject*, jfloat)':
ScriptJDK.cpp:1013: error: `sffloat' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFInt32_CreateObject(JNIEnv*, _jobject*, jint)':
ScriptJDK.cpp:1407: error: `sfint32' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFRotation_CreateObject(JNIEnv*, _jobject*, jfloat, jfloat, 
jfloat, jfloat)':
ScriptJDK.cpp:1697: error: `sfrotation' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFTime_CreateObject(JNIEnv*, _jobject*, jdouble)':
ScriptJDK.cpp:1969: error: `sftime' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFVec2f_CreateObject(JNIEnv*, _jobject*, jfloat, jfloat)':
ScriptJDK.cpp:2075: error: `sfvec2f' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstSFVec3f_CreateObject(JNIEnv*, _jobject*, jfloat, jfloat, 
jfloat)':
ScriptJDK.cpp:2253: error: `sfvec3f' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFColor_CreateObject___3_3F(JNIEnv*, _jobject*, 
_jobjectArray*)':
ScriptJDK.cpp:2458: error: `mfcolor' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFColor_CreateObject__I_3F(JNIEnv*, _jobject*, jint, 
_jfloatArray*)':
ScriptJDK.cpp:2481: error: `mfcolor' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFFloat_CreateObject(JNIEnv*, _jobject*, jint, 
_jfloatArray*)':
ScriptJDK.cpp:3032: error: `mffloat' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFNode_CreateObject(JNIEnv*, _jobject*, jint, 
_jobjectArray*)':
ScriptJDK.cpp:3752: error: `mfnode' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFRotation_CreateObject___3_3F(JNIEnv*, _jobject*, 
_jobjectArray*)':
ScriptJDK.cpp:4158: error: `mfrotation' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFRotation_CreateObject__I_3F(JNIEnv*, _jobject*, jint, 
_jfloatArray*)':
ScriptJDK.cpp:4183: error: `mfrotation' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFString_CreateObject(JNIEnv*, _jobject*, jint, 
_jobjectArray*)':
ScriptJDK.cpp:4680: error: `mfstring' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFTime_CreateObject(JNIEnv*, _jobject*, jint, 
_jdoubleArray*)':
ScriptJDK.cpp:5079: error: `mftime' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFVec2f_CreateObject___3_3F(JNIEnv*, _jobject*, 
_jobjectArray*)':
ScriptJDK.cpp:5475: error: `mfvec2f' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFVec2f_CreateObject__I_3F(JNIEnv*, _jobject*, jint, 
_jfloatArray*)':
ScriptJDK.cpp:5498: error: `mfvec2f' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFVec3f_CreateObject___3_3F(JNIEnv*, _jobject*, 
_jobjectArray*)':
ScriptJDK.cpp:6026: error: `mfvec3f' is not a type
ScriptJDK.cpp: In function `void 
Java_vrml_field_ConstMFVec3f_CreateObject__I_3F(JNIEnv*, _jobject*, jint, 
_jfloatArray*)':
ScriptJDK.cpp:6049: error: `mfvec3f' is not a type
make[4]: *** [ScriptJDK.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.
3/src/libopenvrml/openvrml'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.
3/src/libopenvrml'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.
3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.
3'
make: *** [all] Error 2


This is rebuilding it after an upgrade to gcc 3.4
Comment 4 Heinrich Wendel (RETIRED) gentoo-dev 2006-02-20 00:37:30 UTC
not fixed
Comment 5 Marco Calviani 2006-03-14 03:17:39 UTC
Hi list,
   trying to build the stable version  openvrml-0.11.2

rmlNodeScript.cpp:36:26: strstream.h: No such file or directory
In file included from /usr/lib/gcc/i686-pc-linux-gnu/3.4.5/include/g++-v3/backward/iostream.h:31,
                 from field.h:25,
                 from vrml97node.h:27,
                 from VrmlNodeScript.h:30,
                 from VrmlNodeScript.cpp:38:
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/include/g++-v3/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated                                                or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the                                                <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-dep                                               recated.
make[4]: *** [VrmlNodeScript.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2/src/openvrml/OpenVRML'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2/src/openvrml'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/openvrml-0.11.2/work/openvrml-0.11.2'
make: *** [all-recursive-am] Error 2


Regards,
MC
Comment 6 Jeffrey Gardner (RETIRED) gentoo-dev 2006-04-04 23:41:35 UTC
Same errror here:

 g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../../lib/antlr -I../../../java -I../../../sr                                                   c/libopenvrml -DOPENVRML_LIBDIR_=\"/usr/lib\" -DOPENVRML_PKGDATADIR_=\"/usr/share/openvrml                                                   \" -I/usr/include/freetype2 -I/opt/blackdown-jdk-1.4.2.03/include -I/opt/blackdown-jdk-1.4                                                   .2.03/include/linux -march=opteron -mtune=opteron -fomit-frame-pointer -Os -pipe -MT Scrip                                                   tJDK.lo -MD -MP -MF .deps/ScriptJDK.Tpo -c ScriptJDK.cpp  -fPIC -DPIC -o .libs/ScriptJDK.o
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/include/g++-v3/backward/strst                                                   ream:51,
                 from ScriptJDK.cpp:39:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/include/g++-v3/backward/backward_warning.h:32:2: wa                                                   rning: #warning This file includes at least one deprecated or antiquated header. Please co                                                   nsider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples                                                    include substituting the <X> header for the <X.h> header for C++ includes, or <iostream>                                                    instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated                                                   .
ScriptJDK.cpp: In constructor `openvrml::ScriptJDK::ScriptJDK(openvrml::script_node&, cons                                                   t char*, const char*)':
ScriptJDK.cpp:260: error: reinterpret_cast from `openvrml::script_node*' to `int' loses pr                                                   ecision
ScriptJDK.cpp: In member function `void openvrml::ScriptJDK::activate(double, const std::s                                                   tring&, size_t, const openvrml::field_value* const*)':
ScriptJDK.cpp:471: error: reinterpret_cast from `<unnamed>::VrmlEvent*' to `int' loses pre                                                   cision
ScriptJDK.cpp: In function `_jobject* Java_vrml_Field_clone(JNIEnv*, _jobject*)':
ScriptJDK.cpp:584: error: reinterpret_cast from `openvrml::field_value*' to `int' loses pr                                                   ecision
ScriptJDK.cpp: In function `void Java_vrml_field_ConstSFBool_CreateObject(JNIEnv*, _jobjec                                                   t*, jboolean)':
ScriptJDK.cpp:623: error: `sfbool' is not a type
ScriptJDK.cpp:624: error: reinterpret_cast from `openvrml::sfbool*' to `int' loses precisi                                                   on
ScriptJDK.cpp: In function `void Java_vrml_field_ConstSFColor_CreateObject(JNIEnv*, _jobje                                                   ct*, jfloat, jfloat, jfloat)':
ScriptJDK.cpp:766: error: `sfcolor' is not a type
ScriptJDK.cpp:767: error: reinterpret_cast from `openvrml::sfcolor*' to `int' loses precis                                                   ion
ScriptJDK.cpp: In function `void Java_vrml_field_ConstSFFloat_CreateObject(JNIEnv*, _jobje     
..............
.............
..............
ScriptJDK.cpp:6852: error: reinterpret_cast from `openvrml::browser*' to `int' loses preci                                                   sion
ScriptJDK.cpp: In function `_jobject* Java_vrml_Event_getValue(JNIEnv*, _jobject*)':
ScriptJDK.cpp:7055: error: reinterpret_cast from `const openvrml::field_value*' to `int' l                                                   oses precision
ScriptJDK.cpp: In function `_jobject* Java_vrml_Event_clone(JNIEnv*, _jobject*)':
ScriptJDK.cpp:7078: error: reinterpret_cast from `<unnamed>::VrmlEvent*' to `int' loses pr                                                   ecision
make[4]: *** [ScriptJDK.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.3/src/libo                                                   penvrml/openvrml'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.3/src/libo                                                   penvrml'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/openvrml-0.14.3/work/openvrml-0.14.3'
make: *** [all] Error 2




# emerge info
Portage 2.0.54 (default-linux/amd64/2006.0, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.15-gentoo-r7 x86_64 AMD Opteron(tm) Processor 246
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -mtune=opteron -fomit-frame-pointer -Os -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /var     /qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=opteron -mtune=opteron -fomit-frame-pointer -Os -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.cites.uiuc.edu/pub/gentoo http://mirrors.tds.net/gentoo ftp://gentoo.ccccom.com http://www.ibiblio.org/pub/Linu     x/distributions/gentoo http://gentoo.osuosl.org"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="amd64 3xnowex X a52 aac aalib acpi alsa apache2 apbs audiofile avi bash-completion berkdb bitmap-fonts browserplugin bzip2 cairo canvas      cdr cli cmkopt crypt ctype cups curl dba dga directfb divx4linux dri dts dvd dvdr dvdread effects emboss encode esd exif expat extensions f77      fam fastbuild fbcon ffmpeg fftw flac foomaticdb force-cgi-redirect fortran ftp gb gd gif glut gnutls gpm gtk gtk2 gtkhtml h323 hdf i8x0 imag     emagick imlib inkjar insecure-savers isdnlog ithreads java jce jpeg jpg junit kqemu lcms lesstif libgda lirc live logitech-mouse logrotate lz     w lzw-tiff maildir matroska memlimit mikmod mjpeg mng mopac7 motif mozcalendar mozilla moznocompose moznoirc moznomail mozsvg mp3 mpeg mpi mp     qc mythtv ncurses netcdf network nls no_wxgtk1 nptl nsplugin nvidia offensive ogg oggvorbis openbabel opengl pam pcre pdflib perl plotutils p     lugin png pnp pop posix ppds pppd pymol python quicktime readline rtc sasl sdl session simplexml smp soap sockets spell spl ssl startup-notif     ication svg tcltk tcpd tetex threads tiff tokenizer toolbar truetype truetype-fonts type1-fonts udev usb v4l v4l2 vorbis wmf xchattext xinetd      xml xml2 xpm xprint xscreensaver xsl xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-05-11 00:51:32 UTC
*** Bug 132982 has been marked as a duplicate of this bug. ***
Comment 8 Honza Macháček 2006-05-11 02:45:44 UTC
Created attachment 86599 [details, diff]
Patch to compile openvrml-0.14.3 with gcc-3.4.6

Resolves bug 132982 for me. Since I don't recognize the error messages reported here, I'm not sure if my patch helps this case too. I at least have openvrml-0.14.3 compiled now, although I'm not sure the build actually works.
Comment 9 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-06-29 14:47:19 UTC
If someone can try to compile this with the patch and gcc-4.1, I don't want to patch it for gcc-3.4.X only to have it break in a month or so with gcc-4.1

If we can get both birds with one stone here I'm willing to put in the time on it, otherwise it will leave the tree unless you can find it a maintainer.
Comment 10 Honza Macháček 2006-06-29 20:37:33 UTC
(In reply to comment #9)
> If someone can try to compile this with the patch and gcc-4.1, I don't want to
> patch it for gcc-3.4.X only to have it break in a month or so with gcc-4.1

Since new version is available -- see bug 92690 --, I've gone on to the newest version (0.15.10). Lately I compiled that with gcc 4.1.1 on my x86 notebook; the compilation only was somewhat memory-hungry, started swapping, and consequently went slow as hell, but at the end it was successful.

Now I tried to compile openvrml-0.15.10 on my amd64 box, and failed with multiple ``cast to 'int' loses precission'' errors in ScriptJDK.cpp; in the next few days or weeks I won't be able to pay time to patching attempts.

After being notified of bug 137775 (openvrml being a candidate for removal) I checked openvrml web pages http://www.openvrml.org/ Having found that the latest version mentioned there is still the one year old 0.15.9, while its Sourceforge download page http://sourceforge.net/project/showfiles.php?group_id=7151&package_id=7260 offers about one month younger 0.15.10, I've decided to give up on openvrml and accept its removal. If you are interested in taking care of its ebuild, I would recomend to consult the openvrml developers, whether they themselves have not given up their effort.