Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 887047 - sys-apps/systemd[gnuefi] sys-apps/systemd-utils[boot] fails to compile with llvm-objcopy (CLANG-STRICTER-SYSTEM): error: unknown argument --section-alignment=512
Summary: sys-apps/systemd[gnuefi] sys-apps/systemd-utils[boot] fails to compile with l...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo systemd Team
: 905087 (view as bug list)
Depends on:
Reported: 2022-12-18 19:33 UTC by Agostino Sarubbo
Modified: 2023-04-25 20:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,173.91 KB, text/plain)
2022-12-18 19:33 UTC, Agostino Sarubbo

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2022-12-18 19:33:29 UTC

Issue: sys-apps/systemd-utils-251.9 fails to compile (CLANG-STRICTER-SYSTEM).
Discovered on: amd64 (internal ref: clang-stricter_tinderbox)

(CLANG-STRICTER-SYSTEM) in the summary means that the bug was found on a machine that runs clang with stricter mode

This machine uses clang with CFLAGS/CXXFLAGS=-Werror=implicit-function-declaration -Werror=implicit-int -Werror=incompatible-function-pointer-types

See also:
Comment 1 Agostino Sarubbo gentoo-dev 2022-12-18 19:33:31 UTC
Created attachment 843521 [details]

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2022-12-18 19:33:32 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:

FAILED: src/boot/efi/linuxx64.efi.stub 
Program jekyll found: NO
Program kexec /usr/sbin/kexec /sbin/kexec found: NO
Program quotacheck /usr/sbin/quotacheck /sbin/quotacheck found: NO
Program quotaon /usr/sbin/quotaon /sbin/quotaon found: NO
Program rpm found: NO
Program rpmspec found: NO
Run-time dependency libbpf found: NO (tried pkgconfig and cmake)
Run-time dependency tss2-esys tss2-rc tss2-mu found: NO (tried pkgconfig and cmake)
/usr/lib/llvm/15/bin/x86_64-pc-linux-gnu-objcopy: error: unknown argument '--section-alignment=512'
Comment 3 Mike Gilbert gentoo-dev 2022-12-20 18:26:02 UTC
I think we need objcopy from binutils, not llvm-objcopy.
Comment 4 Mike Gilbert gentoo-dev 2023-04-25 20:38:48 UTC
*** Bug 905087 has been marked as a duplicate of this bug. ***
Comment 5 Mike Gilbert gentoo-dev 2023-04-25 20:45:56 UTC
This should be fixed with the next upstream release of systemd. It no longer uses gnuefi/objcopy.