Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 886155 - =sci-libs/vtk-9.2.2 ninja: error: '/usr/lib64/', needed by 'lib64/', missing and no known rule to make it
Summary: =sci-libs/vtk-9.2.2 ninja: error: '/usr/lib64/', needed by 'lib64/...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
Depends on:
Reported: 2022-12-15 19:07 UTC by Petross404(Petros S)
Modified: 2023-06-09 00:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

sci-libs:vtk-9.2.2:20221215-203427.log (sci-libs:vtk-9.2.2:20221215-203427.log,19.63 KB, text/plain)
2022-12-15 19:07 UTC, Petross404(Petros S)
emerge --info '=sci-libs/vtk-9.2.2::gentoo' (emerge--info.txt,28.01 KB, text/plain)
2022-12-15 19:09 UTC, Petross404(Petros S)

Note You need to log in before you can comment on or make changes to this bug.
Description Petross404(Petros S) 2022-12-15 19:07:06 UTC
Created attachment 842903 [details]


Portage tried to emerge sci-libs/vtk-9.2.2 and then stopped with this error:

-- Configuring done
-- Generating done
-- Build files have been written to: /mnt/Volume_3/Gentoo/temp/portage/sci-libs/vtk-9.2.2/work/VTK-9.2.2_build
>>> Source configured.
>>> Compiling source in /mnt/Volume_3/Gentoo/temp/portage/sci-libs/vtk-9.2.2/work/VTK-9.2.2 ...
 * Source directory (CMAKE_USE_DIR): "/mnt/Volume_3/Gentoo/temp/portage/sci-libs/vtk-9.2.2/work/VTK-9.2.2"
 * Build directory  (BUILD_DIR):     "/mnt/Volume_3/Gentoo/temp/portage/sci-libs/vtk-9.2.2/work/VTK-9.2.2_build"
ninja -v -j3 -l2
ninja: error: '/usr/lib64/', needed by 'lib64/', missing and no known rule to make it
 * ERROR: sci-libs/vtk-9.2.2::gentoo failed (compile phase):
 *   ninja -v -j3 -l2 failed


I used `e-file` and it pointed out dev-libs/c-blosc. After emerging this package the build continued past that point.

So, the ebuild needs c-blosc as a dependency.
Comment 1 Petross404(Petros S) 2022-12-15 19:09:01 UTC
Created attachment 842905 [details]
emerge --info '=sci-libs/vtk-9.2.2::gentoo'
Comment 2 Petross404(Petros S) 2022-12-15 19:10:38 UTC
I think these are needed too.

GENTOO_VM=  CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm"
Comment 3 Jesper Saxtorph 2023-06-04 17:53:41 UTC
I had the same problem on an upgrade where vtk needed a rebuild.
I can see I unmerged dev-libs/c-blosc in May, through an emerge depclean if I am not mistaken. So earlier it have been pulled in by another package and thus the problem have not shown it self before.
Comment 4 falsifiability 2023-06-09 00:13:47 UTC
I can confirm this buy. Had the same error when vtk needed a rebuild caused by app-emulation/libvirt.