Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88546 - Imlib2 can't seem to find X (imlib2-1.2.0.004)
Summary: Imlib2 can't seem to find X (imlib2-1.2.0.004)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-09 22:47 UTC by jason wohlgemuth
Modified: 2005-04-10 13:35 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The config log. (config.log,44.49 KB, text/plain)
2005-04-09 22:49 UTC, jason wohlgemuth
Details
config.log generated by the ebuild on the 10th of Apr.05 on my machine (config.log,42.23 KB, text/plain)
2005-04-10 00:12 UTC, François Bissey
Details
imlib2-libX11.patch (imlib2-libX11.patch,346 bytes, patch)
2005-04-10 04:06 UTC, Ryan Hill (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jason wohlgemuth 2005-04-09 22:47:58 UTC
enabled mmx support
checking for freetype-config... /usr/bin/freetype-config
checking for X... no
configure: error: no X support found.  Use --x-includes and --x-libraries to specify the X
path on your system, or --without-x to disable X support.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/imlib2-1.2.0.004/work/imlib2-1.2.0.004/config.log

!!! ERROR: media-libs/imlib2-1.2.0.004 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

X is installed as shown:

# X -version

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.11-gentoo-r4 i686 [ELF] 
Current Operating System: Linux Aurora 2.6.11-gentoo-r5 #1 Tue Apr 5 16:24:10 CDT 2005 i686
Build Date: 25 March 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present



Reproducible: Always
Steps to Reproduce:
I can't seem to find anything specific that caused this.

Actual Results:  
Imlib2 says it can't find X

Expected Results:  
Normal compilation.

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-4.0.0-beta20050402,
glibc-2.3.4.20050125-r1, 2.6.11-gentoo-r5 i686)
=================================================================
System uname: 2.6.11-gentoo-r5 i686 Intel(R) Pentium(R) III Mobile CPU      1000MHz
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 16 2005, 02:33:19)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.11
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium3 -O2  -pipe -fomit-frame-pointer -fforce-addr -ftracer 
-fno-unit-at-a-time  -ftree-vectorize -ftree-vectorizer-verbose=1 -fweb "
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.1/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O2  -pipe -fomit-frame-pointer -fforce-addr -ftracer
 -fno-unit-at-a-time  -ftree-vectorize -ftree-vectorizer-verbose=1 -fweb "
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sfperms"
GENTOO_MIRRORS="http://mirror.tucdemonic.org/gentoo/
http://gentoo.chem.wisc.edu/gentoo  ftp://gentoo.noved.org/ ftp://gentoo.ccccom.com"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
MAKEOPTS="-j3"                  
PKGDIR="/usr/portage/packages"  
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"          
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts bonobo bootsplash bzlib cddb
cdparanoia cdr clamav codecs crypt cups curl divx4linux dvd dvdr dvdread emboss
encode esd fam fbdev flac foomaticdb fortran gdbm gif gnome gpm gtk gtk2 icc
imagemagick imlib imlib2 ipv6 java jit jpeg kde libg++ libwww mad mikmod mmx
motif mp3 mpeg mplayer msn ncurses nptl nptlonly oggvorbis opengl oss pam pcmcia
pdflib perl png pnp python qemu-fast qt quicktime radeon readline samba sdl
slang softmmu spell sse ssl svga tcltk tcpd tiff truetype truetype-fonts
type1-fonts v4l2 xml2 xmms xprint xv yahoo zlib video_cards_radeon"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL
Comment 1 jason wohlgemuth 2005-04-09 22:49:12 UTC
Created attachment 55832 [details]
The config log.
Comment 2 jason wohlgemuth 2005-04-09 22:52:47 UTC
Aurora ~ # locate Xlib.h
/usr/lib/perl5/vendor_perl/5.8.2/i686-linux/Tk/pTk/Xlib.h
/usr/include/X11/Xlib.h
/usr/include/firefox-0.9/widget/nsIDragSessionXlib.h
Comment 3 jason wohlgemuth 2005-04-09 23:00:52 UTC
After viewing the log I think the problem was caused by something else failing. I think I will close the bug myself because it now looks like a configuration issue on my behalf. I'll mark invalid because it probably isn't a bug.
Comment 4 SpanKY gentoo-dev 2005-04-09 23:05:53 UTC
config.log says that configure cant seem to find 'libX.so' ...
Comment 5 jason wohlgemuth 2005-04-09 23:09:29 UTC
Hmm. I don't seem to have libX.so.  I'll investigate, but I'm guessing it isn't an imlib issue.
Comment 6 teidakankan 2005-04-09 23:48:14 UTC
I'm getting the same error message on two different boxes.  I would appreciate it if you could post any solution you come up with here.  Thanks.
Comment 7 François Bissey 2005-04-10 00:07:48 UTC
This version of Imlib2 just made it into x86 and I am getting by exactly the same problem but my system is mainly x86 with few ~x86 packages.
I suspect that it is the result of changes in xorg 6.8.2.
Definitely a bug and definitely not invalid in my opinion.
Probably need to be fixed upstream though.
I'll attach my own config.log after this message. Here is my emerge info:
 Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  7 2005, 21:17:04)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=athlon-xp -fomit-frame-pointer -pipe -fsigned-char -frename-registers -fno-strict-aliasing"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=athlon-xp -fomit-frame-pointer -pipe -fsigned-char -frename-registers -fno-strict-aliasing"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://mirror.pacific.net.au/linux/Gentoo http://mirrors.tds.net/gentoo ftp://mirrors.tds.net/gentoo http://gentoo.eliteitminds.com"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X a52 aac aalib alsa apm arts avi berkdb bidi bitmap-fonts bootsplash cdf cdparanoia cdr crypt cups curl curlwrappers dga divx4linux dvd dvdr dvdread edl emboss emul-linux encode esd exif fam fastcgi fb fbcon fftw flac font-server foomaticdb fortran fpx gdbm ggi gif gimpprint gpm graphviz gtk gtk2 hdf icc imagemagick imlib imlib2 ipv6 jack java jbig joystick jpeg jpeg2k kde lcms ldap libg++ libwww live lzw-tiff mad matroska mikmod mime mmx mmx2 motif mp3 mpeg mysql ncurses netcdf network nlsnptl ogg oggvorbis openal openexr opengl oss pam pdflib perl png portaudio posix python qt quicktime readline real sdl slang spell sse ssl svg svga tcltk tcpd tetex tga theora tiff truetype truetype-fonts type1-fonts unicode usb vidix wmf xanim xine xml xml2 xmms xpm xsl xv xvid xvmc zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS

==================

Comment 8 François Bissey 2005-04-10 00:12:46 UTC
Created attachment 55835 [details]
config.log generated by the ebuild on the 10th of Apr.05 on my machine
Comment 9 jason wohlgemuth 2005-04-10 00:14:21 UTC
Since I'm not the only one. I'll reopen.
Comment 10 Wolfgang Thiess 2005-04-10 00:22:49 UTC
With a symbolic link "ln -s libX11.so /usr/lib/libX.so" it compiles fine.

emerge -v "<media-libs/imlib2-1.2.0.004" installs imlib2-1.2.0-r2, which compiles without the symbolic link.
Comment 11 M3rL7N 2005-04-10 03:56:31 UTC
Same here.

checking for freetype-config... /usr/bin/freetype-config
checking for X... no
configure: error: no X support found.  Use --x-includes and --x-libraries to specify the X
path on your system, or --without-x to disable X support.
Comment 12 Ryan Hill (RETIRED) gentoo-dev 2005-04-10 04:06:08 UTC
Created attachment 55850 [details, diff]
imlib2-libX11.patch

it should be using -lX11 rather than -lX.

dirtyepic ~/work $ cat test.c 
#include <X11/Xlib.h>

main () {
}

dirtyepic ~/work $ gcc -o test test.c -lX
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../../../i686-pc-linux-gnu/bin/ld:
cannot find -lX
collect2: ld returned 1 exit status

dirtyepic ~/work $ gcc -o test test.c -lX11
dirtyepic ~/work $ 


this patches configure to use the right library.  built and tested.
Comment 13 Stephan 2005-04-10 05:56:13 UTC
Just patching the Sources and it works.
cheers
Comment 14 Steev Klimaszewski gentoo-dev 2005-04-10 06:42:23 UTC
I run everything from cvs, and if I recall correctly, this is caused by the configure script not following the symlink to /usr/X11R6.  It is fixed in CVS.
Comment 15 merwan kashouty 2005-04-10 06:50:59 UTC
put the patch in the files dir of imlib2 and added  

src_compile() {
        epatch ${FILESDIR}/imlib2-libX11.patch
patched and compiled fine.... thanks Ryan
Comment 16 Jory A. Pratt 2005-04-10 07:31:22 UTC
patching is not needed --x-include and --x-library can be passed threw econf.
Comment 17 SpanKY gentoo-dev 2005-04-10 13:35:52 UTC
added patch to portage ... it's already been fixed in upstream cvs