Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 880845 - x11-misc/unclutter-8-r4 - unclutter.c: error: type specifier missing, defaults to int; ISO C99 and
Summary: x11-misc/unclutter-8-r4 - unclutter.c: error: type specifier missing, default...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: clang-16-porting
  Show dependency tree
 
Reported: 2022-11-10 20:30 UTC by Toralf Förster
Modified: 2022-12-31 18:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.01 KB, text/plain)
2022-11-10 20:30 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,146.28 KB, text/plain)
2022-11-10 20:30 UTC, Toralf Förster
Details
environment (environment,58.97 KB, text/plain)
2022-11-10 20:31 UTC, Toralf Förster
Details
etc.clang.tar.bz2 (etc.clang.tar.bz2,704 bytes, application/x-bzip)
2022-11-10 20:31 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,28.45 KB, application/x-bzip)
2022-11-10 20:31 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,16.26 KB, application/x-bzip)
2022-11-10 20:31 UTC, Toralf Förster
Details
x11-misc:unclutter-8-r4:20221110-202958.log (x11-misc:unclutter-8-r4:20221110-202958.log,4.87 KB, text/plain)
2022-11-10 20:31 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-11-10 20:30:55 UTC
      in all versions of C and is not supported in C2x
      [-Wdeprecated-non-prototype]
VirtualRootWindow(dpy, screen)
^
unclutter.c:31:1: error: type specifier missing, defaults to 'int'; ISO C99 and
      later do not support implicit int [-Werror,-Wimplicit-int]
pexit(str)char *str;{

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome-j4-20221109-200005

  -------------------------------------------------------------------

GNUMAKEFLAGS="$GNUMAKEFLAGS --shuffle"
CC=clang
CXX=clang++
gcc-config -l:
 [1] x86_64-pc-linux-gnu-12 *
clang/llvm (if any):
clang version 15.0.4
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
Configuration file: /etc/clang/clang.cfg
/usr/lib/llvm/15
15.0.4
Python 3.10.8
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby31 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.64.0 *
php cli (if any):
  (none found)

  HEAD of ::gentoo
commit 1cfadf62e0795b3455c4f3297d7c56fdd989eed3
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Thu Nov 10 19:46:53 2022 +0000

    2022-11-10 19:46:53 UTC

emerge -qpvO x11-misc/unclutter
[ebuild  N    ] x11-misc/unclutter-8-r4
Comment 1 Toralf Förster gentoo-dev 2022-11-10 20:30:57 UTC
Created attachment 830671 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-11-10 20:30:58 UTC
Created attachment 830673 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2022-11-10 20:31:00 UTC
Created attachment 830675 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-11-10 20:31:00 UTC
Created attachment 830677 [details]
etc.clang.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-11-10 20:31:02 UTC
Created attachment 830679 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-11-10 20:31:03 UTC
Created attachment 830681 [details]
temp.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2022-11-10 20:31:03 UTC
Created attachment 830683 [details]
x11-misc:unclutter-8-r4:20221110-202958.log
Comment 8 Ionen Wolkens gentoo-dev 2022-11-10 22:09:58 UTC
ftr this should probably be last rited, x11-misc/unclutter-xfixes is the maintained and (far) superior alternative

Any user using the old one is putting up with a lot of nonsense caused by the fake window hacks.
Comment 9 Larry the Git Cow gentoo-dev 2022-11-27 16:53:41 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9796537847c340add47f0bfd756133f2e0b3799b

commit 9796537847c340add47f0bfd756133f2e0b3799b
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2022-11-27 16:44:51 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2022-11-27 16:53:33 +0000

    package.mask: Last rite x11-misc/unclutter
    
    Bug: https://bugs.gentoo.org/880845
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 profiles/package.mask | 6 ++++++
 1 file changed, 6 insertions(+)
Comment 10 Larry the Git Cow gentoo-dev 2022-12-31 18:32:16 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cbbf434130c144f1d9d74efde886de8dccea21b9

commit cbbf434130c144f1d9d74efde886de8dccea21b9
Author:     Jakov Smolić <jsmolic@gentoo.org>
AuthorDate: 2022-12-31 18:16:38 +0000
Commit:     Jakov Smolić <jsmolic@gentoo.org>
CommitDate: 2022-12-31 18:30:54 +0000

    x11-misc/unclutter: treeclean
    
    Closes: https://bugs.gentoo.org/880845
    Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>

 profiles/package.mask                              |  6 ----
 x11-misc/unclutter/Manifest                        |  1 -
 .../unclutter/files/unclutter-8-FocusOut.patch     | 17 -----------
 x11-misc/unclutter/files/unclutter-8-include.patch | 10 -------
 x11-misc/unclutter/metadata.xml                    |  8 -----
 x11-misc/unclutter/unclutter-8-r4.ebuild           | 35 ----------------------
 6 files changed, 77 deletions(-)