Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 88023 - mplayer-1.0_pre6-r2 compiling failed due calling at 64bit little_endians
Summary: mplayer-1.0_pre6-r2 compiling failed due calling at 64bit little_endians
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 93607 99012 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-05 04:18 UTC by traini ido
Modified: 2006-06-22 11:25 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description traini ido 2005-04-05 04:18:42 UTC
When i try to emerge mplayer, the compiling fails. Looking into log errors happens for calling at some little_endians libraries that (seems to me) are refered at 64bit platform.

Here is the part of the log with the error:
------
In file included from /usr/src/linux/include/asm/byteorder.h:57,
                 from /usr/src/linux/include/linux/cdrom.h:14,
                 from vcd_read.h:7,
                 from stream_vcd.c:25:
/usr/src/linux/include/linux/byteorder/little_endian.h:43: error: parse error before "__cpu_to_le64p"
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__cpu_to_le64p':
/usr/src/linux/include/linux/byteorder/little_endian.h:45: error: `__le64' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h:45: error: (Each undeclared identifier is reported only once
/usr/src/linux/include/linux/byteorder/little_endian.h:45: error: for each function it appears in.)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:47: error: parse error before '*' token
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__le64_to_cpup':
/usr/src/linux/include/linux/byteorder/little_endian.h:49: error: `p' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:51: error: parse error before "__cpu_to_le32p"
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__cpu_to_le32p':
/usr/src/linux/include/linux/byteorder/little_endian.h:53: error: `__le32' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:55: error: parse error before '*' token
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__le32_to_cpup':
/usr/src/linux/include/linux/byteorder/little_endian.h:57: error: `p' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:59: error: parse error before "__cpu_to_le16p"
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__cpu_to_le16p':
/usr/src/linux/include/linux/byteorder/little_endian.h:61: error: `__le16' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:63: error: parse error before '*' token
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__le16_to_cpup':
/usr/src/linux/include/linux/byteorder/little_endian.h:65: error: `p' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:67: error: parse error before "__cpu_to_be64p"
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__cpu_to_be64p':
/usr/src/linux/include/linux/byteorder/little_endian.h:69: error: `__be64' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h:69: error: parse error before "__swab64p"
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:71: error: parse error before '*' token
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__be64_to_cpup':
/usr/src/linux/include/linux/byteorder/little_endian.h:73: error: `p' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:75: error: parse error before "__cpu_to_be32p"
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__cpu_to_be32p':
/usr/src/linux/include/linux/byteorder/little_endian.h:77: error: `__be32' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h:77: error: parse error before "__swab32p"
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:79: error: parse error before '*' token
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__be32_to_cpup':
/usr/src/linux/include/linux/byteorder/little_endian.h:81: error: `p' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:83: error: parse error before "__cpu_to_be16p"
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__cpu_to_be16p':
/usr/src/linux/include/linux/byteorder/little_endian.h:85: error: `__be16' undeclared (first use in this function)
/usr/src/linux/include/linux/byteorder/little_endian.h:85: error: parse error before "__swab16p"
/usr/src/linux/include/linux/byteorder/little_endian.h: At top level:
/usr/src/linux/include/linux/byteorder/little_endian.h:87: error: parse error before '*' token
/usr/src/linux/include/linux/byteorder/little_endian.h: In function `__be16_to_cpup':
/usr/src/linux/include/linux/byteorder/little_endian.h:89: error: `p' undeclared (first use in this function)
make[1]: *** [stream_vcd.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/mplayer-1.0_pre6-r2/work/MPlayer-1.0pre6a/libmpdemux'
-------

I've tried also to modify my CFLAGS, to change some USE and all the insights posted in bugzilla and in the forum but nothing.

My system is compiled with gcc 3.4

Reproducible: Always
Steps to Reproduce:
1.emerge mplayer
2.
3.

Actual Results:  
fails 

Expected Results:  
success on emerging mplayer 

Portage 2.0.51.19 (default-linux/x86/2004.0, gcc-3.4.3-20050110, 
glibc-2.3.4.20050125-r1, 2.6.9-gentoo-r1 i686) 
================================================================= 
System uname: 2.6.9-gentoo-r1 i686 AMD Athlon(tm) XP 2000+ 
Gentoo Base System version 1.6.10 
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr  3 2005, 02:11:49)] 
ccache version 2.4 [enabled] 
dev-lang/python:     2.3.5 
sys-devel/autoconf:  2.59-r6, 2.13 
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5 
sys-devel/binutils:  2.15.92.0.2-r7 
sys-devel/libtool:   1.5.14 
virtual/os-headers:  2.6.8.1-r4 
ACCEPT_KEYWORDS="x86 ~x86" 
AUTOCLEAN="yes" 
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer" 
CHOST="i686-pc-linux-gnu" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms" 
GENTOO_MIRRORS="http://mirror.switch.ch/mirror/gentoo/ 
ftp://mirror.switch.ch/mirror/gentoo/ 
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/" 
LANG="39" 
LC_ALL="it_IT@euro" 
MAKEOPTS="-j2" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://rsync.gentoo.org/gentoo-portage" 
USE="X aalib alsa apm arts avi berkdb bindist bitmap-fonts cdr crypt cscope 
cups curl doc dvb dvd dvdr emboss encode esd fam fbcon firebird flac 
font-server foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 icq 
imagemagick imlib ipv6 java jikes jpeg junit kde ldap libg++ libwww mad mikmod 
mmx mmxext motif mozilla mp3 mpeg mysql mysqloffensive ncurses nls oggvorbis 
opengl oss pam pdflib perl png ppds python qt quicktime readline samba sdl 
slang spell sqlite sse ssl svga tcltk tcpd tiff truetype truetype-fonts 
type1-fonts usb videos x86 xml xml2 xmms xv xvid zlib linguas_it" 
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-07-14 07:54:55 UTC
*** Bug 99012 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-07-14 07:56:36 UTC
What about trying linux-headers-2.6.11-r2 ? Does it work?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-07-14 07:57:16 UTC
*** Bug 93607 has been marked as a duplicate of this bug. ***
Comment 4 Maik Nijhuis 2005-07-31 07:25:54 UTC
I also encountered this one, using gcc 3.3.4. After switching my gcc (back) to
3.4.4, everything was ok. I don't remember which gcc I used to compile the kernel.

Output from emerge info:

Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r0,
2.6.9-gentoo-r13 i686)
=================================================================
System uname: 2.6.9-gentoo-r13 i686 AMD Duron(tm) Processor
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.4.3-r4, 1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.ipv6.utwente.nl/pub/os/linux/gentoo/
http://ftp.snt.utwente.nl/pub/os/linux/gentoo/
http://ftp.easynet.nl/mirror/gentoo/ ftp://mirror.scarlet-internet.nl/pub/gentoo"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex 3dnowext X a52 acpi alsa avi berkdb bitmap-fonts
bluetooth cdr crypt cups divx4linux dts dvb dvd dvdr dvdread emboss encode fam
fbcon ffmpeg flac foomaticdb gdbm gif gpm gtk gtk2 icq imagemagick imlib ipv6
jabber java jikes jpeg justify libg++ libwww live mad mikmod mmx mmx2 mmxext
motif mp3 mpeg mpeg2 msn ncurses network nptl offensive ogg oggvorbis opengl pam
pdflib perl png python qt quicktime readline real sdl slang snmp spell ssl
stream stroke svga tcpd tiff truetype truetype-fonts type1-fonts usb vorbis
win32codecs xml2 xmms xv xvid zlib video_cards_sis userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 5 Scott 2005-12-31 19:33:00 UTC
I also encountered this one.  I am running linux-headers 2.6.11-r2 and gcc3.4.4-r1 on AMD64.  

emerge --info follows:
=====================
Portage 2.0.53 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.9-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.9-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo/ http://csociety-ftp.ecn.purdue.edu/pub/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ http://mirrors.tds.net/gentoo http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.mirrored.ca http://mirror.datapipe.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X aalib acl aim alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bonobo bzip2 cdr crypt cups curl curlwrappers divx4linux doc dts dvb dvd dvdr eds emboss encode esd ethereal evo exif expat fam fbcon festival ffmpeg flac foomaticdb fortran ftp gd gdbm gif glut gnome gphoto2 gpm gps gstreamer gtk gtk2 guile icq idn imagemagick imlib ipv6 jabber java joystick jpeg junit kde kerberos krb4 lcms libgda libwww lua lzw lzw-tiff mad maildir matroska mbox memlimit mhash mikmod mime mng mozilla mp3 mpeg msql mysql mysqli ncurses nls nsplugin odbc offensive ofx ogg oggvorbis openal opengl pam pcre pda pdflib perl plotutils png postgres ppds prelude print python qt quicktime readline recode samba sdl shape sharedmem slang slp soap sockets socks5 sox speex spell spl ssl tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts unicode usb userlocales videos vorbis xine xinerama xml xml2 xmms xpm xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

Comment 6 Steve Dibb (RETIRED) gentoo-dev 2006-06-22 07:51:21 UTC
Is this bug still present in recent versions of mplayer?
Comment 7 Russ Pridemore 2006-06-22 09:07:49 UTC
(In reply to comment #6)
> Is this bug still present in recent versions of mplayer?
> 
Just successfully emerged 1.0.20060217.
Got several: "warning: cast to pointer from integer of different size" and "warning: comparison is always true due to limited range of data type" and "warning: assignment from incompatible pointer type", so it looks like there remains some housekeeping to do.  I can't test running it until I get home tonight, but it installed fine.
Comment 8 Bill Thompson 2006-06-22 11:25:30 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Is this bug still present in recent versions of mplayer?
> > 
> Just successfully emerged 1.0.20060217.
> Got several: "warning: cast to pointer from integer of different size" and
> "warning: comparison is always true due to limited range of data type" and
> "warning: assignment from incompatible pointer type", so it looks like there
> remains some housekeeping to do.  I can't test running it until I get home
> tonight, but it installed fine.
> 

This error was due to an error in /usr/src/linux/byteorder.h in an earlier version of linux headers.byteorder.h had to edited for mplayer to emerge. Updating the headers solved the problem.