Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 879761 - sci-libs/plplot: possible configure breakage with Clang 16
Summary: sci-libs/plplot: possible configure breakage with Clang 16
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
: 923256 (view as bug list)
Depends on:
Blocks: implicit-in-configure
  Show dependency tree
 
Reported: 2022-11-04 22:15 UTC by Matt Jolly
Modified: 2024-05-10 01:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
clang-14.log (clang-14.log,18.88 KB, text/plain)
2022-11-04 22:15 UTC, Matt Jolly
Details
clang-15.log (clang-15.log,18.78 KB, text/plain)
2022-11-04 22:15 UTC, Matt Jolly
Details
clang.diff (clang.diff,34.42 KB, text/plain)
2022-11-04 22:15 UTC, Matt Jolly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Jolly gentoo-dev 2022-11-04 22:15:09 UTC
This package has been identified via automation as potentially impacted by upcoming Clang 16 changes.
The following have been identified as potential issues:

[-Werror,-Wimplicit-function-declaration]

[-Werror,-Wimplicit-function-declaration]
error: call to undeclared library function 'exit' with type 'void (int) __attribute__((noreturn))'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
Comment 1 Matt Jolly gentoo-dev 2022-11-04 22:15:11 UTC
Created attachment 827531 [details]
clang-14.log

build log
Comment 2 Matt Jolly gentoo-dev 2022-11-04 22:15:14 UTC
Created attachment 827533 [details]
clang-15.log

build log
Comment 3 Matt Jolly gentoo-dev 2022-11-04 22:15:16 UTC
Created attachment 827535 [details]
clang.diff

build log
Comment 4 Pacho Ramos gentoo-dev 2023-11-24 14:06:39 UTC
Please retry with plplot-5.15.0_p6
Comment 5 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2024-05-10 01:22:47 UTC
*** Bug 923256 has been marked as a duplicate of this bug. ***
Comment 6 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2024-05-10 01:23:09 UTC
-/var/tmp/portage/sci-libs/plplot-5.15.0-r103/work/plplot-5.15.0/cmake/modules/TestForHighBitCharacters.c:20:8: error: call to undeclared library function 'exit' with type 'void (int) __attribute__((noreturn))'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
+/var/tmp/portage/sci-libs/plplot-5.14.0-r103/work/plplot-5.14.0/cmake/modules/TestForHighBitCharacters.c:20:8: error: call to undeclared library function 'exit' with type 'void (int) __attribute__((noreturn))'; ISO C99 and later do not support implicit function declarations [-Werror,-Wimplicit-function-declaration]
        exit(1);
        ^
-/var/tmp/portage/sci-libs/plplot-5.15.0-r103/work/plplot-5.15.0/cmake/modules/TestForHighBitCharacters.c:20:8: note: include the header <stdlib.h> or explicitly provide a declaration for 'exit'
+/var/tmp/portage/sci-libs/plplot-5.14.0-r103/work/plplot-5.14.0/cmake/modules/TestForHighBitCharacters.c:20:8: note: include the header <stdlib.h> or explicitly provide a declaration for 'exit'
 

Definitely still there.
Comment 7 Larry the Git Cow gentoo-dev 2024-05-10 01:43:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=359a269725785328df0c0cf856d1e8374d98735e

commit 359a269725785328df0c0cf856d1e8374d98735e
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2024-05-10 01:24:28 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2024-05-10 01:24:28 +0000

    sci-libs/plplot: fix modern C issue in (CMake) configure
    
    Closes: https://bugs.gentoo.org/879761
    Signed-off-by: Sam James <sam@gentoo.org>

 .../plplot/files/plplot-5.15.0_p6-configure-c99.patch  | 18 ++++++++++++++++++
 ...lot-5.15.0_p6.ebuild => plplot-5.15.0_p6-r1.ebuild} |  1 +
 2 files changed, 19 insertions(+)