Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 87800 - patches for mozilla/firefox to compile with gcc4
Summary: patches for mozilla/firefox to compile with gcc4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
: 90118 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-03 09:38 UTC by Genady Okrain
Modified: 2005-06-03 05:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mozilla-1.7.6-gcc4-fix.patch (mozilla-1.7.6-gcc4-fix.patch,538 bytes, text/plain)
2005-04-03 09:39 UTC, Genady Okrain
Details
GCC4 compile fix (mozilla-firefox-1.0.2-gcc4.patch,1.78 KB, patch)
2005-04-06 12:54 UTC, Mark Loeser (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Genady Okrain 2005-04-03 09:38:50 UTC
Compiles fine here.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Genady Okrain 2005-04-03 09:39:21 UTC
Created attachment 55193 [details]
mozilla-1.7.6-gcc4-fix.patch
Comment 2 SpanKY gentoo-dev 2005-04-03 10:10:05 UTC
that may let the package compile but does it work afterwards ?

ive seen a patch that looks very much like this one before where the package compiled fine but then just segfaulted all over the place
Comment 3 Genady Okrain 2005-04-03 10:25:43 UTC
Works fine here with all the gcc-4.0 snapshots from portage and from cvs.
Comment 4 Mark Loeser (RETIRED) gentoo-dev 2005-04-05 23:13:43 UTC
I agree with Spanky.  This patch isn't really fixing the issue and changes the meaning of the code.  It looks like there are some patches upstream already.  I'll look through them and try them out when I get the time.
Comment 5 Mark Loeser (RETIRED) gentoo-dev 2005-04-06 12:54:40 UTC
Created attachment 55512 [details, diff]
GCC4 compile fix

This is the upstream patch for this issue which is already applied in their
CVS.  Successfully compiles and runs here.  The patch applies fine to Firefox
and Thunderbird.
Comment 6 Mark Loeser (RETIRED) gentoo-dev 2005-04-15 23:33:47 UTC
I've tested this patch with the suite, firefox and thunderbird.  It applies fine to all of them and allows compilation with GCC4.  If there are no objections, I would like to add these patches soon.
Comment 7 SpanKY gentoo-dev 2005-04-24 09:48:27 UTC
*** Bug 90118 has been marked as a duplicate of this bug. ***
Comment 8 Mark Loeser (RETIRED) gentoo-dev 2005-05-14 18:55:38 UTC
Patches committed to the tree.  All mozilla related packages should be fixed now.
Comment 9 Pythagoras Mayrhofer 2005-06-03 02:53:55 UTC
i just tried compiling firefox using gcc4 and failed. maybe the fact that i'm
running on an amd64 may be a factor.
i don't know the error any more it was something about incompatible array types.
i'll check that out.
Comment 10 Pythagoras Mayrhofer 2005-06-03 05:10:38 UTC
here is the error ('Fehler' means 'Error'). i'm not shure if this error has to
do with this bug.

c++ -o nsHttpConnectionMgr.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"
-I./../../../base/src -I../../../../dist/include/xpcom
-I../../../../dist/include/string -I../../../../dist/include/pref
-I../../../../dist/include/nkcache -I../../../../dist/include/mimetype
-I../../../../dist/include/intl -I../../../../dist/include/unicharutil
-I../../../../dist/include/caps -I../../../../dist/include/xpconnect
-I../../../../dist/include/js -I../../../../dist/include/uconv
-I../../../../dist/include/necko -I../../../../dist/include
-I/var/tmp/portage/mozilla-thunderbird-1.0.2/work/mozilla/dist/include/nspr    
   -fPIC   -fno-rtti -fno-exceptions  -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -march=k8 -pipe -fPIC -fshort-wchar -pthread -pipe  -DNDEBUG
-DTRIMMED -ffunction-sections -O1   -DMOZILLA_CLIENT -include
../../../../mozilla-config.h -Wp,-MD,.deps/nsHttpConnectionMgr.pp
nsHttpConnectionMgr.cpp
nsHttpRequestHead.cpp
c++ -o nsHttpRequestHead.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"
-I./../../../base/src -I../../../../dist/include/xpcom
-I../../../../dist/include/string -I../../../../dist/include/pref
-I../../../../dist/include/nkcache -I../../../../dist/include/mimetype
-I../../../../dist/include/intl -I../../../../dist/include/unicharutil
-I../../../../dist/include/caps -I../../../../dist/include/xpconnect
-I../../../../dist/include/js -I../../../../dist/include/uconv
-I../../../../dist/include/necko -I../../../../dist/include
-I/var/tmp/portage/mozilla-thunderbird-1.0.2/work/mozilla/dist/include/nspr    
   -fPIC   -fno-rtti -fno-exceptions  -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -march=k8 -pipe -fPIC -fshort-wchar -pthread -pipe  -DNDEBUG
-DTRIMMED -ffunction-sections -O1   -DMOZILLA_CLIENT -include
../../../../mozilla-config.h -Wp,-MD,.deps/nsHttpRequestHead.pp
nsHttpRequestHead.cpp
nsHttpConnectionMgr.cpp: In member function 
Comment 11 Pythagoras Mayrhofer 2005-06-03 05:10:38 UTC
here is the error ('Fehler' means 'Error'). i'm not shure if this error has to
do with this bug.

c++ -o nsHttpConnectionMgr.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"
-I./../../../base/src -I../../../../dist/include/xpcom
-I../../../../dist/include/string -I../../../../dist/include/pref
-I../../../../dist/include/nkcache -I../../../../dist/include/mimetype
-I../../../../dist/include/intl -I../../../../dist/include/unicharutil
-I../../../../dist/include/caps -I../../../../dist/include/xpconnect
-I../../../../dist/include/js -I../../../../dist/include/uconv
-I../../../../dist/include/necko -I../../../../dist/include
-I/var/tmp/portage/mozilla-thunderbird-1.0.2/work/mozilla/dist/include/nspr    
   -fPIC   -fno-rtti -fno-exceptions  -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -march=k8 -pipe -fPIC -fshort-wchar -pthread -pipe  -DNDEBUG
-DTRIMMED -ffunction-sections -O1   -DMOZILLA_CLIENT -include
../../../../mozilla-config.h -Wp,-MD,.deps/nsHttpConnectionMgr.pp
nsHttpConnectionMgr.cpp
nsHttpRequestHead.cpp
c++ -o nsHttpRequestHead.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\"
-I./../../../base/src -I../../../../dist/include/xpcom
-I../../../../dist/include/string -I../../../../dist/include/pref
-I../../../../dist/include/nkcache -I../../../../dist/include/mimetype
-I../../../../dist/include/intl -I../../../../dist/include/unicharutil
-I../../../../dist/include/caps -I../../../../dist/include/xpconnect
-I../../../../dist/include/js -I../../../../dist/include/uconv
-I../../../../dist/include/necko -I../../../../dist/include
-I/var/tmp/portage/mozilla-thunderbird-1.0.2/work/mozilla/dist/include/nspr    
   -fPIC   -fno-rtti -fno-exceptions  -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -march=k8 -pipe -fPIC -fshort-wchar -pthread -pipe  -DNDEBUG
-DTRIMMED -ffunction-sections -O1   -DMOZILLA_CLIENT -include
../../../../mozilla-config.h -Wp,-MD,.deps/nsHttpRequestHead.pp
nsHttpRequestHead.cpp
nsHttpConnectionMgr.cpp: In member function »void
nsHttpConnectionMgr::OnMsgUpdateParam(nsresult, void*)«:
nsHttpConnectionMgr.cpp:837: Fehler: cast from »void*« to »PRUint32« loses precision
nsHttpConnectionMgr.cpp:838: Fehler: cast from »void*« to »PRUint32« loses precision
gmake[5]: *** [nsHttpConnectionMgr.o] Fehler 1