Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 875014 - media-sound/wavegain-1.3.1 - wavegain.c: error: call to undeclared function getpid; ISO C99 and
Summary: media-sound/wavegain-1.3.1 - wavegain.c: error: call to undeclared function g...
Status: RESOLVED DUPLICATE of bug 874903
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: clang-16-porting
  Show dependency tree
 
Reported: 2022-10-04 16:36 UTC by Toralf Förster
Modified: 2022-11-21 00:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.37 KB, text/plain)
2022-10-04 16:36 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,93.37 KB, text/plain)
2022-10-04 16:36 UTC, Toralf Förster
Details
environment (environment,61.11 KB, text/plain)
2022-10-04 16:36 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,13.00 KB, application/x-bzip)
2022-10-04 16:36 UTC, Toralf Förster
Details
media-sound:wavegain-1.3.1:20221004-042612.log (media-sound:wavegain-1.3.1:20221004-042612.log,6.69 KB, text/plain)
2022-10-04 16:36 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,16.97 KB, application/x-bzip)
2022-10-04 16:36 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-10-04 16:36:32 UTC
4 warnings generated.
6 warnings generated.
1 warning generated.
clang -pipe -march=native -fno-diagnostics-color -O2 -Werror=implicit-function-declaration -Werror=implicit-int -DHAVE_CONFIG_H -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0  wavegain.c audio.o dither.o gain_analysis.o getopt1.o getopt.o main.o misc.o recurse.o  -lm -o wavegain
wavegain.c:524:36: error: call to undeclared function 'getpid'; ISO C99 and
      later do not support implicit function declarations
      [-Werror,-Wimplicit-function-declaration]

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome_systemd-j4-20221003-130005

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-12.2.0 *
clang/llvm (if any):
clang version 15.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
/usr/lib/llvm/15
15.0.1
Python 3.10.7
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.64.0 *
The following VMs are available for generation-2:
*)	Eclipse Temurin JDK 17.0.4.1_p1 [openjdk-bin-17]
2)	Eclipse Temurin JDK 8.345_p01 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8 
  [2]   openjdk-bin-17  system-vm

The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
GNU Make 4.3

  HEAD of ::gentoo
commit 501157bc846c4e0beb0c5a4ecf3516e2e7eb4e4e
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Tue Oct 4 03:17:27 2022 +0000

    2022-10-04 03:17:27 UTC

emerge -qpvO media-sound/wavegain
[ebuild  N    ] media-sound/wavegain-1.3.1
Comment 1 Toralf Förster gentoo-dev 2022-10-04 16:36:33 UTC
Created attachment 819328 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-10-04 16:36:34 UTC
Created attachment 819331 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2022-10-04 16:36:36 UTC
Created attachment 819334 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-10-04 16:36:37 UTC
Created attachment 819337 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-10-04 16:36:38 UTC
Created attachment 819340 [details]
media-sound:wavegain-1.3.1:20221004-042612.log
Comment 6 Toralf Förster gentoo-dev 2022-10-04 16:36:39 UTC
Created attachment 819343 [details]
temp.tar.bz2
Comment 7 Ionen Wolkens gentoo-dev 2022-11-21 00:06:05 UTC

*** This bug has been marked as a duplicate of bug 874903 ***