Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 874516 - dev-libs/argtable-2.13-r2 - arg_int.c: error: implicit declaration of function isspace [-Werror=implicit-function-declaration]
Summary: dev-libs/argtable-2.13-r2 - arg_int.c: error: implicit declaration of functio...
Status: RESOLVED DUPLICATE of bug 871231
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: clang-16-porting
  Show dependency tree
 
Reported: 2022-10-03 08:10 UTC by Toralf Förster
Modified: 2022-10-21 14:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.67 KB, text/plain)
2022-10-03 08:10 UTC, Toralf Förster
Details
dev-libs:argtable-2.13-r2:20221003-025140.log (dev-libs:argtable-2.13-r2:20221003-025140.log,11.60 KB, text/plain)
2022-10-03 08:10 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,54.44 KB, text/plain)
2022-10-03 08:10 UTC, Toralf Förster
Details
environment (environment,26.64 KB, text/plain)
2022-10-03 08:10 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,9.65 KB, application/x-bzip)
2022-10-03 08:10 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,7.01 KB, application/x-bzip)
2022-10-03 08:10 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,11.12 KB, application/x-bzip)
2022-10-03 08:10 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-10-03 08:10:00 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -pipe -march=native -fno-diagnostics-color -O2 -Werror=implicit-function-declaration -Werror=implicit-int -c arg_int.c  -fPIC -DPIC -o .libs/arg_int.o
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -pipe -march=native -fno-diagnostics-color -O2 -Werror=implicit-function-declaration -Werror=implicit-int -c arg_dbl.c  -fPIC -DPIC -o .libs/arg_dbl.o
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -pipe -march=native -fno-diagnostics-color -O2 -Werror=implicit-function-declaration -Werror=implicit-int -c arg_str.c  -fPIC -DPIC -o .libs/arg_str.o
arg_int.c: In function strtol0X:
arg_int.c:60:12: error: implicit declaration of function isspace [-Werror=implicit-function-declaration]
   60 |     while (isspace(*ptr))
      |            ^~~~~~~

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_systemd-j4-20221002-182017

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-12.2.0 *
clang/llvm (if any):
clang version 15.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
/usr/lib/llvm/15
15.0.1
Python 3.10.7
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.64.0 *
The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
GNU Make 4.3

  HEAD of ::gentoo
commit 90239ddd9daa9a696e92219d9b544568f639fc5e
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Mon Oct 3 02:31:52 2022 +0000

    2022-10-03 02:31:51 UTC

emerge -qpvO dev-libs/argtable
[ebuild  N    ] dev-libs/argtable-2.13-r2  USE="-debug -doc -examples -static-libs"
Comment 1 Toralf Förster gentoo-dev 2022-10-03 08:10:01 UTC
Created attachment 817042 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-10-03 08:10:02 UTC
Created attachment 817045 [details]
dev-libs:argtable-2.13-r2:20221003-025140.log
Comment 3 Toralf Förster gentoo-dev 2022-10-03 08:10:03 UTC
Created attachment 817048 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2022-10-03 08:10:04 UTC
Created attachment 817051 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2022-10-03 08:10:05 UTC
Created attachment 817054 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-10-03 08:10:06 UTC
Created attachment 817057 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2022-10-03 08:10:08 UTC
Created attachment 817060 [details]
temp.tar.bz2
Comment 8 Ionen Wolkens gentoo-dev 2022-10-21 14:25:06 UTC

*** This bug has been marked as a duplicate of bug 871231 ***