Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 872587 - dev-ml/opam-format-2.1.2-r1 fails tests
Summary: dev-ml/opam-format-2.1.2-r1 fails tests
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Team for the ML programming language family
Depends on:
Reported: 2022-09-24 03:09 UTC by Jonathan Lovelace
Modified: 2022-09-24 21:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

dev-ml:opam-format-2.1.2-r1:20220924-004251.log (dev-ml:opam-format-2.1.2-r1:20220924-004251.log,160.94 KB, text/x-log)
2022-09-24 03:09 UTC, Jonathan Lovelace
dev-ml:opam-format-2.1.2-r1:20220924-030210.log (dev-ml:opam-format-2.1.2-r1:20220924-030210.log,44.14 KB, text/x-log)
2022-09-24 03:20 UTC, Jonathan Lovelace
emerge-info.txt (emerge-info.txt,8.21 KB, text/plain)
2022-09-24 03:20 UTC, Jonathan Lovelace

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2022-09-24 03:09:32 UTC
Created attachment 813907 [details]

=dev-ml/opam-format-2.1.2-r1 fails its tests for me. Early in the diff showing each failure, I note that in the "actual" output, there was the line "bwrap: setting up uid map: Permission denied". Before that, in the part of the log that's hard to search in "less" because of the control characters, there's this:

[ERROR] Sandboxing is not working on your platform gentoo:
        build sh -c echo SUCCESS >$TMPDIR/opam-sandbox-check-out && cat $TMPDIR/opam-sandbox-check-out;
        rm -f $TMPDIR/opam-sandbox-check-out" exited with code 1 "bwrap: setting up uid map: Permission

I tried running without FEATURES=userpriv, which added lots of failures because of warnings about running the testsuite as root, as well as one message from bwrap about failing to mkdir /proc (in a sandboxed environment, I presume).

Then I tried running without FEATURES=sandbox and FEATURES=usersandbox, and while tests still failed it looks like mostly tests that try to fetch test data from Github. I'll attach that build log as well.
Comment 1 Jonathan Lovelace 2022-09-24 03:20:24 UTC
Created attachment 813910 [details]
Comment 2 Jonathan Lovelace 2022-09-24 03:20:49 UTC
Created attachment 813913 [details]
Comment 3 Jonathan Lovelace 2022-09-24 18:32:47 UTC
I just noticed bug #838658; that may be the cause of the tests failing when the sandbox is enabled.