Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 871288 - net-nds/openldap-2.6.3 - configure: error: broken POSIX regex!
Summary: net-nds/openldap-2.6.3 - configure: error: broken POSIX regex!
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
: 881955 (view as bug list)
Depends on:
Blocks: clang-16-porting
  Show dependency tree
 
Reported: 2022-09-18 10:51 UTC by Toralf Förster
Modified: 2022-11-28 11:12 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.98 KB, text/plain)
2022-09-18 10:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,98.48 KB, text/plain)
2022-09-18 10:51 UTC, Toralf Förster
Details
environment (environment,148.98 KB, text/plain)
2022-09-18 10:51 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,13.19 KB, application/x-bzip)
2022-09-18 10:51 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,11.71 KB, application/x-bzip)
2022-09-18 10:51 UTC, Toralf Förster
Details
net-nds:openldap-2.6.3:20220918-103518.log (net-nds:openldap-2.6.3:20220918-103518.log,15.35 KB, text/plain)
2022-09-18 10:51 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,43.21 KB, application/x-bzip)
2022-09-18 10:51 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-09-18 10:51:28 UTC
checking non-posix strerror_r... no
checking for regex.h... yes
checking for library containing regfree... none required
checking for compatible POSIX regex... no
configure: error: broken POSIX regex!

!!! Please attach the following file when seeking support:

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-j4-20220917-070004

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-12.2.0 *
clang/llvm (if any):
clang version 15.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/15/bin
/usr/lib/llvm/15
15.0.0
Python 3.10.7
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-bin-1.63.0 *
The following VMs are available for generation-2:
1)	Eclipse Temurin JDK 11.0.16.1_p1 [openjdk-bin-11]
*)	Eclipse Temurin JDK 17.0.4.1_p1 [openjdk-bin-17]
3)	Eclipse Temurin JDK 8.345_p01 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8 
  [2]   openjdk-bin-11 
  [3]   openjdk-bin-17  system-vm

The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
GNU Make 4.3

  HEAD of ::gentoo
commit 242cd1a84f2a8e702a79f513d0ae26ce7648d849
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sun Sep 18 09:46:48 2022 +0000

    2022-09-18 09:46:48 UTC

emerge -qpvO net-nds/openldap
[ebuild  N    ] net-nds/openldap-2.6.3  USE="cleartext crypt ipv6 ssl syslog -argon2 -autoca -cxx -debug -experimental -gnutls -iodbc -kerberos -kinit -minimal -odbc -overlays -pbkdf2 -perl -samba -sasl (-selinux) -sha2 -smbkrb5passwd -static-libs -systemd -tcpd -test" ABI_X86="(64) -32 (-x32)"
Comment 1 Toralf Förster gentoo-dev 2022-09-18 10:51:29 UTC
Created attachment 811000 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-09-18 10:51:31 UTC
Created attachment 811003 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2022-09-18 10:51:32 UTC
Created attachment 811009 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-09-18 10:51:33 UTC
Created attachment 811012 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-09-18 10:51:34 UTC
Created attachment 811015 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-09-18 10:51:35 UTC
Created attachment 811018 [details]
net-nds:openldap-2.6.3:20220918-103518.log
Comment 7 Toralf Förster gentoo-dev 2022-09-18 10:51:36 UTC
Created attachment 811021 [details]
temp.tar.bz2
Comment 8 hugegameartgd 2022-10-17 12:37:59 UTC
Seems to be a clang 16 issue https://bugs.gentoo.org/870412

I can reproduce the configure error (x86_64-gentoo-linux-musl) which is fixed after adding "-Wno-implicit-int" flag to make.conf
Comment 9 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-11-19 08:39:27 UTC
*** Bug 881955 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2022-11-24 11:27:27 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d4d1d9ed527058cf86b22407cc492944f9b1e6e5

commit d4d1d9ed527058cf86b22407cc492944f9b1e6e5
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-11-24 11:17:03 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-11-24 11:25:33 +0000

    net-nds/openldap: fix configure+build w/ clang 16
    
    This affects the macro which ntp bundles too.
    
    Closes: https://bugs.gentoo.org/871288
    Bug: https://bugs.gentoo.org/871372
    Bug: https://bugs.gentoo.org/882183
    Signed-off-by: Sam James <sam@gentoo.org>

 .../openldap/files/openldap-2.6.3-clang16.patch    | 139 ++++
 net-nds/openldap/openldap-2.6.3-r1.ebuild          | 797 +++++++++++++++++++++
 2 files changed, 936 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2a7bf0374fbbec07e09c5c977e994939c6b79008

commit 2a7bf0374fbbec07e09c5c977e994939c6b79008
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-11-24 11:25:27 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-11-24 11:25:33 +0000

    net-misc/ntp: fix configure w/ clang 16
    
    Refresh OpenLDAP macro & use patched variant from Arsen (bug 871288).
    
    Closes: https://bugs.gentoo.org/871372
    Bug: https://bugs.gentoo.org/871288
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/ntp-4.2.8_p15-configure-clang16.patch    | 582 +++++++++++++++++++++
 net-misc/ntp/ntp-4.2.8_p15-r2.ebuild               | 144 +++++
 2 files changed, 726 insertions(+)
Comment 11 Larry the Git Cow gentoo-dev 2022-11-25 07:05:48 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a87f975e56106632436903be3e94e2f272d9269d

commit a87f975e56106632436903be3e94e2f272d9269d
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-11-25 06:59:15 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-11-25 07:05:07 +0000

    net-nds/openldap: fix configure+build w/ clang 16 deux
    
    The previous patch wasn't enough on some systems.
    
    This affects the macro which ntp bundles too.
    
    Closes: https://bugs.gentoo.org/871288
    Bug: https://bugs.gentoo.org/871372
    Bug: https://bugs.gentoo.org/882183
    Fixes: d4d1d9ed527058cf86b22407cc492944f9b1e6e5
    Signed-off-by: Sam James <sam@gentoo.org>

 .../openldap/files/openldap-2.6.3-clang16.patch    | 48 ++++++++++++++++++----
 ...ap-2.6.3-r1.ebuild => openldap-2.6.3-r2.ebuild} |  0
 2 files changed, 39 insertions(+), 9 deletions(-)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4480ce48447af4d8b6e35ca61f494f91698d5fe6

commit 4480ce48447af4d8b6e35ca61f494f91698d5fe6
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-11-25 07:04:24 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-11-25 07:05:08 +0000

    net-misc/ntp: fix configure w/ clang 16 deux
    
    Refresh OpenLDAP macro & use patched variant from Arsen (bug 871288).
    
    Closes: https://bugs.gentoo.org/871372
    Bug: https://bugs.gentoo.org/871288
    See: 2a7bf0374fbbec07e09c5c977e994939c6b79008
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/ntp-4.2.8_p15-configure-clang16.patch    | 80 ++++++++++++----------
 ...4.2.8_p15-r2.ebuild => ntp-4.2.8_p15-r3.ebuild} |  0
 2 files changed, 45 insertions(+), 35 deletions(-)