Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87103 - ipw2200 module on livecd fails to locate firmware
Summary: ipw2200 module on livecd fails to locate firmware
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 90440 (view as bug list)
Depends on:
Blocks: udev-meta
  Show dependency tree
 
Reported: 2005-03-29 05:47 UTC by Bharath Ramesh
Modified: 2010-12-01 15:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gkrellm window screenshot after gkrellm disappears (,2.38 KB, image/jpeg)
2005-05-25 20:33 UTC, Bharath Ramesh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bharath Ramesh 2005-03-29 05:47:29 UTC
I just booted of the Gentoo 2005.0 x86 Universal Livecd. Everytime ipw2200 module doesnt find the firmware on boot. I have rmmod and modprobe it again for it to find the firmware.

Reproducible: Always
Steps to Reproduce:
1.Boot of the 2005.0 x86 Universal LiveCD
2.
3.

Actual Results:  
ipw2200 module fails to locate firmware

Expected Results:  
Firmware should be located and device should be created
Comment 1 Kevin Jordan 2005-03-29 22:38:15 UTC
Portage seems to carry a different tgz than the one on the ipw2200 site, so the patch failed for me with the one portage downloaded.  Downloading the one from the ipw2200 site and redigesting and applying the patch works for me.
Comment 2 Anthony Fielding 2005-04-07 14:02:01 UTC
I believe this is because /usr/lib/hotplug/firmware/firmware is a symlink to /lib/firmware. It should be /usr/lib/hotplug/firmware linking to /lib/firmware, not /usr/lib/hotplug/firmware/firmware.
Comment 3 Henrik Brix Andersen 2005-04-25 15:27:15 UTC
Doubt that is the reason - looks like a duplicate of bug #90440 to me. Reporter, please see if the tip mentioned there fixes this issue for you.
Comment 4 Bharath Ramesh 2005-04-26 11:53:50 UTC
Just by doing an rmmod and modprobe of ipw2200 fixes the problem, I didnt need to modify or add timeout value in /sys/class/firmware.
Comment 5 Henrik Brix Andersen 2005-04-26 11:56:23 UTC
Perhaps hotplug is run before the firmware directory is mounted?
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2005-05-11 05:22:05 UTC
Hotplug is run after the mounts, which occur before runlevel default.  I honestly think that Anthony was right RE: comment #2 here.  I fixed the issue where the firmware was showing up in the wrong place in catalyst, so this should be resolved for the next release, however, we will need testers to find out if this is the case.
Comment 7 Henrik Brix Andersen 2005-05-11 05:25:54 UTC
/usr/lib/hotplug/firmware is not used by >=sys-apps/hotplug-20040923. The new location is /lib/firmware. Why is the symlink even there?
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2005-05-11 05:40:31 UTC
Because there were module ebuilds that had not been updated at the time of the release...
Comment 9 Bharath Ramesh 2005-05-25 20:33:20 UTC
Created attachment 59844 [details]
gkrellm window screenshot after gkrellm disappears
Comment 10 Bharath Ramesh 2005-05-25 20:33:59 UTC
Comment on attachment 59844 [details]
gkrellm window screenshot after gkrellm disappears

sorry wrong bug report
Comment 11 nefercheprure 2005-08-13 02:02:17 UTC
It seems to me that the bug #90440 is indeed related to this bug, if not identical.
Comment 12 Chris Gianelloni (RETIRED) gentoo-dev 2005-08-15 11:38:28 UTC
*** Bug 90440 has been marked as a duplicate of this bug. ***
Comment 13 Mike Doty (RETIRED) gentoo-dev 2005-10-11 10:35:42 UTC
(In reply to comment #4)
> Just by doing an rmmod and modprobe of ipw2200 fixes the problem, I didnt need
to modify or add timeout value in /sys/class/firmware.

I can confirm this. reinserting the module solves the problem.
Comment 14 lzap 2005-12-14 15:44:08 UTC
Is it bug in ipw module or here? Do you need some testing?
Comment 15 Henrik Brix Andersen 2006-01-06 04:30:02 UTC
Hopefully this is fixed in the newly added net-wireless/ipw2200-1.0.9. It contains a work-around for a firmware loading race.
Comment 16 Wout Snijders 2006-02-20 01:54:44 UTC
I seemed to have the same problem after installing kernel 2.6.15 r1
The text underneath solved the problem for me:

quoting from http://www.openthought.org/blosxom.cgi/Blog/Computers/Organizations/

So, instead of compiling 'firmware_helper' as I had initially suggested above (which doesn't seem to work anymore anyways), just create the file '/etc/udev/rules.d/999-firmware.rules', and add the following line in it:

ACTION=="add", SUBSYSTEM=="firmware", RUN+="/sbin/udev_run_hotplugd"
Then rmmod ipw2200 and the ieee80211* modules, insmod ipw2200, and you should be good to go.

Good luck!

Mostly to help Google catch this, the new error I was received was:


ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.8
ipw2200: Copyright(c) 2003-2005 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Unable to load ucode: -62
ipw2200: Unable to load firmware: -62
ipw2200: failed to register network device
ipw2200: probe of 0000:03:03.0 failed with error -5
Comment 17 Henrik Brix Andersen 2006-03-10 02:22:44 UTC
This problem is still present with the 2006.0 release media. Still, the problem can be worked around by doing a "modprobe -r ipw2200; modprobe ipw2200" after boot up.

According to the ipw2200 driver log messages, the firmware files can not be found when it first attempts to load them (-2 = -ENOENT = "No such file or directory"). I still suspect that /lib/firmware/ipw*.fw is not present when the ipw2200 module is first loaded...

On a side note: the kernel used on the 2006.0 release media contains version 1.0.8 of the ipw2200 driver, which doesn't include the firmware loading race fix found in 1.0.9 and later versions - but seeing that the driver says -ENOENT and not -EIO, I don't think the race is the main issue here.
Comment 18 Aaron Stone 2006-06-26 14:02:14 UTC
Perhaps should be its own bug, but I think the udev package ought to include the lines found at the link below, as well as in the comments here.

http://www.openthought.org/blosxom.cgi/2006/02/13

I've added a /etc/udev/rules.d/99-firmware.rules with the one-liner and now, finally, my ipw2200 works without a hitch. Huzzah! Could we get this into the udev package?
Comment 19 Chris Gianelloni (RETIRED) gentoo-dev 2006-06-26 15:06:43 UTC
Please file a bug for the firmware thing separately,  It really should be fixed in upstream udev, abd our udev maintainer is also one of the main udev developers.

Thanks
Comment 20 Chris Gianelloni (RETIRED) gentoo-dev 2006-09-01 14:22:40 UTC
Can anyone verify this with 2006.1?
Comment 21 Anton Bolshakov 2006-11-02 15:26:01 UTC
it still fails with 2006.1.
dmesg says: 'unable to load firmware' code= -2
However if you 'rmmod ipw2200' and 'modprobe ipw2200' it can find firwmare and works fine after that.
Comment 22 Antti Mäkelä 2006-11-27 05:46:34 UTC
This happens with udev 103, the recently stabilized one as well. 
Comment 23 Antti Mäkelä 2006-11-27 06:02:24 UTC
Ok, seems to work for udev-103 now when

First, I downgraded back to udev-094, and then

CONFIG_PROTECT="-*" emerge udev

It seems that when udev upgrades, some junk from the previous configuration gets left behind. Downgrading and then upgrading with configprotects removed fixed the issue.
Comment 24 Jakub Moc (RETIRED) gentoo-dev 2007-01-15 11:35:30 UTC
(In reply to Comment #21, Comment #22)

Unmerge hotplug; if it fixes the problem, move to Bug 147006...
Comment 25 Antti Mäkelä 2007-01-15 14:00:39 UTC
(In reply to comment #24)
> (In reply to Comment #21, Comment #22)
> Unmerge hotplug; if it fixes the problem, move to Bug 147006...

Unmerging hotplug did not help - only after steps in #23 things started to work.
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2007-01-26 11:12:40 UTC
We should probably get some of the recent udev versions stabilized quickly (104-r3?) and included on release media, it fixes quite a bunch of bugs...
Comment 27 Andrew Gaffney (RETIRED) gentoo-dev 2007-05-10 15:22:31 UTC
Is this still an issue with 2007.0?
Comment 28 FieldySnuts 2007-05-10 16:22:24 UTC
I tried with the i686 livedvd on my IBM Thinkpad T43, with an Intel Pro Wireless 2915 A/B/G.

The firmware loaded fine. However, the device did not show up as a network interface at all. ipconfig -a did not show it (it usually shows up as eth1), nor did iwconfig.

There were no errors, including in kernel logs. In fact it all looked quite normal.

I had to manually modprobe -rav ipw2200 and then modprobe ipw2200 to get this device to work. It then behaved as expected: Showing up as eth1 in both ifconfig and ipconfig. There were no firmware loading errors.

I did not test if it actually worked as I am having major problems with my access point.

So, it seems to work but most users are not going to know to remove the modules then re-add them.
Comment 29 FieldySnuts 2007-05-10 16:23:37 UTC
Meh. s/ipconfig/ifconfig .

Also, before I unloaded and reloaded the modules, the card did show up in lspci.
Comment 30 Andrew Gaffney (RETIRED) gentoo-dev 2007-05-10 16:26:18 UTC
The card would show up in lspci whether there are drivers loaded or not.
Comment 31 Chris Gianelloni (RETIRED) gentoo-dev 2008-04-12 17:27:16 UTC
OK, we've switched to the in-kernel modules for 2008.0.  Has anyone tried 2008.0 Beta 1 on their machine with this card?
Comment 32 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-13 00:43:29 UTC
Can someone test this with 2008.0 final?
Comment 33 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-12-01 15:51:41 UTC
I'm closing this bug as we've been waiting for feedback for over 2 years now.

If you can reproduce this bug with the latest available weekly ISO, feel free to reopen the bug.