Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 870544 - net-libs/libsearpc-3.3.0:0 - searpc-demo-packet.h: error: implicit declaration of function write
Summary: net-libs/libsearpc-3.3.0:0 - searpc-demo-packet.h: error: implicit declaratio...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Quentin Retornaz
URL:
Whiteboard:
Keywords: PullRequest
: 870658 882317 (view as bug list)
Depends on:
Blocks: c99-porting, clang-16-porting
  Show dependency tree
 
Reported: 2022-09-16 19:40 UTC by Toralf Förster
Modified: 2023-04-14 00:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,19.41 KB, text/plain)
2022-09-16 19:40 UTC, Toralf Förster
Details
emerge-history.txt.bz2 (emerge-history.txt.bz2,68.75 KB, application/x-bzip)
2022-09-16 19:40 UTC, Toralf Förster
Details
environment (environment,110.40 KB, text/plain)
2022-09-16 19:40 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,31.31 KB, application/x-bzip)
2022-09-16 19:40 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,7.38 KB, application/x-bzip)
2022-09-16 19:40 UTC, Toralf Förster
Details
net-libs:libsearpc-3.2.0_p1:20220916-183908.log (net-libs:libsearpc-3.2.0_p1:20220916-183908.log,21.60 KB, text/plain)
2022-09-16 19:40 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,32.07 KB, application/x-bzip)
2022-09-16 19:40 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-09-16 19:40:33 UTC
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..    -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include -I../lib -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int -c -o searpc-demo-client.o searpc-demo-client.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..    -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include -I../lib -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int -c -o demo-async-client.o demo-async-client.c
In file included from demo-async-client.c:10:
searpc-demo-packet.h: In function writen:
searpc-demo-packet.h:40:34: error: implicit declaration of function write; did you mean writen? [-Werror=implicit-function-declaration]
   40 |                 if ( (nwritten = write(fd, ptr, nleft)) <= 0) {
      |                                  ^~~~~

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-j4-20220913-110042

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.1
 [2] x86_64-pc-linux-gnu-12.2.1 *
clang/llvm (if any):
Python 3.10.7
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby31 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.63.0 *
The following VMs are available for generation-2:
1)	Eclipse Temurin JDK 11.0.16.1_p1 [openjdk-bin-11]
2)	Eclipse Temurin JDK 17.0.4.1_p1 [openjdk-bin-17]
*)	Eclipse Temurin JDK 8.345_p01 [openjdk-bin-8]
4)	Eclipse Temurin JRE 17.0.4.1_p1 [openjdk-jre-bin-17]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm
  [2]   openjdk-bin-11 
  [3]   openjdk-bin-17 
  [4]   openjdk-jre-bin-17 

The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
GNU Make 4.3.90

  HEAD of ::gentoo
commit e5cd60aa15289f27c42e8230065d3f4c599234a6
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Fri Sep 16 17:46:46 2022 +0000

    2022-09-16 17:46:45 UTC

emerge -qpvO net-libs/libsearpc
[ebuild  N    ] net-libs/libsearpc-3.2.0_p1  PYTHON_SINGLE_TARGET="python3_10 -python3_8 -python3_9"
Comment 1 Toralf Förster gentoo-dev 2022-09-16 19:40:34 UTC
Created attachment 806539 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-09-16 19:40:35 UTC
Created attachment 806542 [details]
emerge-history.txt.bz2
Comment 3 Toralf Förster gentoo-dev 2022-09-16 19:40:37 UTC
Created attachment 806545 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-09-16 19:40:38 UTC
Created attachment 806548 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-09-16 19:40:39 UTC
Created attachment 806551 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-09-16 19:40:40 UTC
Created attachment 806554 [details]
net-libs:libsearpc-3.2.0_p1:20220916-183908.log
Comment 7 Toralf Förster gentoo-dev 2022-09-16 19:40:41 UTC
Created attachment 806557 [details]
temp.tar.bz2
Comment 8 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-11-20 21:17:02 UTC
*** Bug 870658 has been marked as a duplicate of this bug. ***
Comment 9 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-11-20 21:17:09 UTC
*** Bug 882317 has been marked as a duplicate of this bug. ***
Comment 10 Agostino Sarubbo gentoo-dev 2022-12-13 15:35:25 UTC
clang-stricter_tinderbox has reproduced this issue with version 3.3.0 - Updating summary.
Comment 11 Larry the Git Cow gentoo-dev 2023-04-14 00:49:31 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c208bef9e8d9413ef1a57d7541aa4f755b8078c0

commit c208bef9e8d9413ef1a57d7541aa4f755b8078c0
Author:     orbea <orbea@riseup.net>
AuthorDate: 2023-04-09 00:37:10 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2023-04-14 00:48:05 +0000

    net-libs/libsearpc: Fix the build with clang-16
    
    Closes: https://bugs.gentoo.org/870544
    Upstream-PR: https://github.com/haiwen/libsearpc/pull/63
    Signed-off-by: orbea <orbea@riseup.net>
    Closes: https://github.com/gentoo/gentoo/pull/30525
    Signed-off-by: Sam James <sam@gentoo.org>

 .../libsearpc/files/libsearpc-3.3.0-clang16.patch  | 164 +++++++++++++++++++++
 ...arpc-3.3.0.ebuild => libsearpc-3.3.0-r1.ebuild} |   4 +
 2 files changed, 168 insertions(+)